<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-71235901-1', 'auto');
  ga('send', 'pageview');

</script>
<meta name="google-site-verification" content="PuHJs7y90OgOH37jomlyBr-hu1ME7p4zbt8O9C7X8ng"/>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://www.2daygeek.com/xmlrpc.php">
<title>bmon - Real Time Bandwidth Monitor in Linux | 2daygeek</title>
<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>
 
<link rel="author" href="https://plus.google.com/+2daygeeks"/>
<meta name="description" content="2daygeek.com Linux Tips, Tricks & News Today ! bmon - Real Time Bandwidth Monitor and Rate Estimator in Linux."/>
<meta name="keywords" content="bandwidth monitoring tool,bmon,network traffic monitoring tool,network analyzer,rate estimator"/>
<link rel="canonical" href="http://www.2daygeek.com/bmon-real-time-bandwidth-monitoring-tool-linux/"/>
 
<link rel='dns-prefetch' href='//connect.facebook.net'/>
<link rel='dns-prefetch' href='//platform.twitter.com'/>
<link rel='dns-prefetch' href='//apis.google.com'/>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="2daygeek &raquo; Feed" href="http://www.2daygeek.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="2daygeek &raquo; Comments Feed" href="http://www.2daygeek.com/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="2daygeek &raquo; bmon &#8211; Real Time Bandwidth Monitor and Rate Estimator in Linux Comments Feed" href="http://www.2daygeek.com/bmon-real-time-bandwidth-monitoring-tool-linux/feed/"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.2daygeek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='spu-css-css' href='http://www.2daygeek.com/wp-content/plugins/social-popup/spu.css?ver=1.6.4.3' type='text/css' media='all'/>
<link rel='stylesheet' id='font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all'/>
<link rel='stylesheet' id='arconix-shortcodes-css' href='http://www.2daygeek.com/wp-content/plugins/arconix-shortcodes/includes/css/arconix-shortcodes.min.css?ver=2.0.4' type='text/css' media='all'/>
<link rel='stylesheet' id='gglcptch-css' href='http://www.2daygeek.com/wp-content/plugins/google-captcha/css/gglcptch.css?ver=1.27' type='text/css' media='all'/>
<link rel='stylesheet' id='hueman-main-style-css' href='http://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/main.min.css?ver=3.3.2' type='text/css' media='all'/>
<link rel='stylesheet' id='theme-stylesheet-css' href='http://www.2daygeek.com/wp-content/themes/my-child-theme/style.css?ver=3.3.2' type='text/css' media='all'/>
<link rel='stylesheet' id='hueman-font-awesome-css' href='http://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/font-awesome.min.css?ver=3.3.2' type='text/css' media='all'/>
<link rel='stylesheet' id='tablepress-default-css' href='http://www.2daygeek.com/wp-content/tablepress-combined.min.css?ver=9' type='text/css' media='all'/>
<script type='text/javascript' src='http://www.2daygeek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://connect.facebook.net/en_US/all.js?ver=1.6.4.3#xfbml=1'></script>
<script type='text/javascript' src='http://platform.twitter.com/widgets.js?ver=1.6.4.3'></script>
<script type='text/javascript' src='https://apis.google.com/js/plusone.js?ver=1.6.4.3'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/social-popup/spu.js?ver=1.6.4.3'></script>
<link rel='https://api.w.org/' href='http://www.2daygeek.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.2daygeek.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.2daygeek.com/wp-includes/wlwmanifest.xml"/>
<link rel='prev' title='lnav &#8211; An Advanced Console Based Log File Viewer for Linux' href='http://www.2daygeek.com/install-and-use-advanced-log-file-viewer-navigator-lnav-in-linux/'/>
<meta name="generator" content="WordPress 4.7.2"/>
<link rel='shortlink' href='http://www.2daygeek.com/?p=13248'/>
<link rel="alternate" type="application/json+oembed" href="http://www.2daygeek.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.2daygeek.com%2Fbmon-real-time-bandwidth-monitoring-tool-linux%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.2daygeek.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.2daygeek.com%2Fbmon-real-time-bandwidth-monitoring-tool-linux%2F&#038;format=xml"/>
<script type="text/javascript" id="ha-customize-btn">
              jQuery( function($) {
                  $( "#wp-admin-bar-customize").find('a').attr('title', 'Customize this page !' );
              });
            </script>
<style type="text/css" id="ha-fun-ab">@-webkit-keyframes super-rainbow{0%{text-shadow:0px 0px 2px;}20%{text-shadow:0px 0px 5px;}40%{text-shadow:0px 0px 10px;}60%{text-shadow:0px 0px 13px}80%{text-shadow:0px 0px 10px;}100%{text-shadow:0px 0px 5px;}}@-moz-keyframes super-rainbow{0%{text-shadow:0px 0px 2px;}20%{text-shadow:0px 0px 5px;}40%{text-shadow:0px 0px 10px;}60%{text-shadow:0px 0px 13px}80%{text-shadow:0px 0px 10px;}100%{text-shadow:0px 0px 5px;}}#wp-admin-bar-customize .ab-item:before{color:#7ECEFD;-webkit-animation:super-rainbow 4s infinite linear;-moz-animation:super-rainbow 4s infinite linear;}</style>
<style type="text/css">.spu-button{margin-left:15px;margin-left:15px;display:inline-table;margin-top:12px;vertical-align:middle;}#spu-msg-cont{border-bottom:1px solid#ccc;border-top:1px solid#ccc;background-image:linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);background-image:-o-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);background-image:-moz-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);background-image:-webkit-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);background-image:-ms-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);background-image:-webkit-gradient(linear,left bottom,left top,color-stop(0,#D8E7FC),color-stop(0.85,#EBF2FC));padding:16px;}#spu-msg{margin:0 0 22px;}.step-clear{clear:both!important;}#spu-title{font-family:'Lucida Sans Unicode,Lucida Grande,sans-serif!important;
	font-size:12px;
	padding:12px 0 9px 10px;
	font-size:16px;
}					</style>			
					<script type="text/javascript">
						jQuery(document).ready(function($){
								
						setTimeout( 
						function(){				
							socialPopUP({
								// Configure display of popup
								advancedClose: true,
								opacity: "0.65",
								s_to_close: "0",
								days_no_click: "99",
								segundos : "seconds",
								esperar : "Wait",
								thanks_msg : "Thanks for supporting our site!!!",
								thanks_sec : "3",
							})
						}
							,1000								);
						});	
						
						
					</script>
					
	<!--[if lt IE 9]>
<script src="http://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js"></script>
<script src="http://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js"></script>
<![endif]-->
<style type="text/css">
/* Dynamic CSS: For no styles in head, copy and put the css below in your child theme' s style.css,disable dynamic styles */

.search-expand,
#nav-topbar.nav-container { background-color: #3b8dbd; }@media only screen and (min-width: 720px) {#nav-topbar .nav ul{background-color:#3b8dbd;}}#nav-header.nav-container{background-color:#fa720e;}@media only screen and (min-width: 720px) {#nav-header .nav ul{background-color:#fa720e;}}img{-webkit-border-radius:2px;border-radius:2px;}body{background-color:#eaeaea;}</style>
</head>
<body class="post-template-default single single-post postid-13248 single-format-standard wp-custom-logo col-2cl full-width topbar-enabled unknown">
<div id="wrapper">
<header id="header">
<nav class="nav-container group" id="nav-topbar">
<div class="nav-toggle"><i class="fa fa-bars"></i></div>
<div class="nav-text"> </div>
<div class="nav-wrap container"><ul id="menu-menu-1" class="nav container-inner group"><li id="menu-item-293" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-293"><a href="http://www.2daygeek.com/">HOME</a></li>
<li id="menu-item-10920" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10920"><a href="http://linuxnews.2daygeek.com/">LINUX NEWS</a></li>
<li id="menu-item-294" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294"><a href="http://www.2daygeek.com/about-us/">ABOUT US</a></li>
<li id="menu-item-295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295"><a href="http://www.2daygeek.com/contact-us/">CONTACT US</a></li>
<li id="menu-item-296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-296"><a href="http://www.2daygeek.com/disclaimer/">DISCLAIMER</a></li>
<li id="menu-item-3676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3676"><a href="http://www.2daygeek.com/privacy-policy/">PRIVACY POLICY</a></li>
<li id="menu-item-2729" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2729"><a href="http://www.2daygeek.com/support-us/">SUPPORT US</a></li>
<li id="menu-item-8366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8366"><a href="http://www.2daygeek.com/category/os-tweaks/">OS TWEAK</a></li>
<li id="menu-item-12012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12012"><a href="http://www.2daygeek.com/category/icon-theme/">ICONS</a></li>
<li id="menu-item-12013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12013"><a href="http://www.2daygeek.com/category/gtk-theme/">THEMES</a></li>
</ul></div>
<div class="container">
<div class="container-inner">
<div class="toggle-search"><i class="fa fa-search"></i></div>
<div class="search-expand">
<div class="search-expand-inner">
<form method="get" class="searchform themeform" action="http://www.2daygeek.com/">
<div>
<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter"/>
</div>
</form> </div>
</div>
</div> 
</div> 
</nav>  <div class="container group">
<div class="container-inner">
<div class="group pad">
<p class="site-title"><a class="custom-logo-link" href="http://www.2daygeek.com/" rel="home"><img src="http://www.2daygeek.com/wp-content/uploads/2015/12/2day-geek-new-logo-final.png" alt="2daygeek"></a></p>
<p class="site-description"></p>
<div id="header-widgets">
<div style="float:left;border:solid 0px;height:90px;width:728px;"><script id="mNCC" language="javascript">
   medianet_width = "728";
   medianet_height = "90";
   medianet_crid = "847533357";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUF666N9' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div>
<script type="text/javascript" src="https://stacksocial-production-stacksocial.netdna-ssl.com/assets/dealOfTheDay.js"></script><script type="text/javascript">ss_DealOfTheDay.addUrlParam("aid=a-4s5jc8po");</script>
</div> 
</div>
<nav class="nav-container group" id="nav-header">
<div class="nav-toggle"><i class="fa fa-bars"></i></div>
<div class="nav-text"> </div>
<div class="nav-wrap container">
<ul id="menu-menu-2" class="nav container-inner group"><li id="menu-item-6808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6808"><a href="http://www.2daygeek.com/category/linux-distributions/">LINUX DISTRO&#8217;S</a></li>
<li id="menu-item-6806" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6806"><a href="http://www.2daygeek.com/category/linux-commands/">LINUX COMMAND&#8217;S</a></li>
<li id="menu-item-9582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9582"><a href="http://www.2daygeek.com/category/webserver/">WEBSERVER</a></li>
<li id="menu-item-6809" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6809"><a href="http://www.2daygeek.com/category/monitoring-tools/">MONITORING TOOLS</a></li>
<li id="menu-item-6883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6883"><a href="http://www.2daygeek.com/category/package-management/">PACKAGE MANAGEMENT</a></li>
<li id="menu-item-6811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6811"><a href="http://www.2daygeek.com/category/repository/">REPOSITORY</a></li>
<li id="menu-item-6986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6986"><a href="http://www.2daygeek.com/category/free-cloud-storage/">FREE CLOUD STORAGE</a></li>
<li id="menu-item-6810" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6810"><a href="http://www.2daygeek.com/category/owncloud/">OWNCLOUD</a></li>
</ul> </div>
</nav> 
</div> 
</div> 
</header> 
<div class="container" id="page">
<div class="container-inner">
<div class="main">
<div class="main-inner group">
<section class="content">
<div class="page-title pad group">
<ul class="meta-single group">
<li class="category"><a href="http://www.2daygeek.com/category/monitoring-tools/" rel="category tag">monitoring-tools</a></li>
</ul>
</div> 
<div class="pad group">
<article class="post-13248 post type-post status-publish format-standard has-post-thumbnail hentry category-monitoring-tools tag-bandwidth-monitoring-tool tag-bmon tag-network-analyzer tag-network-traffic-monitoring-tool tag-rate-estimator">
<div class="post-inner group">
<h1 class="post-title entry-title">bmon &#8211; Real Time Bandwidth Monitor and Rate Estimator in Linux</h1>
<p class="post-byline">by <span class="vcard author">
<span class="fn"><a href="http://www.2daygeek.com/author/magesh/" title="Posts by Magesh Maruthamuthu" rel="author">Magesh Maruthamuthu</a></span>
</span> &middot;
<span class="published">Published : February 2, 2017 || Last Updated: February 1, 2017</span>
</p>
<div class="clear"></div>
<div class="entry themeform">
<div class="entry-inner">
 
<div style="float:left;margin:10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="8826511175"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>As we already know about Bandwidth because we all are in smartphone world and using 3G &#038; 4G, and fiber optic-based Internet for home use. We don&#8217;t know how its gone (I mean bandwidth usage/utilization) and any leakage happened.</p>
<p>Bandwidth leakage will result a slow response from running application over the network. So carefully monitor bandwidth spikes to avoid the unnecessary leakage. <a href="https://github.com/tgraf/bmon" target="_blank">bmon</a> stands for Bandwidth monitoring tool which used to monitor and debug networking related issues. It capture real-time bandwidth usage and supports various input methods for different architectures.</p>
<p>It features various output methods like HTML output, ASCII output, graph, interactive curses user interface and a programmable text output for scripting.</p>
<p>bmon shows the traffic usage over all the network interfaces on the system.</p>
<h4>Install bmon in Linux</h4>
<p> Most of the distributions (Debian, Ubuntu, Mint, Fedora, suse, openSUSE, Arch Linux, Manjaro, Mageia, etc.) has the bmon package so, we can easily install it from distribution official repository.</p>
<pre>
<span style="color:#848484">[Install bmon on CentOS/RHEL]</span>
$ sudo yum install bmon

<span style="color:#848484">[Install bmon on Fedora]</span>
$ sudo dnf install bmon

<span style="color:#848484">[Install bmon on Debian/Ubuntu]</span>
$ sudo apt-get install bmon

<span style="color:#848484">[Install bmon on Arch Linux]</span>
$ sudo pacman -S bmon

<span style="color:#848484">[Install bmon on Mageia]</span>
$ sudo urpmi bmon

<span style="color:#848484">[Install bmon on openSUSE]</span>
$ sudo zypper install bmon
</pre>
<h4>Monitor live bandwidth usage</h4>
<p> After successfully bmon installed with help of above command. Just fire the below command on terminal to monitor bandwidth usage.</p>
<pre>
# bmon
</pre>
<p><a href="http://www.2daygeek.com/wp-content/uploads/2017/02/bmon-real-time-bandwidth-monitoring.png"><img src="http://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://www.2daygeek.com/wp-content/uploads/2017/02/bmon-real-time-bandwidth-monitoring.png" alt width="1121" height="812" class="aligncenter size-full wp-image-13291" srcset="http://www.2daygeek.com/wp-content/uploads/2017/02/bmon-real-time-bandwidth-monitoring.png 1121w, http://www.2daygeek.com/wp-content/uploads/2017/02/bmon-real-time-bandwidth-monitoring-300x217.png 300w, http://www.2daygeek.com/wp-content/uploads/2017/02/bmon-real-time-bandwidth-monitoring-768x556.png 768w, http://www.2daygeek.com/wp-content/uploads/2017/02/bmon-real-time-bandwidth-monitoring-1024x742.png 1024w" sizes="(max-width: 1121px) 100vw, 1121px"><noscript><img src="http://www.2daygeek.com/wp-content/uploads/2017/02/bmon-real-time-bandwidth-monitoring.png" alt="" width="1121" height="812" class="aligncenter size-full wp-image-13291" srcset="http://www.2daygeek.com/wp-content/uploads/2017/02/bmon-real-time-bandwidth-monitoring.png 1121w, http://www.2daygeek.com/wp-content/uploads/2017/02/bmon-real-time-bandwidth-monitoring-300x217.png 300w, http://www.2daygeek.com/wp-content/uploads/2017/02/bmon-real-time-bandwidth-monitoring-768x556.png 768w, http://www.2daygeek.com/wp-content/uploads/2017/02/bmon-real-time-bandwidth-monitoring-1024x742.png 1024w" sizes="(max-width: 1121px) 100vw, 1121px"/></noscript></a></p>
<p>By default bmon shows only interface info, if you want to load graphics, hit <code>g</code>, <code>i</code> and <code>d</code> for detailed information. These widgets are standard one and not possible to rearrange it.</p>
<pre>
 lo                                                                                                                                    bmon 3.9 
Interfaces                     │ RX bps       pps     %│ TX bps       pps     %
 >lo                           │   1.44KiB     24      │   1.44KiB     24
    qdisc none (noqueue)       │      0         0      │      0         0
  enp0s3                       │    156B        2      │    152B        1
    qdisc none (pfifo_fast)    │      0         0      │    148B        1
───────────────────────────────┴───────────────────────┴────────────────────────────────────────────────────────────────────────────────────────
     KiB                      (RX Bytes/second)                              KiB                      (TX Bytes/second)
    6.09 .........................|..................................       6.09 .........................|..................................
    5.08 .........................||.................................       5.08 .........................||.................................
    4.06 ..................|......||....................|............       4.06 ..................|......||....................|............
    3.05 .....|.|..........|......||....................||.|....|....       3.05 .....|.|..........|......||....................||.|....|....
    2.03 |.|..|.|..|......||......||....................||.|....|....       2.03 |.|..|.|..|......||......||....................||.|....|....
    1.02 |||::||||:|::::||||:|::::|||::|::::|::::|::::||||:|::|:|:::|       1.02 |||::||||:|::::||||:|::::|||::|::::|::::|::::||||:|::|:|:::|
         1   5   10   15   20   25   30   35   40   45   50   55   60            1   5   10   15   20   25   30   35   40   45   50   55   60















───────────────────────────────────────┬───────────────────────────────────────┬────────────────────────────────────────────────────────────────
                      RX          TX   │                      RX          TX   │                      RX          TX
 Bytes             15.51MiB    15.51MiB│ Packets          258.25K     258.25K  │ Abort Error           -           0   
 Carrier Error         -           0   │ Collisions            -           0   │ Compressed            0           0   
 CRC Error             0           -   │ Dropped               0           0   │ Errors                0           0   
 FIFO Error            0           0   │ Frame Error           0           -   │ Heartbeat Erro        -           0   
 ICMPv6                0           0   │ ICMPv6 Checksu        0           -   │ ICMPv6 Errors         0           0   
 Ip6 Address Er        0           -   │ Ip6 Broadcast         0           0   │ Ip6 Broadcast         0           0   
 Ip6 CE Packets        0           -   │ Ip6 Checksum E        0           -   │ Ip6 Delivers     124.83K          -   
 Ip6 ECT(0) Pac        8           -   │ Ip6 ECT(1) Pac        0           -   │ Ip6 Forwarded         -           0   
 Ip6 Header Err        0           -   │ Ip6 Multicast         0           0   │ Ip6 Multicast         0           0   
 Ip6 No Route          0           0   │ Ip6 Non-ECT Pa   124.85K          -   │ Ip6 Reasm/Frag        0           0   
 Ip6 Reasm/Frag        0           0   │ Ip6 Reasm/Frag        0           0   │ Ip6 Reassembly        0           -   
 Ip6 Too Big Er        0           -   │ Ip6 Truncated         0           -   │ Ip6 Unknown Pr        0           -   
 Ip6Discards           0           0   │ Ip6Octets          8.34MiB     8.33MiB│ Ip6Pkts          124.86K     124.83K  
 Length Error          0           -   │ Missed Error          0           -   │ Multicast             -           0   
 Over Error            0           -   │ Window Error          -           0   │
───────────────────────────────────────┼───────────────────────────────────────┼────────────────────────────────────────────────────────────────
 MTU                             65536 │ Flags          loopback,up,running,lo │ Operstate                     unknown
 IfIndex                             1 │ Address             00:00:00:00:00:00 │ Broadcast           00:00:00:00:00:00
 Mode                          default │ TXQlen                              1 │ Family                         unspec
 Alias                                 │ Qdisc                         noqueue │
 Fri Jan 27 18:35:43 2017                                                                                                      Press ? for help 

</pre>
<p>Bmon output is divided into four parts.</p>
 
<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7730570141079407" data-ad-slot="6977341179" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<ul>
<li><strong>Part-1</strong> : Display the available interfaces, received &#038; transferred bytes.</li>
<li><strong>Part-2</strong> : Display the same output alike above with graphical statistics.</li>
<li><strong>Part-3</strong> : Display the detailed information about received &#038; transferred bytes.</li>
<li><strong>Part-4</strong> : Display the additional information.</li>
</ul>
<p>Navigate to <code>Quick Reference</code> page by hitting <code>?</code> button for easy to use bmon.</p>
<pre>
                              ┌───────────────QUICK REFERENCE────────────────┐
                              │ Navigation                                   │
                              │   Up, Down      Previous/Next element        │
                              │   PgUp, PgDown  Scroll up/down entire page   │
                              │   Left, Right   Previous/Next attribute      │
                              │   [, ]          Previous/Next group          │
                              │   ?             Toggle quick reference       │
                              │   q             Quit bmon                    │
                              │                                              │
                              │ Display Settings                             │
                              │   d             Toggle detailed statistics   │
                              │   l             Toggle element list          │
                              │   i             Toggle additional info       │
                              │                                              │
                              │ Graph Settings                               │
                              │   g             Toggle graphical statistics  │
                              │   H             Start recording history data │
                              │   TAB           Switch time unit of graph    │
                              │   <, >          Change number of graphs      │
			      │   r             Reset counter of element     │
			      └──────────────────────────────────────────────┘
</pre>
<h4>Display specific interface usage</h4>
<p> If you want to display specific interface activity for better monitoring. Add <code>-p</code> option, followed by <code>Interface Name</code> with bmon.</p>
<pre>
# bmon -p eth0

 enp0s3                                                                                             bmon 3.9 
Interfaces                     │ RX bps       pps     %│ TX bps       pps     %
 >enp0s3                       │     11B        0      │     11B        0
───────────────────────────────┴───────────────────────┴─────────────────────────────────────────────────────
       B                      (RX Bytes/second)
  618.00 ...........|................................................
  515.00 ...........|................................................
  412.00 ...........|................................................
  309.00 ...........|................................................
  206.00 ........|..|................................................
  103.00 .|......|..|................................................
         1   5   10   15   20   25   30   35   40   45   50   55   60
       B                      (TX Bytes/second)
  160.00 ........|...................................................
  133.33 ........|...................................................
  106.67 ........|...................................................
   80.00 ........|...................................................
   53.33 .|......|..|................................................
   26.67 .|......|..|................................................
         1   5   10   15   20   25   30   35   40   45   50   55   60











─────────────────────────────────── Press d to enable detailed statistics ───────────────────────────────────
───────────────────────────────── Press i to enable additional information ──────────────────────────────────
 Fri Jan 27 18:42:39 2017                                                                   Press ? for help 
</pre>
<h4>Set Read Interval</h4>
<p> By default bmon show statistics every 1 seconds. We can change the statistics read interval by adding <code>-r</code> option, followed by </p>
<p><code>seconds</code> with bmon.</p>
<pre>
# bmon -r 5
</pre>
<h4>get ascii output</h4>
<p> By default bmon show statistics output in curses mode. If you want to get the output in ascii mode, add <code>-o</code> option, followed by <code>ascii</code> with bmon.</p>
<pre>
# bmon -o ascii

Interfaces                               RX bps         pps      %    TX bps         pps      %
  lo                                          0           0                0           0       
   qdisc none (noqueue)                       0           0                0           0       
  enp0s3                                      0           0                0           0       
   qdisc none (pfifo_fast)                    0           0                0           0       
Interfaces                               RX bps         pps      %    TX bps         pps      %
  lo                                        239B          3              239B          3       
   qdisc none (noqueue)                       0           0                0           0       
  enp0s3                                      0           0                0           0       
   qdisc none (pfifo_fast)                    0           0                0           0       
Interfaces                               RX bps         pps      %    TX bps         pps      %
  lo                                        419B          6              419B          6       
   qdisc none (noqueue)                       0           0                0           0       
  enp0s3                                     59B          0               59B          0       
   qdisc none (pfifo_fast)                    0           0               53B          0       

</pre>
<h4>Read more about bmon</h4>

<!-- Quick Adsense WordPress Plugin: http://quicksense.net/ -->
<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script id="mNCC" language="javascript">  medianet_width='728';  medianet_height= '90';  medianet_crid='827143833';  </script>  <script id="mNSC" src="http://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script>
</div>
<p> If you want to know more option which is available for bmon, simply navigate to man page.</p>
<pre>
<span style="color:#848484">[bmon man page]</span>
# bmon --help
or
# man bmon
</pre>

<!-- Quick Adsense WordPress Plugin: http://quicksense.net/ -->
<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script id="mNCC" language="javascript">  medianet_width='468';  medianet_height= '60';  medianet_crid='328488081';  </script>  <script id="mNSC" src="http://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script>
</div>

<div style="font-size:0px;height:0px;line-height:0px;margin:0;padding:0;clear:both"></div>							<nav class="pagination group">
                              </nav><!--/.pagination-->
						</div>

            
						<div class="clear"></div>
					</div><!--/.entry-->

				</div><!--/.post-inner-->
			</article><!--/.post-->
		
		<div class="clear"></div>

		<p class="post-tags"><span>Tags:</span> <a href="http://www.2daygeek.com/tag/bandwidth-monitoring-tool/" rel="tag">Bandwidth Monitoring Tool</a><a href="http://www.2daygeek.com/tag/bmon/" rel="tag">bmon</a><a href="http://www.2daygeek.com/tag/network-analyzer/" rel="tag">Network Analyzer</a><a href="http://www.2daygeek.com/tag/network-traffic-monitoring-tool/" rel="tag">Network Traffic Monitoring Tool</a><a href="http://www.2daygeek.com/tag/rate-estimator/" rel="tag">Rate Estimator</a></p>
					<div class="author-bio">
				<div class="bio-avatar"><img src="http://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://1.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=128&#038;d=mm&#038;r=g" alt srcset="http://1.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=256&amp;d=mm&amp;r=g 2x" class="avatar avatar-128 photo" height="128" width="128"><noscript><img alt='' src='http://1.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=128&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=256&amp;d=mm&amp;r=g 2x' class='avatar avatar-128 photo' height='128' width='128' /></noscript></div>
				<p class="bio-name">Magesh Maruthamuthu</p>
				<p class="bio-desc">Love to play with all Linux distribution</p>
				<div class="clear"></div>
			</div>
		
			<ul class="post-nav group">
		<li class="next"></li>
		<li class="previous"><a href="http://www.2daygeek.com/install-and-use-advanced-log-file-viewer-navigator-lnav-in-linux/" rel="prev"><i class="fa fa-chevron-left"></i><strong>Previous story</strong> <span>lnav &#8211; An Advanced Console Based Log File Viewer for Linux</span></a></li>
	</ul>

		

<h4 class="heading">
	<i class="fa fa-hand-o-right"></i>You may also like...</h4>

<ul class="related-posts group">

		<li class="related post-hover">
		<article class="post-9046 post type-post status-publish format-standard has-post-thumbnail hentry category-monitoring-tools tag-icinga2 tag-install-icinga tag-install-icinga2 tag-monitoring-tool tag-network-monitoring-tool tag-setup-icinga tag-setup-icinga2">

			<div class="post-thumbnail">
				<a href="http://www.2daygeek.com/install-icinga2-network-monitoring-tool-on-ubuntu-debian-mint/" title="Install Icinga2 v2.4.2 (Network Monitoring Tool) on Ubuntu, Debian &#038; Mint">
					<img src="http://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://www.2daygeek.com/wp-content/uploads/2016/02/install-icinga2-on-ubuntu-debian-mint-520x245.png" width="520" height="245" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt srcset="http://www.2daygeek.com/wp-content/uploads/2016/02/install-icinga2-on-ubuntu-debian-mint-520x245.png 520w, http://www.2daygeek.com/wp-content/uploads/2016/02/install-icinga2-on-ubuntu-debian-mint-720x340.png 720w" sizes="(max-width: 520px) 100vw, 520px"><noscript><img width="520" height="245" src="http://www.2daygeek.com/wp-content/uploads/2016/02/install-icinga2-on-ubuntu-debian-mint-520x245.png" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" srcset="http://www.2daygeek.com/wp-content/uploads/2016/02/install-icinga2-on-ubuntu-debian-mint-520x245.png 520w, http://www.2daygeek.com/wp-content/uploads/2016/02/install-icinga2-on-ubuntu-debian-mint-720x340.png 720w" sizes="(max-width: 520px) 100vw, 520px" /></noscript>																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="http://www.2daygeek.com/install-icinga2-network-monitoring-tool-on-ubuntu-debian-mint/" rel="bookmark" title="Install Icinga2 v2.4.2 (Network Monitoring Tool) on Ubuntu, Debian &#038; Mint">Install Icinga2 v2.4.2 (Network Monitoring Tool) on Ubuntu, Debian &#038; Mint</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2016-02-13 00:05:50">February 13, 2016</time>
</p>

				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		<li class="related post-hover">
		<article class="post-4301 post type-post status-publish format-standard has-post-thumbnail hentry category-monitoring-tools tag-install-nagios tag-monitoring-tool tag-nagios tag-network-monitoring-tool tag-nrpe">

			<div class="post-thumbnail">
				<a href="http://www.2daygeek.com/install-nagios-network-monitoring-tool-on-fedora-rhel-centos/" title="Install Nagios 4.1.1 Network Monitoring tool on Fedora, CentOS &#038; RHEL">
					<img src="http://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://www.2daygeek.com/wp-content/uploads/2014/11/install-nagios-network-monitoring-tool-on-fedora-rhel-centos-520x245.png" width="520" height="245" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt srcset="http://www.2daygeek.com/wp-content/uploads/2014/11/install-nagios-network-monitoring-tool-on-fedora-rhel-centos-520x245.png 520w, http://www.2daygeek.com/wp-content/uploads/2014/11/install-nagios-network-monitoring-tool-on-fedora-rhel-centos-720x340.png 720w" sizes="(max-width: 520px) 100vw, 520px"><noscript><img width="520" height="245" src="http://www.2daygeek.com/wp-content/uploads/2014/11/install-nagios-network-monitoring-tool-on-fedora-rhel-centos-520x245.png" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" srcset="http://www.2daygeek.com/wp-content/uploads/2014/11/install-nagios-network-monitoring-tool-on-fedora-rhel-centos-520x245.png 520w, http://www.2daygeek.com/wp-content/uploads/2014/11/install-nagios-network-monitoring-tool-on-fedora-rhel-centos-720x340.png 720w" sizes="(max-width: 520px) 100vw, 520px" /></noscript>																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="http://www.2daygeek.com/install-nagios-network-monitoring-tool-on-fedora-rhel-centos/" rel="bookmark" title="Install Nagios 4.1.1 Network Monitoring tool on Fedora, CentOS &#038; RHEL">Install Nagios 4.1.1 Network Monitoring tool on Fedora, CentOS &#038; RHEL</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2014-11-29 15:44:10">November 29, 2014</time>
</p>

				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		<li class="related post-hover">
		<article class="post-9013 post type-post status-publish format-standard has-post-thumbnail hentry category-monitoring-tools tag-cacti tag-install-cacti tag-monitoring-tool tag-network-monitoring-tool tag-setup-cacti">

			<div class="post-thumbnail">
				<a href="http://www.2daygeek.com/install-cacti-network-monitoring-tool-on-centos-rhel-fedora/" title="Install Cacti 0.8.8b (Network Monitoring Tool) on CentOS, RHEL &#038; Fedora">
					<img src="http://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://www.2daygeek.com/wp-content/uploads/2016/02/install-cacti-on-centos-fedora-rhel-520x245.png" width="520" height="245" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt srcset="http://www.2daygeek.com/wp-content/uploads/2016/02/install-cacti-on-centos-fedora-rhel-520x245.png 520w, http://www.2daygeek.com/wp-content/uploads/2016/02/install-cacti-on-centos-fedora-rhel-720x340.png 720w" sizes="(max-width: 520px) 100vw, 520px"><noscript><img width="520" height="245" src="http://www.2daygeek.com/wp-content/uploads/2016/02/install-cacti-on-centos-fedora-rhel-520x245.png" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" srcset="http://www.2daygeek.com/wp-content/uploads/2016/02/install-cacti-on-centos-fedora-rhel-520x245.png 520w, http://www.2daygeek.com/wp-content/uploads/2016/02/install-cacti-on-centos-fedora-rhel-720x340.png 720w" sizes="(max-width: 520px) 100vw, 520px" /></noscript>																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="http://www.2daygeek.com/install-cacti-network-monitoring-tool-on-centos-rhel-fedora/" rel="bookmark" title="Install Cacti 0.8.8b (Network Monitoring Tool) on CentOS, RHEL &#038; Fedora">Install Cacti 0.8.8b (Network Monitoring Tool) on CentOS, RHEL &#038; Fedora</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2016-02-06 00:05:00">February 6, 2016</time>
</p>

				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		
</ul><!--/.post-related-->


		
<div id="disqus_thread">
    </div>


	</div><!--/.pad-->

</section><!--/.content-->


	<div class="sidebar s1">

		<a class="sidebar-toggle" title="Expand Sidebar"><i class="fa icon-sidebar-toggle"></i></a>

		<div class="sidebar-content">

			  			<div class="sidebar-top group">
          <p>Follow:</p>
          <ul class="social-links"><li><a rel="nofollow" class="social-tooltip"  title="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Google+" href="https://www.google.com/+2daygeeks" target="_blank" style="color:#ffffff"><i class="fa fa-google-plus"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fa fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fa fa-tumblr"></i></a></li></ul>  			</div>
			
			
			
			<div id="text-8" class="widget widget_text"><h3 class="widget-title">&#8211; Google Ads &#8211;</h3>			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 2g-side-bar-1 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-7730570141079407"
     data-ad-slot="7612209571"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div><div id="text-10" class="widget widget_text"><h3 class="widget-title">&#8211; Yahoo Ads &#8211;</h3>			<div class="textwidget"><script id="mNCC" language="javascript">  medianet_width='300';  medianet_height= '250';  medianet_crid='108135239';  </script>  <script id="mNSC" src="http://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script></div>
		</div><div id="text-12" class="widget widget_text"><h3 class="widget-title">StackCommerce</h3>			<div class="textwidget"><iframe src="https://stacksocial.com/300250/learn-linux-in-5-days-and-level-up-your-career?aid=a-4s5jc8po" width="300" height="250" style="border: none;"></iframe></div>
		</div><div id="wp_subscribe-3" class="widget wp_subscribe">            
            <div class="wp-subscribe no-name-field" id="wp-subscribe">
                <h4 class="title">Get Latest LINUX Tips</h4>
                <p class="text"></p>

                                
                    <form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=2daygeekfeed', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true" _lpchecked="1">
                        <input class="email-field" type="text" value="" placeholder="Enter your email here" name="email">
                        <input type="hidden" value="2daygeekfeed" name="uri"><input type="hidden" name="loc" value="en_US">
                        <input class="submit" name="submit" type="submit" value="Sign Up Now">
                    </form>
                
                                <div class="clear"></div>
                
                <p class="footer-text"></p>
                
            </div><!--subscribe_widget-->
        
        </div><div id="text-3" class="widget widget_text">			<div class="textwidget"><script>
  (function() {
    var cx = '014898341766687711766:ajz3putspfm';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//www.google.com/cse/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only></div>
		</div><div id="text-6" class="widget widget_text">			<div class="textwidget"><div id="google_translate_element"></div><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script></div>
		</div><div id="text-5" class="widget widget_text"><h3 class="widget-title">Follow us</h3>			<div class="textwidget"><!-- Place this tag where you want the widget to render. -->
<div class="g-page" data-href="//plus.google.com/107364365185869631781" data-layout="landscape" data-rel="publisher"></div>

<!-- Place this tag after the last widget tag. -->
<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/platform.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></div>
		</div>
		</div><!--/.sidebar-content-->

	</div><!--/.sidebar-->

	

        </div><!--/.main-inner-->
      </div><!--/.main-->
    </div><!--/.container-inner-->
  </div><!--/.container-->
    <footer id="footer">

    
    
    
    <section class="container" id="footer-bottom">
      <div class="container-inner">

        <a id="back-to-top" href="#"><i class="fa fa-angle-up"></i></a>

        <div class="pad group">

          <div class="grid one-half">
                        
            <div id="copyright">
                              <p>2daygeek &copy; 2017. All Rights Reserved.</p>
                          </div><!--/#copyright-->

                          <div id="credit" style="">
                <p><a href="http://www.2daygeek.com">2daygeek</a> :- Linux Tips & Tricks, Linux How-to Guides & Tutorials is licensed under a <a href="http://creativecommons.org/licenses/by-nc/4.0/" rel="nofollow">(cc) BY-NC</a></p>
              </div><!--/#credit-->
            
          </div>

          <div class="grid one-half last">
            <ul class="social-links"><li><a rel="nofollow" class="social-tooltip"  title="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Google+" href="https://www.google.com/+2daygeeks" target="_blank" style="color:#ffffff"><i class="fa fa-google-plus"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fa fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fa fa-tumblr"></i></a></li></ul>          </div>

        </div><!--/.pad-->

      </div><!--/.container-inner-->
    </section><!--/.container-->

  </footer><!--/#footer-->

</div><!--/#wrapper-->

<div id="spu-bg"></div>
				<div id="spu-main"><a href="#" onClick="spuFlush(99);" id="spu-close">Close</a><div id='spu-title'>Please support the site</div>
<div id='spu-msg-cont'>
     <div id='spu-msg'>
     By clicking any of these buttons you help our site to get better </br>
     <div class="spu-button spu-twitter"><a href="https://twitter.com/2daygeek" class="twitter-follow-button" data-show-count="false" >Follow Me</a></div> <div class="spu-button spu-facebook"><div id="fb-root"></div><div class="fb-like" data-href="https://www.facebook.com/2daygeek" data-send="false" data-width="450" data-show-faces="true"data-layout="button_count"></div></div> <div class="spu-button spu-google"><div class="g-plusone" data-callback="googleCB" data-onendinteraction="closeGoogle" data-recommendations="false" data-annotation="bubble" data-size="medium" data-href="https://www.google.com/+2daygeeks"></div></div>
     </div>
    <div class='step-clear'></div>
</div><span id="spu-timer"></span><div id="spu-bottom"></div></div><link rel='stylesheet' id='wp-subscribe-css'  href='http://www.2daygeek.com/wp-content/plugins/wp-subscribe/css/wp-subscribe.css?ver=4.7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/hueman-addons/assets/front/js/jQuerySharrre.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/wf-cookie-consent/js/cookiechoices.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":null,"extLinksTargetExt":null,"extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":null,"imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","vivusSvgSpeed":"300","isDevMode":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/scripts.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-includes/js/comment-reply.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?ver=0.6.1'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/lazy-load/js/lazy-load.js?ver=0.6.1'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.7.2","language":""},"disqusIdentifier":"13248 http:\/\/www.2daygeek.com\/?p=13248","disqusShortname":"2daygeek","disqusTitle":"bmon \u2013 Real Time Bandwidth Monitor and Rate Estimator in Linux","disqusUrl":"http:\/\/www.2daygeek.com\/bmon-real-time-bandwidth-monitoring-tool-linux\/","options":{"manualSync":false},"postId":"13248"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"2daygeek"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.7.2'></script>
<!--[if lt IE 9]>
<script src="http://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/respond.js"></script>
<![endif]-->
<script type="text/javascript">
	window._wfCookieConsentSettings = {"wf_cookietext":"Cookies help us deliver our services. By using our services, you agree to our use of cookies.","wf_dismisstext":"Got it","wf_linktext":"Learn more","wf_linkhref":"http:\/\/www.2daygeek.com\/about-us\/","wf_position":"top","language":"en"};
</script>
</body>
</html>
