<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-71235901-1', 'auto');
  ga('send', 'pageview');

</script>
<meta name="google-site-verification" content="PuHJs7y90OgOH37jomlyBr-hu1ME7p4zbt8O9C7X8ng" />
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.2daygeek.com/xmlrpc.php">
<title>Script - A Simple Command-Line Tool for Recording Your Terminal Session Activity | 2daygeek.com</title>
<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>

<meta name="description" content="By default everyone prefers the history command to review/recall previously entered commands in the terminal. But unfortunately, it only shows commands and does" />
<meta name="keywords" content="script command,record terminal session,save terminal activity,linux" />
<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.2daygeek.com/#organization","url":"https://www.2daygeek.com/","name":"2daygeek.com","sameAs":[]},{"@type":"WebSite","@id":"https://www.2daygeek.com/#website","url":"https://www.2daygeek.com/","name":"2daygeek.com","publisher":{"@id":"https://www.2daygeek.com/#organization"}},{"@type":"WebPage","@id":"https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/#webpage","url":"https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/","inLanguage":"en-US","name":"Script &#8211; A Simple Command-Line Tool for Recording Your Terminal Session Activity","isPartOf":{"@id":"https://www.2daygeek.com/#website"},"image":{"@type":"ImageObject","@id":"https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/#primaryimage","url":"https://www.2daygeek.com/wp-content/uploads/2017/07/linux-script-command-record-replay-terminal-session-activity-1.png","width":600,"height":310},"primaryImageOfPage":{"@id":"https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/#primaryimage"},"datePublished":"2017-07-10T18:35:32+05:30","dateModified":"2019-11-24T13:39:13+05:30"},{"@type":"Article","@id":"https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/#article","isPartOf":{"@id":"https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/#webpage"},"author":{"@id":"https://www.2daygeek.com/author/magesh/#author"},"headline":"Script &#8211; A Simple Command-Line Tool for Recording Your Terminal Session Activity","datePublished":"2017-07-10T18:35:32+05:30","dateModified":"2019-11-24T13:39:13+05:30","commentCount":"3","mainEntityOfPage":{"@id":"https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/#webpage"},"publisher":{"@id":"https://www.2daygeek.com/#organization"},"articleSection":"Linux Advanced Commands, Linux Commands, Terminal Recorder, Linux, Record Terminal Session, Save Terminal Activity, Script Command","image":{"@type":"ImageObject","@id":"https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/#primaryimage","url":"https://www.2daygeek.com/wp-content/uploads/2017/07/linux-script-command-record-replay-terminal-session-activity-1.png","width":600,"height":310}},{"@type":"Person","@id":"https://www.2daygeek.com/author/magesh/#author","name":"Magesh Maruthamuthu","sameAs":[],"image":{"@type":"ImageObject","@id":"https://www.2daygeek.com/#personlogo","url":"https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=96&d=mm&r=g","width":96,"height":96,"caption":"Magesh Maruthamuthu"}}]}</script>
<link rel="canonical" href="https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/" />

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; Feed" href="https://www.2daygeek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; Comments Feed" href="https://www.2daygeek.com/comments/feed/" />
<link id="hu-user-gfont" href="//fonts.googleapis.com/css?family=Roboto+Slab:400,300italic,300,400italic,700&subset=latin,cyrillic-ext" rel="stylesheet" type="text/css"><link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; Script &#8211; A Simple Command-Line Tool for Recording Your Terminal Session Activity Comments Feed" href="https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.2daygeek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.2daygeek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='https://www.2daygeek.com/wp-content/plugins/arconix-shortcodes/includes/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='arconix-shortcodes-css' href='https://www.2daygeek.com/wp-content/plugins/arconix-shortcodes/includes/css/arconix-shortcodes.min.css?ver=2.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-main-style-css' href='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/main.min.css?ver=3.4.29' type='text/css' media='all' />
<style id='hueman-main-style-inline-css' type='text/css'>
body { font-family:'Roboto Slab', Arial, sans-serif;font-size:0.94rem }@media only screen and (min-width: 720px) {
        .nav > li { font-size:0.94rem; }
      }.boxed #wrapper, .container-inner { max-width: 1200px; }@media only screen and (min-width: 720px) {
                .boxed .desktop-sticky {
                  width: 1200px;
                }
              }::selection { background-color: #3b8dbd; }
::-moz-selection { background-color: #3b8dbd; }a,a+span.hu-external::after,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #3b8dbd; }input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #3b8dbd; }.post-format .format-container { border-color: #3b8dbd; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #3b8dbd!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #82b965; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #82b965; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #82b965; }
.post-comments::before { border-right-color: #82b965; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #3b8dbd}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #3b8dbd; }
              }.is-scrolled #header .nav-container.desktop-sticky,
              .is-scrolled #header .search-expand { background-color: #3b8dbd; background-color: rgba(59,141,189,0.90) }.is-scrolled .topbar-transparent #nav-topbar.desktop-sticky .nav ul { background-color: #3b8dbd; background-color: rgba(59,141,189,0.95) }#header { background-color: #33363b; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #33363b; }
}
        #header #nav-mobile { background-color: #33363b; }.is-scrolled #header #nav-mobile { background-color: #33363b; background-color: rgba(51,54,59,0.90) }#nav-header.nav-container, #main-header-search .search-expand { background-color: #fa720e; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #fa720e; }
}
        img { -webkit-border-radius: 2px; border-radius: 2px; }body { background-color: #eaeaea; }
</style>
<link rel='stylesheet' id='theme-stylesheet-css' href='https://www.2daygeek.com/wp-content/themes/my-child-theme/style.css?ver=3.4.29' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-font-awesome-css' href='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/font-awesome.min.css?ver=3.4.29' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.2daygeek.com/wp-content/tablepress-combined.min.css?ver=12' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://www.2daygeek.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.2daygeek.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.9' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.2daygeek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.2daygeek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.2daygeek.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='6 Methods To Check The Running Linux Kernel Version On System' href='https://www.2daygeek.com/check-find-determine-running-installed-linux-kernel-version/' />
<link rel='next' title='KeePass &#8211; A Best GUI Password Management Tool To Store/Secure Passwords In Linux' href='https://www.2daygeek.com/keepass-linux-password-manager-arch-linux-mint-ubuntu-debian-fedora-opensuse/' />
<meta name="generator" content="WordPress 5.3.1" />
<link rel='shortlink' href='https://wp.me/paS4jV-sO' />
<link rel="alternate" type="application/json+oembed" href="https://www.2daygeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.2daygeek.com%2Flinux-script-command-record-replay-terminal-session-activity%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.2daygeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.2daygeek.com%2Flinux-script-command-record-replay-terminal-session-activity%2F&#038;format=xml" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js"></script>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js"></script>
<![endif]-->

<meta property="og:type" content="article" />
<meta property="og:title" content="Script &#8211; A Simple Command-Line Tool for Recording Your Terminal Session Activity" />
<meta property="og:url" content="https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/" />
<meta property="og:description" content="By default everyone prefers the history command to review/recall previously entered commands in the terminal. But unfortunately, it only shows commands and does not show the output of previously ex…" />
<meta property="article:published_time" content="2017-07-10T18:35:32+00:00" />
<meta property="article:modified_time" content="2019-11-24T13:39:13+00:00" />
<meta property="og:site_name" content="2daygeek.com" />
<meta property="og:image" content="https://www.2daygeek.com/wp-content/uploads/2017/07/linux-script-command-record-replay-terminal-session-activity-1.png" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="310" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@2daygeek" />
<meta name="twitter:text:title" content="Script &#8211; A Simple Command-Line Tool for Recording Your Terminal Session Activity" />
<meta name="twitter:image" content="https://www.2daygeek.com/wp-content/uploads/2017/07/linux-script-command-record-replay-terminal-session-activity-1.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<link rel="icon" href="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-300x300.png" />
<style type="text/css" id="wp-custom-css">
				.entry
{
	color: #000;
}			</style>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-1786 single-format-standard wp-custom-logo wp-embed-responsive col-2cl boxed topbar-enabled header-desktop-sticky header-mobile-sticky unknown">
<div id="wrapper">
<header id="header" class="main-menu-mobile-on one-mobile-menu main_menu header-ads-desktop header-ads-mobile topbar-transparent no-header-img">
<nav class="nav-container group mobile-menu mobile-sticky " id="nav-mobile" data-menu-id="header-1">
<div class="mobile-title-logo-in-header"> <p class="site-title"><a class="custom-logo-link" href="https://www.2daygeek.com/" rel="home" title="2daygeek.com | Home page"><img src="https://www.2daygeek.com/wp-content/uploads/2015/12/2day-geek-new-logo-final.png" alt="2daygeek.com" " /></a></p>
</div>

<button class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false">
<div class="ham__navbar-span-wrapper">
<span class="line line-1"></span>
<span class="line line-2"></span>
<span class="line line-3"></span>
</div>
</button>
<div class="nav-text"></div>
<div class="nav-wrap container">
<ul class="nav container-inner group mobile-search">
<li>
<form method="get" class="searchform themeform" action="https://www.2daygeek.com/">
<div>
<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
</div>
</form> </li>
</ul>
<ul id="menu-menu-2" class="nav container-inner group"><li id="menu-item-19118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19118"><a href="https://www.2daygeek.com/category/shell-script/">Shell Script</a></li>
<li id="menu-item-6808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6808"><a href="https://www.2daygeek.com/category/linux-distributions/">Linux Distro&#8217;s</a></li>
<li id="menu-item-6806" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6806"><a href="https://www.2daygeek.com/category/linux-commands/">Linux Commands</a></li>
<li id="menu-item-9582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9582"><a href="https://www.2daygeek.com/category/webserver/">Web Servers</a></li>
<li id="menu-item-6809" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6809"><a href="https://www.2daygeek.com/category/monitoring-tools/">Monitoring Tools</a></li>
<li id="menu-item-6883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6883"><a href="https://www.2daygeek.com/category/package-management/">Package Manager</a></li>
<li id="menu-item-6811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6811"><a href="https://www.2daygeek.com/category/repository/">Additional Repos</a></li>
<li id="menu-item-6986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6986"><a href="https://www.2daygeek.com/category/free-cloud-storage/">Cloud Storage</a></li>
</ul> </div>
</nav>
<nav class="nav-container group desktop-menu desktop-sticky " id="nav-topbar" data-menu-id="header-2">
<div class="nav-text"></div>
<div class="topbar-toggle-down">
<i class="fas fa-angle-double-down" aria-hidden="true" data-toggle="down" title="Expand menu"></i>
<i class="fas fa-angle-double-up" aria-hidden="true" data-toggle="up" title="Collapse menu"></i>
</div>
<div class="nav-wrap container">
<ul id="menu-menu-1" class="nav container-inner group"><li id="menu-item-293" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-293"><a href="https://www.2daygeek.com/">Home</a></li>
<li id="menu-item-10920" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10920"><a href="https://linuxtechnews.com/">Linux Tech News</a></li>
<li id="menu-item-294" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294"><a href="https://www.2daygeek.com/about-us/">About</a></li>
<li id="menu-item-3676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3676"><a href="https://www.2daygeek.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-296"><a href="https://www.2daygeek.com/terms-and-conditions/">Terms And Conditions</a></li>
<li id="menu-item-2729" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2729"><a href="https://www.2daygeek.com/donate/">Donate</a></li>
<li id="menu-item-19232" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19232"><a href="https://www.2daygeek.com/join-us/">Join Us</a></li>
<li id="menu-item-295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295"><a href="https://www.2daygeek.com/contact-us/">Contact Us</a></li>
<li id="menu-item-8366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8366"><a href="https://www.2daygeek.com/category/os-tweaks/">OS Tweak</a></li>
<li id="menu-item-12012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12012"><a href="https://www.2daygeek.com/category/icon-theme/">Icons</a></li>
<li id="menu-item-12013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12013"><a href="https://www.2daygeek.com/category/gtk-theme/">Themes</a></li>
</ul> </div>
<div id="topbar-header-search" class="container">
<div class="container-inner">
<button class="toggle-search"><i class="fas fa-search"></i></button>
<div class="search-expand">
<div class="search-expand-inner"><form method="get" class="searchform themeform" action="https://www.2daygeek.com/">
<div>
<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
</div>
</form></div>
</div>
</div>
</div>
</nav>
<div class="container group">
<div class="container-inner">
<div class="group pad central-header-zone">
<div class="logo-tagline-group">
<p class="site-title"><a class="custom-logo-link" href="https://www.2daygeek.com/" rel="home" title="2daygeek.com | Home page"><img src="https://www.2daygeek.com/wp-content/uploads/2015/12/2day-geek-new-logo-final.png" alt="2daygeek.com" " /></a></p>
</div>
<div id="header-widgets">
<div id="ai_widget-4" class="widget ai_widget"><div class='code-block code-block-2' style='margin: 8px 0; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="3848983170"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div> </div>
</div>
<nav class="nav-container group desktop-menu " id="nav-header" data-menu-id="header-3">
<div class="nav-text"></div>
<div class="nav-wrap container">
<ul id="menu-menu-3" class="nav container-inner group"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19118"><a href="https://www.2daygeek.com/category/shell-script/">Shell Script</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6808"><a href="https://www.2daygeek.com/category/linux-distributions/">Linux Distro&#8217;s</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6806"><a href="https://www.2daygeek.com/category/linux-commands/">Linux Commands</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9582"><a href="https://www.2daygeek.com/category/webserver/">Web Servers</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6809"><a href="https://www.2daygeek.com/category/monitoring-tools/">Monitoring Tools</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6883"><a href="https://www.2daygeek.com/category/package-management/">Package Manager</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6811"><a href="https://www.2daygeek.com/category/repository/">Additional Repos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6986"><a href="https://www.2daygeek.com/category/free-cloud-storage/">Cloud Storage</a></li>
</ul> </div>
</nav>
</div>
</div>
</header>
<div class="container" id="page">
<div class="container-inner">
<div class="main">
<div class="main-inner group">
<section class="content">
<div class="page-title pad group">
<ul class="meta-single group">
<li class="category"><a href="https://www.2daygeek.com/category/linux-advanced-commands/" rel="category tag">Linux Advanced Commands</a> <span>/</span> <a href="https://www.2daygeek.com/category/linux-commands/" rel="category tag">Linux Commands</a> <span>/</span> <a href="https://www.2daygeek.com/category/terminal-recorder/" rel="category tag">Terminal Recorder</a></li>
</ul>
</div>
<div class="pad group">
<article class="post-1786 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-advanced-commands category-linux-commands category-terminal-recorder tag-linux tag-record-terminal-session tag-save-terminal-activity tag-script-command">
<div class="post-inner group">
<h1 class="post-title entry-title">Script &#8211; A Simple Command-Line Tool for Recording Your Terminal Session Activity</h1>
<p class="post-byline">
by <span class="vcard author">
<span class="fn"><a href="https://www.2daygeek.com/author/magesh/" title="Posts by Magesh Maruthamuthu" rel="author">Magesh Maruthamuthu</a></span>
</span>
&middot;
<span class="published">Last Updated: November 24, 2019</span>
</p>
<div class="clear"></div>
<div class="entry themeform">
<div class="entry-inner">

<div class="4ce8cb410074a13c74175297f2ee75bb" data-index="1" style="float: left; margin: 10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="8826511175"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>By default everyone prefers the history command to review/recall previously entered commands in the terminal.</p>
<p>But unfortunately, it only shows commands and does not show the output of previously executed commands.</p>
<p>There are many applications in the GUI that record terminal session activity, but very few applications are available on the command line.</p>
<p>The script is a great application for record your terminal session functionality on the headless server.</p>
<p>It is a good practice to record your terminal activity and keep it safe for further reference.</p>
<p>This may help you to see the detailed output if you want to investigate it sometime later.</p>
<p>According to this article, you need to manually run the script command if you want to record the terminal session functionality, see the following article if you want to automate it for all users.</p>
<ul>
<li><strong><a href="https://www.2daygeek.com/automatically-record-all-users-terminal-sessions-activity-linux-script-command/" rel="noopener noreferrer" target="_blank">How to Automatically Record the Terminal Session Activity of All Users on Linux</a><br />
</strong>
</li>
</ul>
<p>This application provides two commands &#8211; script and scriptreplay.</p>
<h4>What is script Command</h4>
<p> Script is a UNIX command-line application that records a terminal session (in other words, it records everything that is displayed on your terminal).</p>
<p>It stores the output as text file in the current directory and the default filename is <code>typescript</code>.</p>

<div class="4ce8cb410074a13c74175297f2ee75bb" data-index="2" style="float: left; margin: 10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="3265433976"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<h4>What is scriptreplay</h4>
<p> This program replays a typescript, using timing information to ensure that output happens at the same speed as it originally appeared when the script was recorded.</p>
<h4>How to Check if the script Command is Installed or not on Linux</h4>
<p> The script is part of the Linux Core application and is already installed on most Linux distributions by default.</p>
<p>The script command is part of the <strong>&#8220;util-linux-ng&#8221;</strong> package on RHEL-based systems and the <strong>&#8220;bsdutils&#8221;</strong> package on Debian-based systems.</p>
<p>For RPM based systems</p>
<pre># rpm -qf /usr/bin/script
util-linux-2.32.1-8.el8.x86_64

# rpm -qf /usr/bin/scriptreplay
util-linux-2.32.1-8.el8.x86_64
</pre>
<p>For DEB based systems</p>

<div class="4ce8cb410074a13c74175297f2ee75bb" data-index="3" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-7730570141079407" data-ad-slot="5150237910"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<pre># dpkg -S /usr/bin/script
bsdutils: /usr/bin/script

# dpkg -S /usr/bin/scriptreplay
bsdutils: /usr/bin/scriptreplay
</pre>
<p>If you want to find out which package provides a file in Linux, see the following article.</p>
<ul>
<li><strong><a href="https://www.2daygeek.com/how-to-find-out-what-package-provides-a-file-in-linux/" rel="noopener noreferrer" target="_blank">How to Find Out Which Package Provides a File</a><br />
</strong>
</li>
</ul>
<h4>1) How to Use script Command in Linux</h4>
<p> If you type the <code>script</code> command separately on the terminal, it will immediately start recording the current terminal function.</p>
<p>Once you have done the activity, type <code>exit</code> to save the current record.</p>
<p>To start the record, type the <code>script</code> command in the terminal and you will get a message like the one below.</p>
<pre>$ script
Script started, file is typescript
</pre>
<p>Let&#8217;s run few commands in the terminal to check this experiment.</p>
<p>The &#8220;w&#8221; command <strong><a href="https://www.2daygeek.com/commands-to-find-check-list-identify-logged-in-users-in-linux/" rel="noopener noreferrer" target="_blank">show who is logged on Linux system</a></strong> and what they are doing.</p>
<pre>$ w
 13:35:43 up  3:47,  1 user,  load average: 1.27, 1.32, 1.43
USER     TTY        <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="d19d9e96989f91">[email&#160;protected]</a>   IDLE   JCPU   PCPU WHAT
daygeek  :1        09:49   ?xdm?   2:39m  0.02s /usr/lib/gdm-x-session --run-script /usr/bin/gnome-session
</pre>
<p>The <strong><a href="https://www.2daygeek.com/10-methods-to-check-view-the-hostname-in-linux/" rel="noopener noreferrer" target="_blank">hostnamectl command</a></strong> used to query and change the system hostname and related settings.</p>
<pre>$ hostnamectl
   Static hostname: daygeek-Y700
         Icon name: computer-laptop
           Chassis: laptop
        Machine ID: xxxxx-xxxxx-xxxxx-xxxx-xxxx-xxx
           Boot ID: xxxxx-xxxxx-xxxxx-xxxx-xxxx-xxx
  Operating System: Manjaro Linux
            Kernel: Linux 4.19.84-1-MANJARO
      Architecture: x86-64
</pre>
<p>The <strong><a href="https://www.2daygeek.com/how-to-check-user-login-history-in-linux-using-last-lastb-lastlog-command/" rel="noopener noreferrer" target="_blank">last command</a></strong> show a listing of last logged in users.</p>
<pre>$ last | head -5
daygeek  :1           :1               Wed Nov 20 09:49   still logged in
reboot   system boot  4.19.84-1-MANJAR Wed Nov 20 09:48   still running
daygeek  :1           :1               Tue Nov 19 10:07 - down   (17:14)
reboot   system boot  4.19.80-1-MANJAR Tue Nov 19 10:06 - 03:21  (17:14)
daygeek  :1           :1               Sat Nov 16 09:23 - down  (2+17:46)
</pre>
<p>The &#8220;uname&#8221; command prints certain system information.</p>
<pre>$ uname -a
Linux daygeek-Y700 4.19.84-1-MANJARO #1 SMP PREEMPT Wed Nov 13 00:07:37 UTC 2019 x86_64 GNU/Linux
</pre>
<p>The &#8220;pwd&#8221; command outputs (prints) the current working directory.</p>
<pre>$ pwd
/home/daygeek
</pre>
<p>The <strong><a href="https://www.2daygeek.com/free-command-to-check-memory-usage-statistics-in-linux/" rel="noopener noreferrer" target="_blank">free command</a></strong> display amount of free and used memory in the system.</p>
<pre>$ free -m
              total        used        free      shared  buff/cache   available
Mem:          15867        3950        7722        2528        4195        9075
Swap:         17454           0       17454
</pre>
<p>speedtest-cli is a simple python script which help us to <strong><a href="https://www.2daygeek.com/speedtest-cli-test-internet-speed-linux-command-line/" rel="noopener noreferrer" target="_blank">test internet bandwidth (Upload &#038; Download) speed in Linux command line</a></strong> using speedtest.net. It’s using pure socket tests instead of HTTP based tests.</p>
<pre>$ speedtest-cli
Retrieving speedtest.net configuration...
Testing from Bangalore Broadband Network Pvt (103.5.134.176)...
Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by JIFFY CABLE AND DATACOM (Bangalore) [0.10 km]: 54.121 ms
Testing download speed................................................................................
Download: 25.33 Mbit/s
Testing upload speed......................................................................................................
Upload: 21.46 Mbit/s
</pre>
<p>Type the <code>exit</code> command in the terminal to save the script command and exit.</p>
<pre>$ exit
exit
Script done, file is typescript
</pre>
<h4>2) How to Check the Output of a script Command Record on Linux</h4>
<p> Once you have performed your activity in the above step. It&#8217;s time to check it again. You can use any file manipulation command to read the output.</p>

<div class="4ce8cb410074a13c74175297f2ee75bb" data-index="4" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script id="mNCC" language="javascript">
   medianet_width = "728";
   medianet_height = "90";
   medianet_crid = "847533357";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUF666N9' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div>
<pre>$ cat typescript
Script started on 2019-11-20 13:35:39+05:30 [TERM="xterm-256color" TTY="/dev/pts/0" COLUMNS="211" LINES="55"]

$ w
 13:35:43 up  3:47,  1 user,  load average: 1.27, 1.32, 1.43
USER     TTY        <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="89c5c6cec0c7c9">[email&#160;protected]</a>   IDLE   JCPU   PCPU WHAT
daygeek  :1        09:49   ?xdm?   2:39m  0.02s /usr/lib/gdm-x-session --run-script /usr/bin/gnome-session

$ hostnamectl
   Static hostname: daygeek-Y700
         Icon name: computer-laptop
           Chassis: laptop
        Machine ID: xxxxx-xxxxx-xxxxx-xxxx-xxxx-xxx
           Boot ID: xxxxx-xxxxx-xxxxx-xxxx-xxxx-xxx
  Operating System: Manjaro Linux
            Kernel: Linux 4.19.84-1-MANJARO
      Architecture: x86-64

$ last | head -5
daygeek  :1           :1               Wed Nov 20 09:49   still logged in
reboot   system boot  4.19.84-1-MANJAR Wed Nov 20 09:48   still running
daygeek  :1           :1               Tue Nov 19 10:07 - down   (17:14)
reboot   system boot  4.19.80-1-MANJAR Tue Nov 19 10:06 - 03:21  (17:14)
daygeek  :1           :1               Sat Nov 16 09:23 - down  (2+17:46)

$ uname -a
Linux daygeek-Y700 4.19.84-1-MANJARO #1 SMP PREEMPT Wed Nov 13 00:07:37 UTC 2019 x86_64 GNU/Linux

$ pwd
/home/daygeek

$ free -m
              total        used        free      shared  buff/cache   available
Mem:          15867        3950        7722        2528        4195        9075
Swap:         17454           0       17454

$ speedtest-cli
Retrieving speedtest.net configuration...
Testing from Bangalore Broadband Network Pvt (103.5.134.176)...
Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by JIFFY CABLE AND DATACOM (Bangalore) [0.10 km]: 54.121 ms
Testing download speed................................................................................
Download: 25.33 Mbit/s
Testing upload speed......................................................................................................
Upload: 21.46 Mbit/s

$ exit
exit
Script done on 2019-11-20 13:41:27+05:30 [COMMAND_EXIT_CODE="0"]
</pre>
<h4>3) How to Add a Custom File Name to the script Command</h4>
<p> By default the script stores the command output in the <code>typescript</code> name. You can add a custom file name for the script command output by adding a file name to the script command.</p>
<p>In my case, I input the file name <code>2g-terminal.txt</code>, and you can change the file name of your choice.</p>
<pre>$ script 2g-terminal.txt
Script started, file is 2g-terminal.txt
</pre>
<h4>4) How to Append script Command Output to an Existing File</h4>
<p> Running the script command without the <code>-a</code> option will overwrite the output file. To add new values to an existing file without overwriting it, use the <code>-a</code> option in the script command.</p>
<pre>$ script -a 2g-terminal.txt
Script started, file is 2g-terminal.txt
</pre>
<h4>5) How to Save Single Command Outputs in a File Using the script Command</h4>
<p> To store a single command output instead of an interactive shell session, use the <code>-c</code> option with the script command.</p>
<p>For example, updating the system package comes with at least 200+ lines of output, and this option is very useful for capturing them all.</p>
<pre>$ script -c 'yum update' magi-terminal.txt
Script started, file is magi-terminal.txt
Last metadata expiration check: 1 day, 12:08:03 ago on Tue 19 Nov 2019 01:53:28 PM IST.
Dependencies resolved.
====================================================================================================================
 Package                                 Arch     Version                                         Repository   Size
====================================================================================================================
Installing:
 kernel                                  x86_64   4.18.0-80.11.2.el8_0                            BaseOS      424 k
 kernel-core                             x86_64   4.18.0-80.11.2.el8_0                            BaseOS       24 M
 kernel-modules                          x86_64   4.18.0-80.11.2.el8_0                            BaseOS       20 M
Upgrading:
 anaconda-core                           x86_64   29.19.0.43-1.el8_0                              AppStream   2.1 M
 anaconda-gui                            x86_64   29.19.0.43-1.el8_0                              AppStream   500 k
 anaconda-tui                            x86_64   29.19.0.43-1.el8_0                              AppStream   256 k
 anaconda-widgets                        x86_64   29.19.0.43-1.el8_0                              AppStream   191 k
 appstream-data                          noarch   8-20190215.el8_0                                AppStream   1.8 M
 bind-libs                               x86_64   32:9.11.4-17.P2.el8_0.1                         AppStream   169 k
 bind-libs-lite                          x86_64   32:9.11.4-17.P2.el8_0.1                         AppStream   1.1 M
.
.
.
 systemd-libs                            x86_64   239-13.el8_0.5                                  BaseOS      551 k
 systemd-pam                             x86_64   239-13.el8_0.5                                  BaseOS      222 k
 systemd-udev                            x86_64   239-13.el8_0.5                                  BaseOS      1.3 M
 vdo                                     x86_64   6.2.0.298-10.el8_0                              BaseOS      682 k
 epel-release                            noarch   8-7.el8                                         epel         21 k
Installing dependencies:
 grub2-tools-efi                         x86_64   1:2.02-66.el8_0.1                               BaseOS      444 k

Transaction Summary
====================================================================================================================
Install    4 Packages
Upgrade  171 Packages

Total download size: 246 M
Is this ok [y/N]: n
Operation aborted.
Script done, file is magi-terminal.txt
</pre>
<h4>6) How to Run the script Command in Quiet Mode</h4>
<p> Use the <code>-q</code> option with the script command to suppress messages such as the script started and the script finished.</p>
<pre>$ script -c 'whoami' -q magi-terminal.txt
magi
</pre>
<h4>7) How to Replay the Session Recorded Through scriptreplay Command</h4>
<p> If you want to use the scriptreplay command to run a recorded session, make sure that you should record the session using the following format, otherwise it will not run the recorded session.</p>
<pre># script --timing=timing.txt session.txt
Script started, file is session.txt

# hostnamectl
   Static hostname: CentOS8.2DayGeek.com
         Icon name: computer-vm
           Chassis: vm
        Machine ID: e39e3a27005d44d8bcbfcab201480b45
           Boot ID: 61ae1ebd0cf448f3a5927cee7cf14e0d
    Virtualization: oracle
  Operating System: CentOS Linux 8 (Core)
       CPE OS Name: cpe:/o:centos:centos:8
            Kernel: Linux 4.18.0-80.el8.x86_64
      Architecture: x86-64

# cat /etc/centos-release
CentOS Linux release 8.0.1905 (Core)

# cat /etc/os-release 
NAME="CentOS Linux"
VERSION="8 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="8"
PLATFORM_ID="platform:el8"
PRETTY_NAME="CentOS Linux 8 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:8"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-8"
CENTOS_MANTISBT_PROJECT_VERSION="8"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="8"

# exit
exit
Script done, file is session.txt
</pre>
<p>Once you have recorded the terminal session activity using the format above, use the scriptreplay command to run the recorded session.</p>
<pre>$ scriptreplay --timing=timing.txt session.txt
</pre>

<div class="4ce8cb410074a13c74175297f2ee75bb" data-index="5" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script id="mNCC" language="javascript">  medianet_width='468';  medianet_height= '60';  medianet_crid='328488081';  </script> <script id="mNSC" src="https://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-7730570141079407" data-ad-slot="9495141575"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-1786" class="share-facebook sd-button share-icon" href="https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-1786" class="share-linkedin sd-button share-icon" href="https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-1786" class="share-twitter sd-button share-icon" href="https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-1786" class="share-pinterest sd-button share-icon" href="https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://www.2daygeek.com/linux-script-command-record-replay-terminal-session-activity/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li></ul></div></div></div> <nav class="pagination group">
</nav>
</div>
<div class="clear"></div>
</div>
</div>
</article>
<div class="clear"></div>
<p class="post-tags"><span>Tags:</span> <a href="https://www.2daygeek.com/tag/linux/" rel="tag">Linux</a><a href="https://www.2daygeek.com/tag/record-terminal-session/" rel="tag">Record Terminal Session</a><a href="https://www.2daygeek.com/tag/save-terminal-activity/" rel="tag">Save Terminal Activity</a><a href="https://www.2daygeek.com/tag/script-command/" rel="tag">Script Command</a></p>
<div class="author-bio">
<div class="bio-avatar"><img alt='' src='https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=128&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=256&#038;d=mm&#038;r=g 2x' class='avatar avatar-128 photo' height='128' width='128' /></div>
<p class="bio-name">Magesh Maruthamuthu</p>
<p class="bio-desc">Love to play with all Linux distribution</p>
<div class="clear"></div>
</div>
<ul class="post-nav group">
<li class="next"><a href="https://www.2daygeek.com/keepass-linux-password-manager-arch-linux-mint-ubuntu-debian-fedora-opensuse/" rel="next"><i class="fas fa-chevron-right"></i><strong>Next story</strong> <span>KeePass &#8211; A Best GUI Password Management Tool To Store/Secure Passwords In Linux</span></a></li>
<li class="previous"><a href="https://www.2daygeek.com/check-find-determine-running-installed-linux-kernel-version/" rel="prev"><i class="fas fa-chevron-left"></i><strong>Previous story</strong> <span>6 Methods To Check The Running Linux Kernel Version On System</span></a></li>
</ul>
<h4 class="heading">
<i class="far fa-hand-point-right"></i>You may also like...</h4>
<ul class="related-posts group">
<li class="related post-hover">
<article class="post-1590 post type-post status-publish format-standard has-post-thumbnail hentry category-apache-tutorials category-linux-advanced-commands category-linux-commands tag-apache-uptime tag-httpd-uptime tag-linux-daemon-uptime tag-linux-services-uptime tag-uptime tag-web-server-uptime">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/check-find-apache-httpd-web-server-uptime-linux/">
<img width="520" height="245" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2017/08/check-find-apache-httpd-web-server-uptime-linux-1-520x245.png" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" /> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/check-find-apache-httpd-web-server-uptime-linux/" rel="bookmark" title="Permalink to 4 Ways To Check Uptime of Apache Web Server (httpd) on Linux">4 Ways To Check Uptime of Apache Web Server (httpd) on Linux</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2017-08-25 00:05:58">August 25, 2017</time>
</p>
</div>
</div>
</article>
</li>
<li class="related post-hover">
<article class="post-16879 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-etchostname-file tag-change-hostname tag-hostnamectl tag-linux tag-nmcli tag-nmtui tag-update-hostname">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/four-methods-to-change-the-hostname-in-linux/">
<img width="520" height="245" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2019/02/Four-Methods-To-Change-HostName-In-Linux-520x245.png" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2019/02/Four-Methods-To-Change-HostName-In-Linux-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2019/02/Four-Methods-To-Change-HostName-In-Linux-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/four-methods-to-change-the-hostname-in-linux/" rel="bookmark" title="Permalink to 4 Methods to change the HostName in Linux">4 Methods to change the HostName in Linux</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2019-02-15 15:04:27">February 15, 2019</time>
</p>
</div>
</div>
</article>
</li>
<li class="related post-hover">
<article class="post-15943 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-advanced-commands category-linux-commands category-linux-configuration-files category-user-management tag-etcpasswd-file tag-check-user-information tag-compgen-command tag-find-gid tag-find-uid tag-find-user-information tag-finger-command tag-getent-command tag-id-command tag-linux tag-lslogins-command">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/find-check-user-name-and-other-information-in-linux/">
<img width="520" height="245" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2018/08/find-check-user-name-and-other-information-in-linux-1-520x245.png" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" /> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/find-check-user-name-and-other-information-in-linux/" rel="bookmark" title="Permalink to 6 Simple ways to check Username and related information in Linux">6 Simple ways to check Username and related information in Linux</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2018-08-02 00:05:28">August 2, 2018</time>
</p>
</div>
</div>
</article>
</li>
</ul>
<div id="disqus_thread"></div>
</div>
</section>
<div class="sidebar s1 collapsed" data-position="right" data-layout="col-2cl" data-sb-id="s1">
<button class="sidebar-toggle" title="Expand Sidebar"><i class="fas icon-sidebar-toggle"></i></button>
<div class="sidebar-content">
<div class="sidebar-top group">
<p>Follow:</p>
<ul class="social-links"><li><a rel="nofollow" class="social-tooltip" title="Facebook" aria-label="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Twitter" aria-label="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Linkein" aria-label="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Pinterest" aria-label="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fab fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Tumblr" aria-label="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fab fa-tumblr"></i></a></li></ul> </div>
<div id="media_image-4" class="widget widget_media_image"><h3 class="widget-title">Linux &#038; Open Source News</h3><a href="https://www.linuxtechnews.com/" target="_blank" rel="noopener noreferrer"><img width="300" height="43" src="https://www.2daygeek.com/wp-content/uploads/2019/05/linuxtechnews-logo-v3-300x43.png" class="image wp-image-17665  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://www.2daygeek.com/wp-content/uploads/2019/05/linuxtechnews-logo-v3-300x43.png 300w, https://www.2daygeek.com/wp-content/uploads/2019/05/linuxtechnews-logo-v3.png 330w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div id="text-8" class="widget widget_text"><h3 class="widget-title">&#8211; Click Here To Get Offers &#8211;</h3> <div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="7612209571"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div><div id="media_image-5" class="widget widget_media_image"><h3 class="widget-title">Ethical Hacking Course</h3><a href="https://ethicalhackersacademy.com/?ref=400ewqahhx" target="_blank" rel="noopener noreferrer"><img width="421" height="212" src="https://www.2daygeek.com/wp-content/uploads/2015/11/Hacking-Course-2.png" class="image wp-image-17800  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.2daygeek.com/wp-content/uploads/2015/11/Hacking-Course-2.png 421w, https://www.2daygeek.com/wp-content/uploads/2015/11/Hacking-Course-2-300x151.png 300w" sizes="(max-width: 421px) 100vw, 421px" /></a></div><div id="text-10" class="widget widget_text"><h3 class="widget-title">&#8211; For Better Offers &#8211;</h3> <div class="textwidget"><script id="mNCC" language="javascript">  medianet_width='300';  medianet_height= '250';  medianet_crid='108135239';  </script> <script id="mNSC" src="https://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script></div>
</div> <div id="wp_subscribe-3" class="widget wp_subscribe">
<div id="wp-subscribe" class="wp-subscribe-wrap wp-subscribe wp-subscribe-1" data-thanks_page="0" data-thanks_page_url="" data-thanks_page_new_window="0">
<h4 class="title">Get Latest LINUX Tips</h4>
<p class="text"></p>
<form action="https://feedburner.google.com/fb/a/mailverify?uri=2daygeekfeed" method="post" class="wp-subscribe-form wp-subscribe-feedburner" id="wp-subscribe-form-1" target="popupwindow">
<input class="regular-text email-field" type="email" name="email" placeholder="Enter your email here" required>
<input type="hidden" name="uri" value="2daygeekfeed">
<input type="hidden" name="loc" value="en_US">
<input type="hidden" name="form_type" value="widget">
<input type="hidden" name="service" value="feedburner">
<input type="hidden" name="widget" value="wp_subscribe-3">
<div class="wps-consent-wrapper">
<label for="consent-field">
<input class="consent-field" id="consent-field" type="checkbox" name="consent" required />
I consent to my submitted data being collected via this form* </label>
</div>
<input class="submit" type="submit" name="submit" value="Sign Up Now">
</form>
<div class="wp-subscribe-loader">
<svg version="1.1" id="loader-1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0" y="0" width="40px" height="40px" viewBox="0 0 50 50" style="enable-background:new 0 0 50 50;" xml:space="preserve">
<path fill="#ffffff" d="M43.935,25.145c0-10.318-8.364-18.683-18.683-18.683c-10.318,0-18.683,8.365-18.683,18.683h4.068c0-8.071,6.543-14.615,14.615-14.615c8.072,0,14.615,6.543,14.615,14.615H43.935z">
<animateTransform attributeType="xml" attributeName="transform" type="rotate" from="0 25 25" to="360 25 25" dur="0.6s" repeatCount="indefinite" />
</path>
</svg>
</div>
<p class="thanks">Thank you for subscribing.</p>
<p class="error">Something went wrong.</p>
<div class="clear"></div>
<p class="footer-text"></p>
</div>
</div>
<div id="text-3" class="widget widget_text"><h3 class="widget-title">To Search, Type and Hit Enter</h3> <div class="textwidget"><script>
  (function() {
    var cx = '007232544684438091033:5mzh938wm_e';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchresults-only></gcse:searchresults-only></div>
</div><div id="text-6" class="widget widget_text"><h3 class="widget-title">Google Translater</h3> <div class="textwidget"><div id="google_translate_element"></div><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script></div>
</div><div id="media_image-6" class="widget widget_media_image"><h3 class="widget-title">Linux Online Course</h3><a href="https://stacksocial.com/sales/complete-linux-crash-course-includes-topics-on-red-hat-unix-kali-python-and-opensuse?aid=a-4s5jc8po" target="_blank" rel="noopener noreferrer"><img width="402" height="355" src="https://www.2daygeek.com/wp-content/uploads/2015/11/Linux-Online-Course.png" class="image wp-image-17806  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.2daygeek.com/wp-content/uploads/2015/11/Linux-Online-Course.png 402w, https://www.2daygeek.com/wp-content/uploads/2015/11/Linux-Online-Course-300x265.png 300w" sizes="(max-width: 402px) 100vw, 402px" /></a></div>
</div>
</div>
</div>
</div>
</div>
</div>
<footer id="footer">
<section class="container" id="footer-bottom">
<div class="container-inner">
<a id="back-to-top" href="#"><i class="fas fa-angle-up"></i></a>
<div class="pad group">
<div class="grid one-half">
<div id="copyright">
<p></p>
</div>
<div id="credit" style="">
<p>Powered by&nbsp;<a class="fab fa-wordpress" title="Powered by WordPress" href="https://wordpress.org/" target="_blank"></a> - Designed with the&nbsp;<a href="" title="Hueman theme">Hueman theme</a></p>
</div>
</div>
<div class="grid one-half last">
<ul class="social-links"><li><a rel="nofollow" class="social-tooltip" title="Facebook" aria-label="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Twitter" aria-label="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Linkein" aria-label="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Pinterest" aria-label="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fab fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Tumblr" aria-label="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fab fa-tumblr"></i></a></li></ul> </div>
</div>
</div>
</section>
</footer>
</div>
<div style="display:none">
<div class="grofile-hash-map-d487bef1de15143a7b80a40396e96118">
</div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.2daygeek.com\/linux-script-command-record-replay-terminal-session-activity\/":1786};
	</script>
<link rel='stylesheet' id='wp-subscribe-css' href='https://www.2daygeek.com/wp-content/plugins/wp-subscribe/assets/css/wp-subscribe-form.css?ver=5.3.1' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"2daygeek"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"1786 https:\/\/www.2daygeek.com\/?p=1786","disqusShortname":"2daygeek","disqusTitle":"Script \u2013 A Simple Command-Line Tool for Recording Your Terminal Session Activity","disqusUrl":"https:\/\/www.2daygeek.com\/linux-script-command-record-replay-terminal-session-activity\/","postId":"1786"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/hueman-addons/addons/assets/front/js/jQuerySharrre.min.js?ver=5.3.1'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201950'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/wf-cookie-consent/js/cookiechoices.min.js?ver=5.3.1'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Decaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.3.1'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"","extLinksTargetExt":"","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"1","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":true,"mobile":true},"isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_up","mobile":"stick_up"},"mobileSubmenuExpandOnClick":"","submenuTogglerIcon":"<i class=\"fas fa-angle-down\"><\/i>","isDevMode":"","ajaxUrl":"https:\/\/www.2daygeek.com\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"9c5f366acc"},"isWelcomeNoteOn":"","welcomeContent":"","i18n":{"collapsibleExpand":"Expand","collapsibleCollapse":"Collapse"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/scripts.min.js?ver=3.4.29'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/comment-reply.min.js?ver=5.3.1'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/wp-embed.min.js?ver=5.3.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wp_subscribe = {"ajaxurl":"https:\/\/www.2daygeek.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/wp-subscribe/assets/js/wp-subscribe-form.js?ver=5.3.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.9'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<!--[if lt IE 9]>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/respond.js"></script>
<![endif]-->
<script type="text/javascript">
	window._wfCookieConsentSettings = {"wf_cookietext":"Cookies help us deliver our services. By using our services, you agree to our use of cookies.","wf_dismisstext":"Got it","wf_linktext":"Learn more","wf_linkhref":"https:\/\/www.2daygeek.com\/about-us\/","wf_position":"top","language":"en"};
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201950.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.9',blog:'160649683',post:'1786',tz:'5.5',srv:'www.2daygeek.com'} ]);
	_stq.push([ 'clickTrackerInit', '160649683', '1786' ]);
</script>
</body>
</html>