<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-71235901-1', 'auto');
  ga('send', 'pageview');

</script>
<meta name="google-site-verification" content="PuHJs7y90OgOH37jomlyBr-hu1ME7p4zbt8O9C7X8ng" />
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.2daygeek.com/xmlrpc.php">
<title>Rsync (Remote Sync) - Rsync Command Examples and Usage | 2daygeek.com</title>
<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>

<meta name="description" content="Rsync stands for remote synchronization. Rsync is a fast and extraordinarily versatile file copying tool. It is used for fast and incremental file transfer." />
<meta name="keywords" content="rsync,rsync 10 practical examples,rsync commad,rsync examples,rsync for backup,rsync for incremental backup" />
<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.2daygeek.com/#organization","url":"https://www.2daygeek.com/","name":"2daygeek.com","sameAs":[]},{"@type":"WebSite","@id":"https://www.2daygeek.com/#website","url":"https://www.2daygeek.com/","name":"2daygeek.com","publisher":{"@id":"https://www.2daygeek.com/#organization"}},{"@type":"WebPage","@id":"https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/#webpage","url":"https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/","inLanguage":"en-US","name":"Rsync (Remote Sync) &#8211; Rsync Command Examples and Usage","isPartOf":{"@id":"https://www.2daygeek.com/#website"},"image":{"@type":"ImageObject","@id":"https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/#primaryimage","url":"https://www.2daygeek.com/wp-content/uploads/2015/08/linux-rsync-command-local-remote-file-synchronization-1.png","width":600,"height":310},"primaryImageOfPage":{"@id":"https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/#primaryimage"},"datePublished":"2015-08-26T01:15:57+00:00","dateModified":"2019-09-24T07:05:52+00:00"},{"@type":"Article","@id":"https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/#article","isPartOf":{"@id":"https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/#webpage"},"author":{"@id":"https://www.2daygeek.com/author/magesh/#author"},"headline":"Rsync (Remote Sync) &#8211; Rsync Command Examples and Usage","datePublished":"2015-08-26T01:15:57+00:00","dateModified":"2019-09-24T07:05:52+00:00","commentCount":"2","mainEntityOfPage":{"@id":"https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/#webpage"},"publisher":{"@id":"https://www.2daygeek.com/#organization"},"articleSection":"Linux Commands, rsync, rsync 10 practical examples, rsync commad, rsync examples, rsync for backup, rsync for incremental backup","image":{"@type":"ImageObject","@id":"https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/#primaryimage","url":"https://www.2daygeek.com/wp-content/uploads/2015/08/linux-rsync-command-local-remote-file-synchronization-1.png","width":600,"height":310}},{"@type":"Person","@id":"https://www.2daygeek.com/author/magesh/#author","name":"Magesh Maruthamuthu","sameAs":[],"image":{"@type":"ImageObject","@id":"https://www.2daygeek.com/#personlogo","url":"https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=96&d=mm&r=g","width":96,"height":96,"caption":"Magesh Maruthamuthu"}}]}</script>
<link rel="canonical" href="https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/" />

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; Feed" href="https://www.2daygeek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; Comments Feed" href="https://www.2daygeek.com/comments/feed/" />
<link id="hu-user-gfont" href="//fonts.googleapis.com/css?family=Roboto+Slab:400,300italic,300,400italic,700&subset=latin,cyrillic-ext" rel="stylesheet" type="text/css"><link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; Rsync (Remote Sync) &#8211; Rsync Command Examples and Usage Comments Feed" href="https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.2daygeek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.3"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.2daygeek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='https://www.2daygeek.com/wp-content/plugins/arconix-shortcodes/includes/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='arconix-shortcodes-css' href='https://www.2daygeek.com/wp-content/plugins/arconix-shortcodes/includes/css/arconix-shortcodes.min.css?ver=2.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-main-style-css' href='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/main.min.css?ver=3.4.29' type='text/css' media='all' />
<style id='hueman-main-style-inline-css' type='text/css'>
body { font-family:'Roboto Slab', Arial, sans-serif;font-size:0.94rem }@media only screen and (min-width: 720px) {
        .nav > li { font-size:0.94rem; }
      }.boxed #wrapper, .container-inner { max-width: 1200px; }@media only screen and (min-width: 720px) {
                .boxed .desktop-sticky {
                  width: 1200px;
                }
              }::selection { background-color: #3b8dbd; }
::-moz-selection { background-color: #3b8dbd; }a,a+span.hu-external::after,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #3b8dbd; }input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #3b8dbd; }.post-format .format-container { border-color: #3b8dbd; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #3b8dbd!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #82b965; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #82b965; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #82b965; }
.post-comments::before { border-right-color: #82b965; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #3b8dbd}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #3b8dbd; }
              }.is-scrolled #header .nav-container.desktop-sticky,
              .is-scrolled #header .search-expand { background-color: #3b8dbd; background-color: rgba(59,141,189,0.90) }.is-scrolled .topbar-transparent #nav-topbar.desktop-sticky .nav ul { background-color: #3b8dbd; background-color: rgba(59,141,189,0.95) }#header { background-color: #33363b; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #33363b; }
}
        #header #nav-mobile { background-color: #33363b; }.is-scrolled #header #nav-mobile { background-color: #33363b; background-color: rgba(51,54,59,0.90) }#nav-header.nav-container, #main-header-search .search-expand { background-color: #fa720e; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #fa720e; }
}
        img { -webkit-border-radius: 2px; border-radius: 2px; }body { background-color: #eaeaea; }
</style>
<link rel='stylesheet' id='theme-stylesheet-css' href='https://www.2daygeek.com/wp-content/themes/my-child-theme/style.css?ver=3.4.29' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-font-awesome-css' href='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/font-awesome.min.css?ver=3.4.29' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.2daygeek.com/wp-content/tablepress-combined.min.css?ver=11' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://www.2daygeek.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.2daygeek.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.7.1' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.2daygeek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.2daygeek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.2daygeek.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='BodhiLinux 3.1.0 Release notes and upgrade' href='https://www.2daygeek.com/bodhilinux-3-1-0-release-notes-and-upgrade/' />
<link rel='next' title='Install mod_pagespeed to Improve Apache Performance on CentOS/RHEL &#038; Fedora' href='https://www.2daygeek.com/install-mod_pagespeed-to-improve-apache-performance-on-centos-rhel-fedora/' />
<meta name="generator" content="WordPress 5.2.3" />
<link rel='shortlink' href='https://wp.me/paS4jV-2O' />
<link rel="alternate" type="application/json+oembed" href="https://www.2daygeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.2daygeek.com%2Flinux-rsync-command-local-remote-file-synchronization%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.2daygeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.2daygeek.com%2Flinux-rsync-command-local-remote-file-synchronization%2F&#038;format=xml" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js"></script>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js"></script>
<![endif]-->

<meta property="og:type" content="article" />
<meta property="og:title" content="Rsync (Remote Sync) &#8211; Rsync Command Examples and Usage" />
<meta property="og:url" content="https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/" />
<meta property="og:description" content="Rsync stands for remote synchronization. Rsync is a fast and extraordinarily versatile file copying tool. It is used for fast and incremental file transfer. Rsync is widely used for backups and mir…" />
<meta property="article:published_time" content="2015-08-26T01:15:57+00:00" />
<meta property="article:modified_time" content="2019-09-24T07:05:52+00:00" />
<meta property="og:site_name" content="2daygeek.com" />
<meta property="og:image" content="https://www.2daygeek.com/wp-content/uploads/2015/08/linux-rsync-command-local-remote-file-synchronization-1.png" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="310" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@2daygeek" />
<meta name="twitter:text:title" content="Rsync (Remote Sync) &#8211; Rsync Command Examples and Usage" />
<meta name="twitter:image" content="https://www.2daygeek.com/wp-content/uploads/2015/08/linux-rsync-command-local-remote-file-synchronization-1.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<link rel="icon" href="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-300x300.png" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-174 single-format-standard wp-custom-logo wp-embed-responsive col-2cl boxed topbar-enabled header-desktop-sticky header-mobile-sticky unknown">
<div id="wrapper">
<header id="header" class="main-menu-mobile-on one-mobile-menu main_menu header-ads-desktop header-ads-mobile topbar-transparent no-header-img">
<nav class="nav-container group mobile-menu mobile-sticky " id="nav-mobile" data-menu-id="header-1">
<div class="mobile-title-logo-in-header"> <p class="site-title"><a class="custom-logo-link" href="https://www.2daygeek.com/" rel="home" title="2daygeek.com | Home page"><img src="https://www.2daygeek.com/wp-content/uploads/2015/12/2day-geek-new-logo-final.png" alt="2daygeek.com" " /></a></p>
</div>

<button class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false">
<div class="ham__navbar-span-wrapper">
<span class="line line-1"></span>
<span class="line line-2"></span>
<span class="line line-3"></span>
</div>
</button>
<div class="nav-text"></div>
<div class="nav-wrap container">
<ul class="nav container-inner group mobile-search">
<li>
<form method="get" class="searchform themeform" action="https://www.2daygeek.com/">
<div>
<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
</div>
</form> </li>
</ul>
<ul id="menu-menu-2" class="nav container-inner group"><li id="menu-item-6808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6808"><a href="https://www.2daygeek.com/category/linux-distributions/">Linux Distro&#8217;s</a></li>
<li id="menu-item-6806" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6806"><a href="https://www.2daygeek.com/category/linux-commands/">Linux Commands</a></li>
<li id="menu-item-9582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9582"><a href="https://www.2daygeek.com/category/webserver/">Web Servers</a></li>
<li id="menu-item-6809" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6809"><a href="https://www.2daygeek.com/category/monitoring-tools/">Monitoring Tools</a></li>
<li id="menu-item-6883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6883"><a href="https://www.2daygeek.com/category/package-management/">Package Manager</a></li>
<li id="menu-item-6811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6811"><a href="https://www.2daygeek.com/category/repository/">Additional Repos</a></li>
<li id="menu-item-6986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6986"><a href="https://www.2daygeek.com/category/free-cloud-storage/">Cloud Storage</a></li>
<li id="menu-item-18197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18197"><a href="https://www.2daygeek.com/2daygeek-post-archive/">Archive</a></li>
</ul> </div>
</nav>
<nav class="nav-container group desktop-menu desktop-sticky " id="nav-topbar" data-menu-id="header-2">
<div class="nav-text"></div>
<div class="topbar-toggle-down">
<i class="fas fa-angle-double-down" aria-hidden="true" data-toggle="down" title="Expand menu"></i>
<i class="fas fa-angle-double-up" aria-hidden="true" data-toggle="up" title="Collapse menu"></i>
</div>
<div class="nav-wrap container">
<ul id="menu-menu-1" class="nav container-inner group"><li id="menu-item-293" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-293"><a href="https://www.2daygeek.com/">HOME</a></li>
<li id="menu-item-10920" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10920"><a href="https://linuxtechnews.com/">Linux Tech News</a></li>
<li id="menu-item-294" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294"><a href="https://www.2daygeek.com/about-us/">ABOUT US</a></li>
<li id="menu-item-295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295"><a href="https://www.2daygeek.com/contact-us/">CONTACT US</a></li>
<li id="menu-item-296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-296"><a href="https://www.2daygeek.com/disclaimer/">DISCLAIMER</a></li>
<li id="menu-item-3676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3676"><a href="https://www.2daygeek.com/privacy-policy/">PRIVACY POLICY</a></li>
<li id="menu-item-2729" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2729"><a href="https://www.2daygeek.com/support-us/">SUPPORT US</a></li>
<li id="menu-item-8366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8366"><a href="https://www.2daygeek.com/category/os-tweaks/">OS TWEAK</a></li>
<li id="menu-item-12012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12012"><a href="https://www.2daygeek.com/category/icon-theme/">ICONS</a></li>
<li id="menu-item-12013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12013"><a href="https://www.2daygeek.com/category/gtk-theme/">THEMES</a></li>
</ul> </div>
<div id="topbar-header-search" class="container">
<div class="container-inner">
<button class="toggle-search"><i class="fas fa-search"></i></button>
<div class="search-expand">
<div class="search-expand-inner"><form method="get" class="searchform themeform" action="https://www.2daygeek.com/">
<div>
<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
</div>
</form></div>
</div>
</div>
</div>
</nav>
<div class="container group">
<div class="container-inner">
<div class="group pad central-header-zone">
<div class="logo-tagline-group">
<p class="site-title"><a class="custom-logo-link" href="https://www.2daygeek.com/" rel="home" title="2daygeek.com | Home page"><img src="https://www.2daygeek.com/wp-content/uploads/2015/12/2day-geek-new-logo-final.png" alt="2daygeek.com" " /></a></p>
</div>
<div id="header-widgets">
<div id="ai_widget-4" class="widget ai_widget"><div class='code-block code-block-2' style='margin: 8px 0; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="3848983170"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div> </div>
</div>
<nav class="nav-container group desktop-menu " id="nav-header" data-menu-id="header-3">
<div class="nav-text"></div>
<div class="nav-wrap container">
<ul id="menu-menu-3" class="nav container-inner group"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6808"><a href="https://www.2daygeek.com/category/linux-distributions/">Linux Distro&#8217;s</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6806"><a href="https://www.2daygeek.com/category/linux-commands/">Linux Commands</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9582"><a href="https://www.2daygeek.com/category/webserver/">Web Servers</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6809"><a href="https://www.2daygeek.com/category/monitoring-tools/">Monitoring Tools</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6883"><a href="https://www.2daygeek.com/category/package-management/">Package Manager</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6811"><a href="https://www.2daygeek.com/category/repository/">Additional Repos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6986"><a href="https://www.2daygeek.com/category/free-cloud-storage/">Cloud Storage</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18197"><a href="https://www.2daygeek.com/2daygeek-post-archive/">Archive</a></li>
</ul> </div>
</nav>
</div>
</div>
</header>
<div class="container" id="page">
<div class="container-inner">
<div class="main">
<div class="main-inner group">
<section class="content">
<div class="page-title pad group">
<ul class="meta-single group">
<li class="category"><a href="https://www.2daygeek.com/category/linux-commands/" rel="category tag">Linux Commands</a></li>
</ul>
</div>
<div class="pad group">
<article class="post-174 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-rsync tag-rsync-10-practical-examples tag-rsync-commad tag-rsync-examples tag-rsync-for-backup tag-rsync-for-incremental-backup">
<div class="post-inner group">
<h1 class="post-title entry-title">Rsync (Remote Sync) &#8211; Rsync Command Examples and Usage</h1>
<p class="post-byline">
by <span class="vcard author">
<span class="fn"><a href="https://www.2daygeek.com/author/magesh/" title="Posts by Magesh Maruthamuthu" rel="author">Magesh Maruthamuthu</a></span>
</span>
&middot;
<span class="published">Published : August 26, 2015 || Last Updated: September 24, 2019</span>
</p>
<div class="clear"></div>
<div class="entry themeform">
<div class="entry-inner">

<div style="float: left; margin: 10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="8826511175"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>Rsync stands for remote synchronization.</p>
<p>Rsync is a fast and extraordinarily versatile file copying tool.</p>
<p>It is used for fast and incremental file transfer. Rsync is widely used for backups and mirroring purpose.</p>
<p>rsync is typically used to synchronize files and directories between two different systems or local directory.</p>
<p>It uses &#8220;<strong>delta-transfer algorithm&#8221;</strong>, which reduces the amount of data sent over the network by transferring only changed files to destination that has changed since the last backup.</p>
<p>It offers a wide range of options that control every aspect of its behavior and permit very flexible specification of the set of files to be copied.</p>
<p>Rsync finds files that need to be transferred using a <strong>&#8220;quick check&#8221;</strong> algorithm (by default) that looks for files that have changed in size or in last-modified time.</p>
<h4>How to Install rsync on Linux</h4>
<p> The rsync command isn’t installed by default on a Linux system, it’s available in the distribution repository, so use the following commands to install it.</p>
<p>For <strong><code>Fedora</code></strong> system, use <strong><a href="https://www.2daygeek.com/dnf-command-examples-manage-packages-fedora-system/" target="_blank" rel="noopener noreferrer">DNF Command</a></strong> to install rsync.</p>
<pre>$ sudo dnf install rsync
</pre>
<p>For <strong><code>Debian/Ubuntu</code></strong> systems, use <strong><a href="https://www.2daygeek.com/apt-get-apt-cache-command-examples-manage-packages-debian-ubuntu-systems/" target="_blank" rel="noopener noreferrer">APT-GET Command</a></strong> or <strong><a href="https://www.2daygeek.com/apt-command-examples-manage-packages-debian-ubuntu-systems/" target="_blank" rel="noopener noreferrer">APT Command</a></strong> to install rsync.</p>

<div style="float: left; margin: 10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="3265433976"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<pre>$ sudo apt install rsync
</pre>
<p>For <strong><code>Arch Linux</code></strong> based systems, use <strong><a href="https://www.2daygeek.com/pacman-command-examples-manage-packages-arch-linux-system/" target="_blank" rel="noopener noreferrer">Pacman Command</a></strong> to install rsync.</p>
<pre>$ sudo pacman -S rsync
</pre>
<p>For <strong><code>RHEL/CentOS</code></strong> systems, use <strong><a href="https://www.2daygeek.com/yum-command-examples-manage-packages-rhel-centos-systems/" target="_blank" rel="noopener noreferrer">YUM Command</a></strong> to install rsync.</p>
<pre>$ sudo yum install rsync
</pre>
<p>For <strong><code>openSUSE Leap</code></strong> system, use <strong><a href="https://www.2daygeek.com/zypper-command-examples-manage-packages-opensuse-system/" target="_blank" rel="noopener noreferrer">Zypper Command</a></strong> to install rsync.</p>
<pre>$ sudo zypper install rsync
</pre>
<p>The rsync command syntax is as follows:</p>
<pre>rsync [options] [source] [destination]
</pre>
<p>There are many options available for rsync, but the options listed below are often used, so make a note of it.</p>

<div style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-7730570141079407" data-ad-slot="5150237910"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<pre>-a : Archive mode
-v : Increase verbosity
-z : Compress files and folders data during the transfer
-e : Specify the remote shell to use
-r : Recurse into directories
--delete : Delete files that don't exist on sender system
</pre>
<h4>1) How to Copy/Sync Files Locally</h4>
<p> The example below will synchronize files locally from one location to another. The <strong>&#8220;cpmove-mageshco.tar.gz&#8221;</strong> file will be copied from the <strong>&#8220;/home/2daygeek&#8221;</strong> directory to the <strong>&#8220;/home/mageshm&#8221;</strong> directory.</p>
<pre># rsync -zvr /home/2daygeek/cpmove-mageshco.tar.gz /home/mageshm/
sending incremental file list
cpmove-mageshco.tar.gz

sent 39554341 bytes  received 31 bytes  26369581.33 bytes/sec
total size is 39540978  speedup is 1.00
</pre>
<h4>2) How to Copy/Sync Directories Recursively Locally</h4>
<p> The below example will synchronize directories locally from one location to another. The &#8220;/home/2daygeek/&#8221; entire directory will be copied to the /home/mageshm/ directory.</p>
<pre># rsync -zvr /home/2daygeek/ /home/mageshm/
or
# rsync -avz /home/2daygeek/ /home/mageshm/
sending incremental file list
2daygeek.txt
cpmove-mageshco.tar.gz
test/
test/2daygeek-insdie.txt

sent 37912510 bytes  received 73 bytes  10832166.57 bytes/sec
total size is 39541296  speedup is 1.04
</pre>
<h4>3) How to Copy/Sync Files and Directories Recursively From Local System to Remote System</span></h4>
<p> The example below will sync files and directories from a local system to a remote system.<br />
<strong>Local folder:</strong> /home/mageshco/public_html/rsync-magesh<br />
<strong>Remote System IP:</strong> 192.168.1.5<br />
<strong>Remote folder:</strong> /home/mageshm/</p>
<pre># rsync -zvr /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="e99b86869da9d8d0dbc7d8dfd1c7d8c7dc">[email&#160;protected]</a>:/home/mageshm/
or
# rsync -avz /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="0d7f6262794d3c343f233c3b35233c2338">[email&#160;protected]</a>:/home/mageshm/</span>
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="e4968b8b90a4d5ddd6cad5d2dccad5cad1">[email&#160;protected]</a>'s password:
sending incremental file list
magesh.txt
test/magesh-inside.txt

sent 171 bytes  received 51 bytes  9.87 bytes/sec
total size is 0  speedup is 0.00
</pre>
<h4>4) How to Copy/Sync Files and Directories From Remote System to Local System</span></h4>
<p> It&#8217;s vice versa. The example below will sync files and directories from a remote system to a local system.<br />
<strong>Local folder:</strong> /home/mageshco/public_html/rsync-magesh<br />
<strong>Remote System IP:</strong> 192.168.1.5<br />
<strong>Remote folder:</strong> /home/mageshm/</p>
<pre># rsync -zvr <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="acdec3c3d8ec9d959e829d9a94829d8299">[email&#160;protected]</a>:/home/mageshm/ /home/mageshco/public_html/rsync-magesh/
or
# rsync -avz <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="63110c0c1723525a514d52555b4d524d56">[email&#160;protected]</a>:/home/mageshm/ /home/mageshco/public_html/rsync-magesh/
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="3e4c51514a7e0f070c100f0806100f100b">[email&#160;protected]</a>'s password:
receiving incremental file list
.bash_logout
.bash_profile
.bashrc
magesh.txt
test/
test/magesh-inside.txt

sent 110 bytes  received 610 bytes  53.33 bytes/sec
total size is 318  speedup is 0.44
</pre>
<h4>5) How to Copy/Sync Files and Directories From Local System to Remote System Over SSH</h4>
<p> The example below will synchronize files and directories from a local system to a remote system via SSH. </p>
<p>It uses a secure SSH protocol for file transfer, so I recommend users to go with this option when you want to perform file transfer on a remote machine.<br />
<strong>Local folder:</strong> /home/mageshco/public_html/rsync-magesh<br />
<strong>Remote System IP:</strong> 192.168.1.5<br />
<strong>Remote folder:</strong> /home/mageshm/</p>
<pre># rsync -zvre ssh /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="cebca1a1ba8efff7fce0fff8f6e0ffe0fb">[email&#160;protected]</a>:/home/mageshm/
or
# rsync -avze ssh /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="afddc0c0dbef9e969d819e9997819e819a">[email&#160;protected]</a>:/home/mageshm/
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="b2c0ddddc6f2838b809c83848a9c839c87">[email&#160;protected]</a>'s password:
sending incremental file list
test.txt
test/
test/test-inside.txt

sent 164 bytes  received 54 bytes  14.06 bytes/sec
total size is 0  speedup is 0.00
</pre>
<h4>6) How to Copy/Sync Files and Directories From Remote System to Local System Over SSH</span></h4>
<p> It&#8217;s like vice versa. The example below will synchronize files and directories from a remote system to a local system via SSH. </p>
<p>It uses a secure SSH protocol for file transfer, so I recommend users to go with this option when you want to perform file transfer on a remote machine.<br />
<strong>Local folder:</strong> /home/mageshco/public_html/rsync-magesh<br />
<strong>Remote System IP:</strong> 192.168.1.5<br />
<strong>Remote folder:</strong> /home/mageshm/</p>
<pre># rsync -zvre ssh <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="51233e3e25116068637f6067697f607f64">[email&#160;protected]</a>:/home/mageshm/ /home/mageshco/public_html/rsync-magesh/
or
# rsync -avze ssh <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="176578786357262e253926212f39263922">[email&#160;protected]</a>:/home/mageshm/ /home/mageshco/public_html/rsync-magesh/
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="b8cad7d7ccf889818a96898e809689968d">[email&#160;protected]</a>'s password:
receiving incremental file list
./
.bash_logout
.bash_profile
.bashrc
test.txt
test/
test/test-inside.txt

sent 113 bytes  received 663 bytes  31.67 bytes/sec
total size is 318  speedup is 0.41
</pre>
<h4>7) How to Copy/Sync Files and Directories From Local System to Remote System Over SSH With Non-Standard Port</h4>
<p> The example below will synchronize files and directories from a local system to a remote system via SSH with Non-Standard port.</p>
<p>This example is useful if the default SSH port has been replaced by another port for security reasons.</p>
<p>It uses a secure SSH protocol for file transfer, so I recommend users to go with this option when you want to perform file transfer on a remote machine.<br />
<strong>Local folder:</strong> /home/mageshco/public_html/rsync-magesh<br />
<strong>Remote System IP:</strong> 192.168.1.5<br />
<strong>Remote folder:</strong> /home/mageshm/</p>

<div style="float: none; margin:10px 0 10px 0; text-align:center;">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script id="mNCC" language="javascript">
   medianet_width = "728";
   medianet_height = "90";
   medianet_crid = "847533357";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUF666N9' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div>
<pre># rsync -zvre "ssh -p 2200" /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="7c0e1313083c4d454e524d4a44524d5249">[email&#160;protected]</a>:/home/mageshm/
or
rsync -avze "ssh -p 2200" /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="2f5d40405b6f1e161d011e1917011e011a">[email&#160;protected]</a>:/home/mageshm/
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="b7c5d8d8c3f7868e859986818f99869982">[email&#160;protected]</a>'s password:
stdin: is not a tty
sending incremental file list
.bash_logout
.bash_profile
.bashrc
test.txt
test/
test/test-inside.txt

sent 613 bytes  received 111 bytes  96.53 bytes/sec
total size is 318  speedup is 0.44
</pre>
<h4>8) How to Copy/Sync Files and Directories From Remote System to Local System Over SSH With Non-Standard Port</span></h4>
<p> It&#8217;s like vice versa. The example below will synchronize files and directories from a remote system to a local system via SSH with Non-Standard port.</p>
<p>This example is useful if the default SSH port has been replaced by another port for security reasons.</p>
<p>It uses a secure SSH protocol for file transfer, so I recommend users to go with this option when you want to perform file transfer on a remote machine.<br />
<strong>Local folder:</strong> /home/mageshco/public_html/rsync-magesh<br />
<strong>Remote System IP:</strong> 192.168.1.5<br />
<strong>Remote folder:</strong> /home/mageshm/</p>
<pre># rsync -zvre "ssh -p 2200" <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="0c7e6363784c3d353e223d3a34223d2239">[email&#160;protected]</a>:/home/mageshm/ /home/mageshco/public_html/rsync-magesh/
or
# rsync -avze "ssh -p 2200" <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="3e4c51514a7e0f070c100f0806100f100b">[email&#160;protected]</a>:/home/mageshm/ /home/mageshco/public_html/rsync-magesh/
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="760419190236474f445847404e58475843">[email&#160;protected]</a>'s password:
stdin: is not a tty
receiving incremental file list
.bash_logout
.bash_profile
.bashrc
test.txt
test/
test/test-inside.txt

sent 128 bytes  received 309 bytes  17.84 bytes/sec
total size is 318  speedup is 0.73
</pre>
<h4>9) How to Add a Progress Status When Executing the rsync Command</h4>
<p> The below rsync command shows the progress of the file/folder copy. This may give you an estimate idea of how long this activity will last.<br />
<strong>Local folder:</strong> /home/mageshco/public_html/rsync-magesh<br />
<strong>Remote System IP:</strong> 192.168.1.5<br />
<strong>Remote folder:</strong> /home/mageshm/</p>
<pre># rsync -zvre ssh --progress <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="592b36362d1968606b77686f617768776c">[email&#160;protected]</a>:/home/mageshm/ /home/mageshco/public_html/rsync-magesh/
or
# rsync -avze ssh --progress <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="bac8d5d5cefa8b8388948b8c82948b948f">[email&#160;protected]</a>:/home/mageshm/ /home/mageshco/public_html/rsync-magesh/
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="5c2e3333281c6d656e726d6a64726d7269">[email&#160;protected]</a>'s password:
receiving incremental file list
.bash_logout
          18 100%   17.58kB/s    0:00:00 (xfer#1, to-check=5/7)
.bash_profile
         176 100%  171.88kB/s    0:00:00 (xfer#2, to-check=4/7)
.bashrc
         124 100%  121.09kB/s    0:00:00 (xfer#3, to-check=3/7)
test.txt
           0 100%    0.00kB/s    0:00:00 (xfer#4, to-check=2/7)
test/
test/test-inside.txt
           0 100%    0.00kB/s    0:00:00 (xfer#5, to-check=0/7)

sent 110 bytes  received 594 bytes  56.32 bytes/sec
total size is 318  speedup is 0.45
</pre>
<h4>10) How to Delete Files/Folders That Don&#8217;t Exist in the Sender System When Using the rsync Command</h4>
<p> The example below will sync files and directories from the local system to the remote system and remove files and folders that aren&#8217;t in the sender system.</p>
<p>This can be achieved by adding the <code>--delete</code> option with the rsync command.<br />
<strong>Local folder:</strong> /home/mageshco/public_html/rsync-magesh<br />
<strong>Remote System IP:</strong> 192.168.1.5<br />
<strong>Remote folder:</strong> /home/mageshm/</p>
<pre># rsync -zvre ssh --delete /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="b5c7dadac1f5848c879b84838d9b849b80">[email&#160;protected]</a>:/home/mageshm/
or
# rsync -avze ssh --delete /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="15677a7a6155242c273b24232d3b243b20">[email&#160;protected]</a>:/home/mageshm/
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="8cfee3e3f8ccbdb5bea2bdbab4a2bda2b9">[email&#160;protected]</a>'s password:
sending incremental file list
deleting test.txt

sent 141 bytes  received 13 bytes  20.53 bytes/sec
total size is 318  speedup is 2.06
</pre>
<h4>11) How to Remove Source System Files After Synchronization</h4>
<p> The example below will synchronize files and directories from the local system to the remote system and remove all files and folders from the source system once synced.</p>
<p>This can be achieved by adding the <code>--remove-source-files</code> option with the rsync command.<br />
<strong>Local folder:</strong> /home/mageshco/public_html/rsync-magesh<br />
<strong>Remote System IP:</strong> 192.168.1.5<br />
<strong>Remote folder:</strong> /home/mageshm/</p>
<pre># rsync -zvre ssh --remove-source-files /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="a6d4c9c9d2e6979f948897909e88978893">[email&#160;protected]</a>:/home/mageshm/
or
# rsync -avze ssh --remove-source-files /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="d5a7babaa195e4ece7fbe4e3edfbe4fbe0">[email&#160;protected]</a>:/home/mageshm/
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="cdbfa2a2b98dfcf4ffe3fcfbf5e3fce3f8">[email&#160;protected]</a>'s password:
sending incremental file list
test.html
test.php
test1.php

sent 255 bytes  received 70 bytes  34.21 bytes/sec
total size is 318  speedup is 0.98

# ls -lh /home/mageshco/public_html/rsync-magesh/
ls: cannot access /home/mageshco/public_html/rsync-magesh/: No such file or directory
</pre>
<h4>12) How to Synchronize Only the Specific Type of Files From Local System to a Remote System</h4>
<p> The example below will synchronize only the &#8220;.php&#8221; extension files from the local system to the remote system.</p>
<p>This can be achieved by adding the <code>--include</code> option with the rsync command.<br />
<strong>Local folder:</strong> /home/mageshco/public_html/rsync-magesh<br />
<strong>Remote System IP:</strong> 192.168.1.5<br />
<strong>Remote folder:</strong> /home/mageshm/</p>
<pre># rsync -zvre ssh --include '*.php' --exclude '*' /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="a9dbc6c6dde998909b87989f918798879c">[email&#160;protected]</a>:/home/mageshm/
or
# rsync -avze ssh --include '*.php' --exclude '*' /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="24564b4b5064151d160a15121c0a150a11">[email&#160;protected]</a>:/home/mageshm/
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="52203d3d2612636b607c63646a7c637c67">[email&#160;protected]</a>'s password:
sending incremental file list
test.php
test1.php

sent 132 bytes  received 50 bytes  17.33 bytes/sec
total size is 0  speedup is 0.00
</pre>
<h4>13) How to Synchronize All Files From a Local System to a Remote System Except for a Specific Type</h4>
<p> The example below will synchronize all files except the &#8220;.txt&#8221; extension files from the local system to the remote system.</p>
<p>This can be achieved by adding the <code>--exclude</code> option with the rsync command.<br />
<strong>Local folder:</strong> /home/mageshco/public_html/rsync-magesh<br />
<strong>Remote System IP:</strong> 192.168.1.5<br />
<strong>Remote folder:</strong> /home/mageshm/</p>
<pre># rsync -zvre ssh --exclude '*.txt' /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="01736e6e75413038332f3037392f302f34">[email&#160;protected]</a>:/home/mageshm/
or
# rsync -avze ssh --exclude '*.txt' /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="0d7f6262794d3c343f233c3b35233c2338">[email&#160;protected]</a>:/home/mageshm/
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="60120f0f14205159524e5156584e514e55">[email&#160;protected]</a>'s password:
sending incremental file list
test.html
test.php
test1.php

sent 255 bytes  received 70 bytes  34.21 bytes/sec
total size is 318  speedup is 0.98
</pre>
<h4>14) How to Exclude Files That Have the Latest Date in the Target System</h4>
<p> The following example will skip any files that have been newly modified on the target system. This option helps you when you synchronize files from production servers to development servers.</p>
<p>This can be achieved by adding the <code>--update</code> option with the rsync command.<br />
<strong>Local folder:</strong> /home/mageshco/public_html/rsync-magesh<br />
<strong>Remote System IP:</strong> 192.168.1.5<br />
<strong>Remote folder:</strong> /home/mageshm/</p>
<pre># rsync -zvre ssh --update /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="e5978a8a91a5d4dcd7cbdcdccbd7d1d3cbd6d6">[email&#160;protected]</a>:/home/mageshm/
or
# rsync -avze ssh --update /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="bac8d5d5cefa8b838894838394888e8c948989">[email&#160;protected]</a>:/home/mageshm/
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="c3b1acacb783f2faf1edfafaedf1f7f5edf0f0">[email&#160;protected]</a>'s password:
sending incremental file list

sent 190 bytes  received 13 bytes  23.88 bytes/sec
</pre>
<h4>15) How To Set the File Size Limit in the rsync Command</h4>
<p> You can specify the MAX file size limit in the sync command. This will leave large (Like, zip, tar and video files) size files. This can be achieved by adding the <code>--max-size=</code> option with the rsync command.</p>
<p>The below example will synchronize only files that has a size ≤100KB.<br />
<strong>Local folder:</strong> /home/mageshco/public_html/rsync-magesh<br />
<strong>Remote System IP:</strong> 192.168.1.5<br />
<strong>Remote folder:</strong> /home/mageshm/</p>
<pre># rsync -zvre ssh --max-size='100k' /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="24564b4b5064151d160a15121c0a150a11">[email&#160;protected]</a>:/home/mageshm/
or
# rsync -avze ssh --max-size='100k' /home/mageshco/public_html/rsync-magesh/ <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="88fae7e7fcc8b9b1baa6b9beb0a6b9a6bd">[email&#160;protected]</a>:/home/mageshm/
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="73011c1c0733424a415d42454b5d425d46">[email&#160;protected]</a>'s password:
sending incremental file list
test.html
test.php
test.txt
test1.php

sent 334 bytes  received 95 bytes  24.51 bytes/sec
total size is 318  speedup is 0.74
</pre>
<h4>16) How to Automate Your Backup to Remote Server Using the rsync Command</h4>
<p> Automating remote backups is one of the mandatory procedures in any environment. If you want to do that, follow the four steps described in the article below.</p>
<ul>
<li><strong><a href="https://www.2daygeek.com/bash-script-remote-backup-replication-using-rsync-command/" rel="noopener noreferrer" target="_blank">How to Automate Your Backup to Remote Server Using the rsync Command</a></strong></li>
</ul>
<p>I hope you found this article helpful. Please provide your valuable feedback / comments in the comment section.</p>
<p>Stay tuned with us !!</p>

<div style="float: none; margin:10px 0 10px 0; text-align:center;">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script id="mNCC" language="javascript">  medianet_width='468';  medianet_height= '60';  medianet_crid='328488081';  </script> <script id="mNSC" src="https://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-7730570141079407" data-ad-slot="9495141575"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-174" class="share-facebook sd-button share-icon" href="https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-174" class="share-linkedin sd-button share-icon" href="https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-174" class="share-twitter sd-button share-icon" href="https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-174" class="share-pinterest sd-button share-icon" href="https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://www.2daygeek.com/linux-rsync-command-local-remote-file-synchronization/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li></ul></div></div></div> <nav class="pagination group">
</nav>
</div>
<div class="clear"></div>
</div>
</div>
</article>
<div class="clear"></div>
<p class="post-tags"><span>Tags:</span> <a href="https://www.2daygeek.com/tag/rsync/" rel="tag">rsync</a><a href="https://www.2daygeek.com/tag/rsync-10-practical-examples/" rel="tag">rsync 10 practical examples</a><a href="https://www.2daygeek.com/tag/rsync-commad/" rel="tag">rsync commad</a><a href="https://www.2daygeek.com/tag/rsync-examples/" rel="tag">rsync examples</a><a href="https://www.2daygeek.com/tag/rsync-for-backup/" rel="tag">rsync for backup</a><a href="https://www.2daygeek.com/tag/rsync-for-incremental-backup/" rel="tag">rsync for incremental backup</a></p>
<div class="author-bio">
<div class="bio-avatar"><img alt='' src='https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=128&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=256&#038;d=mm&#038;r=g 2x' class='avatar avatar-128 photo' height='128' width='128' /></div>
<p class="bio-name">Magesh Maruthamuthu</p>
<p class="bio-desc">Love to play with all Linux distribution</p>
<div class="clear"></div>
</div>
<ul class="post-nav group">
<li class="next"><a href="https://www.2daygeek.com/install-mod_pagespeed-to-improve-apache-performance-on-centos-rhel-fedora/" rel="next"><i class="fas fa-chevron-right"></i><strong>Next story</strong> <span>Install mod_pagespeed to Improve Apache Performance on CentOS/RHEL &#038; Fedora</span></a></li>
<li class="previous"><a href="https://www.2daygeek.com/bodhilinux-3-1-0-release-notes-and-upgrade/" rel="prev"><i class="fas fa-chevron-left"></i><strong>Previous story</strong> <span>BodhiLinux 3.1.0 Release notes and upgrade</span></a></li>
</ul>
<h4 class="heading">
<i class="far fa-hand-point-right"></i>You may also like...</h4>
<ul class="related-posts group">
<li class="related post-hover">
<article class="post-17138 post type-post status-publish format-standard has-post-thumbnail hentry category-fast-directories-navigation category-linux-advanced-commands category-linux-commands tag-autocd tag-bd-command tag-faster-navigation tag-liux tag-navigate-directories-faster tag-quick-navigation tag-up-shell-script">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/up-shell-script-quickly-go-back-to-a-specific-parent-directory-in-linux/">
<img width="520" height="245" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2019/04/UP-Shell-Script-Quickly-Navigate-To-A-Specific-Parent-Directory-In-Linux-520x245.png" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2019/04/UP-Shell-Script-Quickly-Navigate-To-A-Specific-Parent-Directory-In-Linux-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2019/04/UP-Shell-Script-Quickly-Navigate-To-A-Specific-Parent-Directory-In-Linux-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/up-shell-script-quickly-go-back-to-a-specific-parent-directory-in-linux/" rel="bookmark" title="Permalink to UP Shell Script &#8211; Quickly Navigate To A Specific Parent Directory In Linux">UP Shell Script &#8211; Quickly Navigate To A Specific Parent Directory In Linux</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2019-04-02 17:41:11">April 2, 2019</time>
</p>
</div>
</div>
</article>
</li>
<li class="related post-hover">
<article class="post-14854 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-bash tag-exa tag-linux-command tag-list-directory tag-list-files tag-ls">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/exa-a-modern-replacement-for-ls-command-linux/">
<img width="520" height="245" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2017/09/exa-modern-replacement-for-ls-520x245.png" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2017/09/exa-modern-replacement-for-ls-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2017/09/exa-modern-replacement-for-ls-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/exa-a-modern-replacement-for-ls-command-linux/" rel="bookmark" title="Permalink to Exa &#8211; A Modern And Colorful Replacement For LS Command Written In Rust">Exa &#8211; A Modern And Colorful Replacement For LS Command Written In Rust</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2017-09-15 11:51:44">September 15, 2017</time>
</p>
</div>
</div>
</article>
</li>
<li class="related post-hover">
<article class="post-1292 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands category-package-management tag-check-installed-package tag-find-installed-package tag-linux-package-manager tag-search-installed-package">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/find-out-if-package-is-installed-or-not-in-linux-unix/">
<img width="520" height="245" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2013/12/find-out-if-package-is-installed-or-not-in-linux-unix-1-520x245.png" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2013/12/find-out-if-package-is-installed-or-not-in-linux-unix-1-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2013/12/find-out-if-package-is-installed-or-not-in-linux-unix-1-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/find-out-if-package-is-installed-or-not-in-linux-unix/" rel="bookmark" title="Permalink to How to Find Out if a Package is Installed on Linux or Not?">How to Find Out if a Package is Installed on Linux or Not?</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2013-12-19 16:40:41">December 19, 2013</time>
</p>
</div>
</div>
</article>
</li>
</ul>
<div id="disqus_thread"></div>
</div>
</section>
<div class="sidebar s1 collapsed" data-position="right" data-layout="col-2cl" data-sb-id="s1">
<button class="sidebar-toggle" title="Expand Sidebar"><i class="fas icon-sidebar-toggle"></i></button>
<div class="sidebar-content">
<div class="sidebar-top group">
<p>Follow:</p>
<ul class="social-links"><li><a rel="nofollow" class="social-tooltip" title="Facebook" aria-label="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Twitter" aria-label="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Linkein" aria-label="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Pinterest" aria-label="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fab fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Tumblr" aria-label="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fab fa-tumblr"></i></a></li></ul> </div>
<div id="media_image-4" class="widget widget_media_image"><h3 class="widget-title">Linux &#038; Open Source News</h3><a href="https://www.linuxtechnews.com/" target="_blank" rel="noopener noreferrer"><img width="300" height="43" src="https://www.2daygeek.com/wp-content/uploads/2019/05/linuxtechnews-logo-v3-300x43.png" class="image wp-image-17665  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://www.2daygeek.com/wp-content/uploads/2019/05/linuxtechnews-logo-v3-300x43.png 300w, https://www.2daygeek.com/wp-content/uploads/2019/05/linuxtechnews-logo-v3.png 330w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div id="text-8" class="widget widget_text"><h3 class="widget-title">&#8211; Click Here To Get Offers &#8211;</h3> <div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="7612209571"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div><div id="media_image-5" class="widget widget_media_image"><h3 class="widget-title">Ethical Hacking Course</h3><a href="https://ethicalhackersacademy.com/?ref=400ewqahhx" target="_blank" rel="noopener noreferrer"><img width="421" height="212" src="https://www.2daygeek.com/wp-content/uploads/2015/11/Hacking-Course-2.png" class="image wp-image-17800  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.2daygeek.com/wp-content/uploads/2015/11/Hacking-Course-2.png 421w, https://www.2daygeek.com/wp-content/uploads/2015/11/Hacking-Course-2-300x151.png 300w" sizes="(max-width: 421px) 100vw, 421px" /></a></div><div id="text-10" class="widget widget_text"><h3 class="widget-title">&#8211; For Better Offers &#8211;</h3> <div class="textwidget"><script id="mNCC" language="javascript">  medianet_width='300';  medianet_height= '250';  medianet_crid='108135239';  </script> <script id="mNSC" src="https://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script></div>
</div> <div id="wp_subscribe-3" class="widget wp_subscribe">
<div id="wp-subscribe" class="wp-subscribe-wrap wp-subscribe wp-subscribe-1" data-thanks_page="0" data-thanks_page_url="" data-thanks_page_new_window="0">
<h4 class="title">Get Latest LINUX Tips</h4>
<p class="text"></p>
<form action="https://feedburner.google.com/fb/a/mailverify?uri=2daygeekfeed" method="post" class="wp-subscribe-form wp-subscribe-feedburner" id="wp-subscribe-form-1" target="popupwindow">
<input class="regular-text email-field" type="email" name="email" placeholder="Enter your email here" required>
<input type="hidden" name="uri" value="2daygeekfeed">
<input type="hidden" name="loc" value="en_US">
<input type="hidden" name="form_type" value="widget">
<input type="hidden" name="service" value="feedburner">
<input type="hidden" name="widget" value="wp_subscribe-3">
<div class="wps-consent-wrapper">
<label for="consent-field">
<input class="consent-field" id="consent-field" type="checkbox" name="consent" required />
I consent to my submitted data being collected via this form* </label>
</div>
<input class="submit" type="submit" name="submit" value="Sign Up Now">
</form>
<div class="wp-subscribe-loader">
<svg version="1.1" id="loader-1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0" y="0" width="40px" height="40px" viewBox="0 0 50 50" style="enable-background:new 0 0 50 50;" xml:space="preserve">
<path fill="#ffffff" d="M43.935,25.145c0-10.318-8.364-18.683-18.683-18.683c-10.318,0-18.683,8.365-18.683,18.683h4.068c0-8.071,6.543-14.615,14.615-14.615c8.072,0,14.615,6.543,14.615,14.615H43.935z">
<animateTransform attributeType="xml" attributeName="transform" type="rotate" from="0 25 25" to="360 25 25" dur="0.6s" repeatCount="indefinite" />
</path>
</svg>
</div>
<p class="thanks">Thank you for subscribing.</p>
<p class="error">Something went wrong.</p>
<div class="clear"></div>
<p class="footer-text"></p>
</div>
</div>
<div id="text-3" class="widget widget_text"><h3 class="widget-title">To Search, Type and Hit Enter</h3> <div class="textwidget"><script>
  (function() {
    var cx = '007232544684438091033:5mzh938wm_e';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchresults-only></gcse:searchresults-only></div>
</div><div id="text-6" class="widget widget_text"><h3 class="widget-title">Google Translater</h3> <div class="textwidget"><div id="google_translate_element"></div><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script></div>
</div><div id="media_image-6" class="widget widget_media_image"><h3 class="widget-title">Linux Online Course</h3><a href="https://stacksocial.com/sales/complete-linux-crash-course-includes-topics-on-red-hat-unix-kali-python-and-opensuse?aid=a-4s5jc8po" target="_blank" rel="noopener noreferrer"><img width="402" height="355" src="https://www.2daygeek.com/wp-content/uploads/2015/11/Linux-Online-Course.png" class="image wp-image-17806  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.2daygeek.com/wp-content/uploads/2015/11/Linux-Online-Course.png 402w, https://www.2daygeek.com/wp-content/uploads/2015/11/Linux-Online-Course-300x265.png 300w" sizes="(max-width: 402px) 100vw, 402px" /></a></div>
</div>
</div>
</div>
</div>
</div>
</div>
<footer id="footer">
<section class="container" id="footer-bottom">
<div class="container-inner">
<a id="back-to-top" href="#"><i class="fas fa-angle-up"></i></a>
<div class="pad group">
<div class="grid one-half">
<div id="copyright">
<p></p>
</div>
<div id="credit" style="">
<p>Powered by&nbsp;<a class="fab fa-wordpress" title="Powered by WordPress" href="https://wordpress.org/" target="_blank"></a> - Designed with the&nbsp;<a href="" title="Hueman theme">Hueman theme</a></p>
</div>
</div>
<div class="grid one-half last">
<ul class="social-links"><li><a rel="nofollow" class="social-tooltip" title="Facebook" aria-label="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Twitter" aria-label="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Linkein" aria-label="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Pinterest" aria-label="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fab fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Tumblr" aria-label="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fab fa-tumblr"></i></a></li></ul> </div>
</div>
</div>
</section>
</footer>
</div>
<div style="display:none">
<div class="grofile-hash-map-d487bef1de15143a7b80a40396e96118">
</div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.2daygeek.com\/linux-rsync-command-local-remote-file-synchronization\/":174};
	</script>
<link rel='stylesheet' id='wp-subscribe-css' href='https://www.2daygeek.com/wp-content/plugins/wp-subscribe/assets/css/wp-subscribe-form.css?ver=5.2.3' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"2daygeek"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"174 https:\/\/www.2daygeek.com\/?p=174","disqusShortname":"2daygeek","disqusTitle":"Rsync (Remote Sync) \u2013 Rsync Command Examples and Usage","disqusUrl":"https:\/\/www.2daygeek.com\/linux-rsync-command-local-remote-file-synchronization\/","postId":"174"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/hueman-addons/addons/assets/front/js/jQuerySharrre.min.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201939'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/wf-cookie-consent/js/cookiechoices.min.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Sepaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"","extLinksTargetExt":"","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"1","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":true,"mobile":true},"isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_up","mobile":"stick_up"},"mobileSubmenuExpandOnClick":"","submenuTogglerIcon":"<i class=\"fas fa-angle-down\"><\/i>","isDevMode":"","ajaxUrl":"https:\/\/www.2daygeek.com\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"f92a1acd04"},"isWelcomeNoteOn":"","welcomeContent":"","i18n":{"collapsibleExpand":"Expand","collapsibleCollapse":"Collapse"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/scripts.min.js?ver=3.4.29'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/comment-reply.min.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/wp-embed.min.js?ver=5.2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wp_subscribe = {"ajaxurl":"https:\/\/www.2daygeek.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/wp-subscribe/assets/js/wp-subscribe-form.js?ver=5.2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.7.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<!--[if lt IE 9]>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/respond.js"></script>
<![endif]-->
<script type="text/javascript">
	window._wfCookieConsentSettings = {"wf_cookietext":"Cookies help us deliver our services. By using our services, you agree to our use of cookies.","wf_dismisstext":"Got it","wf_linktext":"Learn more","wf_linkhref":"https:\/\/www.2daygeek.com\/about-us\/","wf_position":"top","language":"en"};
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201939.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.7.1',blog:'160649683',post:'174',tz:'5.5',srv:'www.2daygeek.com'} ]);
	_stq.push([ 'clickTrackerInit', '160649683', '174' ]);
</script>
</body>
</html>