<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-71235901-1', 'auto');
  ga('send', 'pageview');

</script>
<meta name="google-site-verification" content="PuHJs7y90OgOH37jomlyBr-hu1ME7p4zbt8O9C7X8ng" />
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.2daygeek.com/xmlrpc.php">
<title>pip - Easy Way To Manage Python Packages On Linux | 2daygeek.com</title>
<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>

<meta name="description" content="All the major Linux distributions has their own package manager that helps users to install, update, remove packages and update their system to next available" />
<meta name="keywords" content="linux,python,pip,package manager,pypi" />
<link rel="canonical" href="https://www.2daygeek.com/install-pip-manage-python-packages-linux/" />

<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; Feed" href="https://www.2daygeek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; Comments Feed" href="https://www.2daygeek.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; pip &#8211; Easy Way To Manage Python Packages On Linux Comments Feed" href="https://www.2daygeek.com/install-pip-manage-python-packages-linux/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.2daygeek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='spu-css-css' href='https://www.2daygeek.com/wp-content/plugins/social-popup/spu.css?ver=1.6.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='ea-share-count-css' href='https://www.2daygeek.com/wp-content/plugins/EA-Share-Count-master/assets/css/share-count.css?ver=1.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='arconix-shortcodes-css' href='https://www.2daygeek.com/wp-content/plugins/arconix-shortcodes/includes/css/arconix-shortcodes.min.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://www.2daygeek.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='gglcptch-css' href='https://www.2daygeek.com/wp-content/plugins/google-captcha/css/gglcptch.css?ver=1.31' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-main-style-css' href='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/main.min.css?ver=3.3.20' type='text/css' media='all' />
<link rel='stylesheet' id='theme-stylesheet-css' href='https://www.2daygeek.com/wp-content/themes/my-child-theme/style.css?ver=3.3.20' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-font-awesome-css' href='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/font-awesome.min.css?ver=3.3.20' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.2daygeek.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.8' type='text/css' media='all' />
<style id='tablepress-default-inline-css' type='text/css'>
.tablepress tbody td{text-align:left!important;padding:.3em .4em!important}.tablepress td{border:2px solid #DDD}
</style>
<script>
      if (document.location.protocol != "https:") {
          document.location = document.URL.replace(/^http:/i, "https:");
      }
      </script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://connect.facebook.net/en_US/all.js?ver=1.6.4.3#xfbml=1'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=1.6.4.3'></script>
<script type='text/javascript' src='https://apis.google.com/js/plusone.js?ver=1.6.4.3'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/social-popup/spu.js?ver=1.6.4.3'></script>
<link rel='https://api.w.org/' href='https://www.2daygeek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.2daygeek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.2daygeek.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='whereami &#8211; A Small Nifty Tool To Get Your Geolocation Information In Linux' href='https://www.2daygeek.com/whereami-to-get-your-geolocation-information-linux-command-line/' />
<link rel='next' title='How To Use lspci, lsscsi, lsusb, And lsblk To Get Linux System Devices Information' href='https://www.2daygeek.com/check-system-hardware-devices-bus-information-lspci-lsscsi-lsusb-lsblk-linux/' />
<meta name="generator" content="WordPress 4.8.2" />
<link rel='shortlink' href='https://www.2daygeek.com/?p=14992' />
<link rel="alternate" type="application/json+oembed" href="https://www.2daygeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.2daygeek.com%2Finstall-pip-manage-python-packages-linux%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.2daygeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.2daygeek.com%2Finstall-pip-manage-python-packages-linux%2F&#038;format=xml" />
<script type="text/javascript" id="ha-customize-btn">
              jQuery( function($) {
                  $( "#wp-admin-bar-customize").find('a').attr('title', 'Customize this page !' );
              });
            </script>
<style type="text/css" id="ha-fun-ab">
              @-webkit-keyframes super-rainbow {
                0%   { text-shadow : 0px 0px 2px;}
                20%  { text-shadow : 0px 0px 5px; }
                40%  { text-shadow : 0px 0px 10px; }
                60%  { text-shadow : 0px 0px 13px }
                80%  { text-shadow : 0px 0px 10px; }
                100% { text-shadow : 0px 0px 5px; }
              }
              @-moz-keyframes super-rainbow {
                0%   { text-shadow : 0px 0px 2px;}
                20%  { text-shadow : 0px 0px 5px; }
                40%  { text-shadow : 0px 0px 10px; }
                60%  { text-shadow : 0px 0px 13px }
                80%  { text-shadow : 0px 0px 10px; }
                100% { text-shadow : 0px 0px 5px; }
              }

              #wp-admin-bar-customize .ab-item:before {
                  color:#7ECEFD;
                  -webkit-animation: super-rainbow 4s infinite linear;
                   -moz-animation: super-rainbow 4s infinite linear;
              }
            </style>
<style type="text/css">
					.spu-button {
		margin-left:15px;
		margin-left: 15px;
		display: inline-table;
		margin-top: 12px;
		vertical-align: middle;
}
#spu-msg-cont {
	border-bottom:1px solid#ccc;
	border-top:1px solid#ccc;
	background-image:linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);
	background-image:-o-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);
	background-image:-moz-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);
	background-image:-webkit-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);
	background-image:-ms-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);
	background-image:-webkit-gradient(linear,left bottom,left top,color-stop(0,#D8E7FC),color-stop(0.85,#EBF2FC));
	padding:16px;
}
#spu-msg {
	margin:0 0 22px;
}
.step-clear {
	clear:both!important;
}
#spu-title {
	font-family:'Lucida Sans Unicode,Lucida Grande,sans-serif!important;
	font-size:12px;
	padding:12px 0 9px 10px;
	font-size:16px;
}					</style>
<script type="text/javascript">
						jQuery(document).ready(function($){
								
						setTimeout( 
						function(){				
							socialPopUP({
								// Configure display of popup
								advancedClose: true,
								opacity: "0.65",
								s_to_close: "0",
								days_no_click: "99",
								segundos : "seconds",
								esperar : "Wait",
								thanks_msg : "Thanks for supporting our site!!!",
								thanks_sec : "3",
							})
						}
							,1000								);
						});	
						
						
					</script>
<!--[if lt IE 9]>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js"></script>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js"></script>
<![endif]-->
<style type="text/css" id="hu-dynamic-style">/* Dynamic CSS: For no styles in head, copy and put the css below in your child theme's style.css, disable dynamic styles */body { font-size:1.00rem; }@media only screen and (min-width: 720px) {
        .nav > li { font-size:1.00rem; }
      }.container-inner { max-width: 1225px; }::selection { background-color: #3b8dbd; }
::-moz-selection { background-color: #3b8dbd; }a,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #3b8dbd; }.themeform input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #3b8dbd; }.post-format .format-container { border-color: #3b8dbd; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #3b8dbd!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #82b965; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #82b965; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #82b965; }
.post-comments span:before { border-right-color: #82b965; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #3b8dbd}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #3b8dbd; }
              }.is-scrolled #header .nav-container.desktop-sticky,
              .is-scrolled #header .search-expand { background-color: #3b8dbd; background-color: rgba(59,141,189,0.90) }.is-scrolled .topbar-transparent #nav-topbar.desktop-sticky .nav ul { background-color: #3b8dbd; background-color: rgba(59,141,189,0.95) }#header { background-color: #33363b; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #33363b; }
}
        #header #nav-mobile { background-color: #33363b; }.is-scrolled #header #nav-mobile { background-color: #33363b; background-color: rgba(51,54,59,0.90) }#nav-header.nav-container, #main-header-search .search-expand { background-color: #fa720e; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #fa720e; }
}
        img { -webkit-border-radius: 2px; border-radius: 2px; }body { background-color: #eaeaea; }</style>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-14992 single-format-standard wp-custom-logo col-2cl full-width topbar-enabled header-desktop-sticky header-mobile-sticky unknown">
<div id="wrapper">
<header id="header" class="main-menu-mobile-on one-mobile-menu main_menu header-ads-desktop  topbar-transparent">
<nav class="nav-container group mobile-menu mobile-sticky " id="nav-mobile" data-menu-id="header-1">
<div class="mobile-title-logo-in-header"> <p class="site-title"><a class="custom-logo-link" href="https://www.2daygeek.com/" rel="home" title="2daygeek.com | Home page"><img src="https://www.2daygeek.com/wp-content/uploads/2015/12/2day-geek-new-logo-final.png" alt="2daygeek.com"></a></p>
</div>

<div class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false">
<div class="ham__navbar-span-wrapper">
<span class="line line-1"></span>
<span class="line line-2"></span>
<span class="line line-3"></span>
</div>
</div>
<div class="nav-text"></div>
<div class="nav-wrap container">
<ul class="nav container-inner group mobile-search">
<li>
<form method="get" class="searchform themeform" action="https://www.2daygeek.com/">
<div>
<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
</div>
</form> </li>
</ul>
<ul id="menu-menu-2" class="nav container-inner group"><li id="menu-item-6808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6808"><a href="https://www.2daygeek.com/category/linux-distributions/">LINUX DISTRO&#8217;S</a></li>
<li id="menu-item-6806" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6806"><a href="https://www.2daygeek.com/category/linux-commands/">LINUX COMMAND&#8217;S</a></li>
<li id="menu-item-9582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9582"><a href="https://www.2daygeek.com/category/webserver/">WEBSERVER</a></li>
<li id="menu-item-6809" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6809"><a href="https://www.2daygeek.com/category/monitoring-tools/">MONITORING TOOLS</a></li>
<li id="menu-item-6883" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6883"><a href="https://www.2daygeek.com/category/package-management/">PACKAGE MANAGEMENT</a></li>
<li id="menu-item-6811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6811"><a href="https://www.2daygeek.com/category/repository/">REPOSITORY</a></li>
<li id="menu-item-6986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6986"><a href="https://www.2daygeek.com/category/free-cloud-storage/">CLOUD STORAGE</a></li>
<li id="menu-item-14871" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-14871"><a href="https://gbhackers.com/">HACKING</a>
<ul class="sub-menu">
<li id="menu-item-14872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14872"><a href="https://gbhackers.com/">Tutorials</a></li>
</ul>
</li>
</ul> </div>
</nav>
<nav class="nav-container group desktop-menu desktop-sticky " id="nav-topbar" data-menu-id="header-2">
<div class="nav-text"></div>
<div class="topbar-toggle-down">
<i class="fa fa-angle-double-down" aria-hidden="true" data-toggle="down" title="Expand menu"></i>
<i class="fa fa-angle-double-up" aria-hidden="true" data-toggle="up" title="Collapse menu"></i>
</div>
<div class="nav-wrap container">
<ul id="menu-menu-1" class="nav container-inner group"><li id="menu-item-293" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-293"><a href="https://www.2daygeek.com/">HOME</a></li>
<li id="menu-item-10920" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10920"><a href="http://linuxnews.2daygeek.com/">LINUX NEWS</a></li>
<li id="menu-item-294" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294"><a href="https://www.2daygeek.com/about-us/">ABOUT US</a></li>
<li id="menu-item-295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295"><a href="https://www.2daygeek.com/contact-us/">CONTACT US</a></li>
<li id="menu-item-296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-296"><a href="https://www.2daygeek.com/disclaimer/">DISCLAIMER</a></li>
<li id="menu-item-3676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3676"><a href="https://www.2daygeek.com/privacy-policy/">PRIVACY POLICY</a></li>
<li id="menu-item-2729" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2729"><a href="https://www.2daygeek.com/support-us/">SUPPORT US</a></li>
<li id="menu-item-8366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8366"><a href="https://www.2daygeek.com/category/os-tweaks/">OS TWEAK</a></li>
<li id="menu-item-12012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12012"><a href="https://www.2daygeek.com/category/icon-theme/">ICONS</a></li>
<li id="menu-item-12013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12013"><a href="https://www.2daygeek.com/category/gtk-theme/">THEMES</a></li>
</ul> </div>
<div id="topbar-header-search" class="container">
<div class="container-inner">
<div class="toggle-search"><i class="fa fa-search"></i></div>
<div class="search-expand">
<div class="search-expand-inner"><form method="get" class="searchform themeform" action="https://www.2daygeek.com/">
<div>
<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
</div>
</form></div>
</div>
</div>
</div>
</nav>
<div class="container group">
<div class="container-inner">
<div class="group pad central-header-zone">
<div class="logo-tagline-group">
<p class="site-title"><a class="custom-logo-link" href="https://www.2daygeek.com/" rel="home" title="2daygeek.com | Home page"><img src="https://www.2daygeek.com/wp-content/uploads/2015/12/2day-geek-new-logo-final.png" alt="2daygeek.com"></a></p>
</div>
<div id="header-widgets">
<div style="float:left;border:solid 0px;height:90px;width:728px;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="3848983170"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
</div>
<nav class="nav-container group desktop-menu " id="nav-header" data-menu-id="header-3">
<div class="nav-text"></div>
<div class="nav-wrap container">
<ul id="menu-menu-3" class="nav container-inner group"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6808"><a href="https://www.2daygeek.com/category/linux-distributions/">LINUX DISTRO&#8217;S</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6806"><a href="https://www.2daygeek.com/category/linux-commands/">LINUX COMMAND&#8217;S</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9582"><a href="https://www.2daygeek.com/category/webserver/">WEBSERVER</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6809"><a href="https://www.2daygeek.com/category/monitoring-tools/">MONITORING TOOLS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6883"><a href="https://www.2daygeek.com/category/package-management/">PACKAGE MANAGEMENT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6811"><a href="https://www.2daygeek.com/category/repository/">REPOSITORY</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6986"><a href="https://www.2daygeek.com/category/free-cloud-storage/">CLOUD STORAGE</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-14871"><a href="https://gbhackers.com/">HACKING</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14872"><a href="https://gbhackers.com/">Tutorials</a></li>
</ul>
</li>
</ul> </div>
</nav>
</div>
</div>
</header>
<div class="container" id="page">
<div class="container-inner">
<div class="main">
<div class="main-inner group">
<section class="content">
<div class="page-title pad group">
<ul class="meta-single group">
<li class="category"><a href="https://www.2daygeek.com/category/package-management/" rel="category tag">Package Management</a></li>
</ul>
</div>
<div class="pad group">
<article class="post-14992 post type-post status-publish format-standard has-post-thumbnail hentry category-package-management tag-linux tag-package-manager tag-pip tag-pypi tag-python">
<div class="post-inner group">
<h1 class="post-title entry-title">pip &#8211; Easy Way To Manage Python Packages On Linux</h1>
<p class="post-byline">by <span class="vcard author">
<span class="fn"><a href="https://www.2daygeek.com/author/2daygeek/" title="Posts by 2daygeek" rel="author">2daygeek</a></span>
</span> &middot;
<span class="published">Published : September 27, 2017 || Last Updated: September 27, 2017</span>
</p>
<div class="clear"></div>
<div class="entry themeform">
<div class="entry-inner">

<div style="float:left;margin:10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="8826511175"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class="ea-share-count-wrap before_content"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.2daygeek.com/install-pip-manage-python-packages-linux/&#038;display=popup&#038;ref=plugin&#038;src=share_button" title="Share on Facebook" target="_blank" class="ea-share-count-button style-fancy ea-share-no-count facebook" data-postid="14992"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon easc-icon-facebook"></i><span class="ea-share-count-label">Facebook</span></span><span class="ea-share-count">0</span></a><a href="https://twitter.com/share?url=https://www.2daygeek.com/install-pip-manage-python-packages-linux/&#038;text=pip &#8211; Easy Way To Manage Python Packages On Linux" title="Share on Twitter" target="_blank" class="ea-share-count-button style-fancy ea-share-no-count twitter" data-postid="14992"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon easc-icon-twitter"></i><span class="ea-share-count-label">Tweet</span></span><span class="ea-share-count">0</span></a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://www.2daygeek.com/install-pip-manage-python-packages-linux/" title="Share on LinkedIn" target="_blank" class="ea-share-count-button style-fancy ea-share-no-count linkedin" data-postid="14992"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon easc-icon-linkedin"></i><span class="ea-share-count-label">LinkedIn</span></span><span class="ea-share-count">0</span></a><a href="https://plus.google.com/share?url=https://www.2daygeek.com/install-pip-manage-python-packages-linux/" title="Share on Google+" target="_blank" class="ea-share-count-button style-fancy ea-share-no-count google" data-postid="14992"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon easc-icon-google-plus"></i><span class="ea-share-count-label">Google+</span></span><span class="ea-share-count">0</span></a></div>
<p>All the major Linux distributions has their own package manager that helps users to install, update, remove packages and update their system to next available version (i mean, operating system upgrade can be taken care in the same way as well). </p>
<p>When it comes to python based applications, you wont get a latest version of packages from distribution official repository since those were already included in the repository at the time of operating system build.</p>
<p>Dev team wont rebuild all the packages whenever new release come until its necessary to fix some important bug. So, i would advise you to install pip on your system to get a latest version of python build packages from python repository.</p>
<p>We have already covered in our previous article about other package managers such as Yum, Dnf, Apt-Get, Apt, Rpm, Dpkg, and Snop.</p>
<p style="padding: 15px; background-color: #dbe7f8; border: 1px solid #b0cbf0; color: #1e529c;"><strong>Suggested Read : </strong><br />
<strong>(#) </strong> <a style="color: #1e529c; text-decoration: none;" href="https://www.2daygeek.com/yum-command-examples-manage-packages-rhel-centos-systems/" target="_blank">YUM Command To Manage Packages on RHEL/CentOS Systems</a><br />
<strong>(#) </strong> <a style="color: #1e529c; text-decoration: none;" href="https://www.2daygeek.com/dnf-command-examples-manage-packages-fedora-system/" target="_blank">DNF (Fork of YUM) Command To Manage Packages on Fedora System</a><br />
<strong>(#) </strong> <a style="color: #1e529c; text-decoration: none;" href="https://www.2daygeek.com/zypper-command-examples-manage-packages-opensuse-system/" target="_blank">Zypper Command To Manage Packages On openSUSE &#038; suse Systems</a><br />
<strong>(#) </strong> <a style="color: #1e529c; text-decoration: none;" href="https://www.2daygeek.com/apt-get-apt-cache-command-examples-manage-packages-debian-ubuntu-systems/" target="_blank">Apt-Get &#038; Apt-Cache commands to manage packages on Debian Based Systems</a><br />
<strong>(#) </strong> <a style="color: #1e529c; text-decoration: none;" href="https://www.2daygeek.com/pacman-command-examples-manage-packages-arch-linux-system/" target="_blank">Pacman Command To Manage Packages On Arch Linux Based Systems</a><br />
<strong>(#) </strong> <a style="color: #1e529c; text-decoration: none;" href="https://www.2daygeek.com/apt-command-examples-manage-packages-debian-ubuntu-systems/" target="_blank">APT (Advanced Packaging Tool) : Advanced Package Management tool for Debian Based Systems</a><br />
<strong>(#) </strong> <a style="color: #1e529c; text-decoration: none;" href="https://www.2daygeek.com/snap-command-examples/" target="_blank">Snap Brand New Package Manager for Ubuntu</a><br />
<strong>(#) </strong> <a style="color: #1e529c; text-decoration: none;" href="https://www.2daygeek.com/urpmi-command-examples/" target="_blank">URPMI Package Management tool for Mageia System</a><br />
<strong>(#) </strong> <a style="color: #1e529c; text-decoration: none;" href="https://www.2daygeek.com/dpkg-command-to-manage-packages-on-debian-ubuntu-linux-mint-systems/" target="_blank">Dpkg Command To Manage Packages On Debian Based Systems</a><br />
<strong>(#) </strong> <a style="color: #1e529c; text-decoration: none;" href="https://www.2daygeek.com/rpm-command-examples/" target="_blank">RPM commands to manage packages on RHEL based systems</a>
</p>
<h4>What&#8217;s Python</h4>
<p> Python is a widely used high-level programming language for general-purpose programming that lets you work quickly and integrate systems more effectively.</p>
<h4>What&#8217;s pip</h4>
<p> pip is a modern python module bundled with setuptools, it’s one of the recommended tool for installing Python packages in Linux.</p>
<h4>What&#8217;s PyPi</h4>
<p> The Python Package Index (PyPi) is a repository of software for the Python programming language and currently 117803 packages are available.</p>

<div style="float:left;margin:10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="3265433976"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<h4>How to Install pip</h4>
<p> Run the following commands based on your distribution to install pip on Linux.</p>
<p>For <strong><code>Debian/Ubuntu</code></strong>, use <a href="https://www.2daygeek.com/apt-get-apt-cache-command-examples-manage-packages-debian-ubuntu-systems/" target="_blank">apt-get command</a> or <a href="https://www.2daygeek.com/apt-command-examples-manage-packages-debian-ubuntu-systems/" target="_blank">apt command</a> to install pip.</p>
<pre><span style="color: #848484;">[For Python2]</span>
$ sudo apt install python-pip python-setuptools

<span style="color: #848484;">[For Python3]</span>
$ sudo apt install python3-pip
</pre>
<p>pip doesn&#8217;t shipped with <strong><code>RHEL/CentOS</code></strong> system official repository so, enable <a href="https://www.2daygeek.com/yum-command-examples-manage-packages-rhel-centos-systems/" target="_blank">EPEL Repository</a> and use <a href="https://www.2daygeek.com/yum-command-examples-manage-packages-rhel-centos-systems/" target="_blank">YUM command</a> to install pip.</p>
<pre>$ sudo yum install python-pip python-devel python-setuptools
</pre>
<p>For <strong><code>Fedora</code></strong> system, use <a href="https://www.2daygeek.com/dnf-command-examples-manage-packages-fedora-system/" target="_blank">dnf Command</a> to install pip.</p>
<pre><span style="color: #848484;">[For Python2]</span>
$ sudo dnf install python-pip

<span style="color: #848484;">[For Python3]</span>
$ sudo dnf install python3
</pre>
<p>For <strong><code>Arch Linux</code></strong> based systems, use <a href="https://www.2daygeek.com/pacman-command-examples-manage-packages-arch-linux-system/" target="_blank">Pacman Command</a> to install pip.</p>
<pre><span style="color: #848484;">[For Python2]</span>
$ sudo pacman -S python2-pip python-setuptools

<span style="color: #848484;">[For Python3]</span>
$ sudo pacman -S python-pip python3-setuptools
</pre>
<p>For <strong><code>openSUSE</code></strong> system, use <a href="https://www.2daygeek.com/zypper-command-examples-manage-packages-opensuse-system/" target="_blank">Zypper Command</a> to install pip.</p>
<pre><span style="color: #848484;">[For Python2]</span>
$ sudo pacman -S python-pip

<span style="color: #848484;">[For Python3]</span>
$ sudo pacman -S python3-pip
</pre>
<p>Run the following command to upgrade pip to latest available version</p>

<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-7730570141079407" data-ad-slot="5150237910"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<pre>$ sudo pip install -U pip
</pre>
<h4>How to Use pip</h4>
<p> pip tool comes with easy to use syntax like how other Linux distribution package mangers has. It help users to install, remove, search, and update python packages smoothly from python repository.</p>
<pre>pip [command] [options] [Pacakge Name]
</pre>
<h4>How to Install Package</h4>
<p> Install package and its dependencies from PyPI.</p>
<pre>pip [install] [options] [Pacakge Name]
</pre>
<p>1) Install latest version of python package.</p>
<pre>$ sudo pip install netutils-linux
Collecting netutils-linux
Collecting argparse (from netutils-linux)
  Using cached argparse-1.4.0-py2.py3-none-any.whl
Collecting colorama (from netutils-linux)
  Using cached colorama-0.3.9-py2.py3-none-any.whl
Collecting prettytable (from netutils-linux)
Collecting ipaddress (from netutils-linux)
  Using cached ipaddress-1.0.18-py2-none-any.whl
Collecting six (from netutils-linux)
  Using cached six-1.11.0-py2.py3-none-any.whl
Collecting pyyaml (from netutils-linux)
Installing collected packages: argparse, colorama, prettytable, ipaddress, six, pyyaml, netutils-linux
Successfully installed argparse-1.4.0 colorama-0.3.9 ipaddress-1.0.18 netutils-linux-2.5.0 prettytable-0.7.2 pyyaml-3.12 six-1.11.0
</pre>
<p>2) Install specific version of python package.</p>
<pre>$ sudo pip install netutils-linux==1.0.4
</pre>
<p>3) Install Minimum version of python package.</p>
<pre>$ sudo pip install 'netutils-linux>=1.0.4'
</pre>
<p>4) Install Development version of python package. By default, pip only finds stable versions.</p>

<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script id="mNCC" language="javascript">  medianet_width='728';  medianet_height= '90';  medianet_crid='827143833';  </script> <script id="mNSC" src="https://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script>
</div>
<pre>$ sudo pip install --pre netutils-linux
</pre>
<h4>How to Upgrade a Package</h4>
<p> Upgrade specified packages to the newest available version.</p>
<pre>$ sudo pip install --upgrade netutils-linux
Collecting netutils-linux
  Downloading netutils-linux-2.5.0.tar.gz
Collecting argparse (from netutils-linux)
  Downloading argparse-1.4.0-py2.py3-none-any.whl
Collecting colorama (from netutils-linux)
  Downloading colorama-0.3.9-py2.py3-none-any.whl
Collecting ipaddress (from netutils-linux)
  Downloading ipaddress-1.0.18-py2-none-any.whl
Collecting prettytable (from netutils-linux)
  Downloading prettytable-0.7.2.zip
Collecting pyyaml (from netutils-linux)
  Downloading PyYAML-3.12.tar.gz (253kB)
    100% |████████████████████████████████| 256kB 734kB/s 
Collecting six (from netutils-linux)
  Downloading six-1.11.0-py2.py3-none-any.whl
Building wheels for collected packages: netutils-linux, prettytable, pyyaml
  Running setup.py bdist_wheel for netutils-linux ... done
  Stored in directory: /home/magi/.cache/pip/wheels/d9/bd/18/7d5e9f30030c84d15025b30f83b01161ac52beb6992596bb48
  Running setup.py bdist_wheel for prettytable ... done
  Stored in directory: /home/magi/.cache/pip/wheels/b6/90/7b/1c22b89217d0eba6d5f406e562365ebee804f0d4595b2bdbcd
  Running setup.py bdist_wheel for pyyaml ... done
  Stored in directory: /home/magi/.cache/pip/wheels/2c/f7/79/13f3a12cd723892437c0cfbde1230ab4d82947ff7b3839a4fc
Successfully built netutils-linux prettytable pyyaml
Installing collected packages: argparse, colorama, ipaddress, prettytable, pyyaml, six, netutils-linux
Successfully installed argparse-1.4.0 colorama-0.3.9 ipaddress-1.0.18 netutils-linux-2.5.0 prettytable-0.7.2 pyyaml-3.12 six-1.11.0
</pre>
<h4>How to Download a Package</h4>
<p> Download a package and all of its dependencies into directory instead of install.</p>
<pre>$ sudo pip download netutils-linux
Collecting netutils-linux
  Using cached netutils-linux-2.5.0.tar.gz
  Saved ./netutils-linux-2.5.0.tar.gz
Collecting argparse (from netutils-linux)
  Using cached argparse-1.4.0-py2.py3-none-any.whl
  Saved ./argparse-1.4.0-py2.py3-none-any.whl
Collecting colorama (from netutils-linux)
  Using cached colorama-0.3.9-py2.py3-none-any.whl
  Saved ./colorama-0.3.9-py2.py3-none-any.whl
Collecting ipaddress (from netutils-linux)
  Using cached ipaddress-1.0.18-py2-none-any.whl
  Saved ./ipaddress-1.0.18-py2-none-any.whl
Collecting prettytable (from netutils-linux)
  Using cached prettytable-0.7.2.zip
  Saved ./prettytable-0.7.2.zip
Collecting pyyaml (from netutils-linux)
  Using cached PyYAML-3.12.tar.gz
  Saved ./PyYAML-3.12.tar.gz
Collecting six (from netutils-linux)
  Using cached six-1.11.0-py2.py3-none-any.whl
  Saved ./six-1.11.0-py2.py3-none-any.whl
Successfully downloaded netutils-linux argparse colorama ipaddress prettytable pyyaml six
</pre>
<h4>How to Uninstall a Package</h4>
<p> pip is able to uninstall most installed packages.</p>
<pre>$ sudo pip uninstall netutils-linux
Uninstalling netutils-linux-2.5.0:
  /home/magi/.local/bin/autorps
  /home/magi/.local/bin/autotune-reductor
  /home/magi/.local/bin/autoxps
  /home/magi/.local/bin/detect_virt.py
  /home/magi/.local/bin/detect_virt.pyc
  /home/magi/.local/bin/irqtop
  /home/magi/.local/bin/link-rate
  /home/magi/.local/bin/maskify
  /home/magi/.local/bin/maximize-cpu-freq
  /home/magi/.local/bin/network-top
.
.
  /home/magi/.local/lib/python2.7/site-packages/netutils_linux_tuning/test_rss_ladder.pyc
  /home/magi/.local/lib/python2.7/site-packages/netutils_linux_tuning/test_rx_buffers.py
  /home/magi/.local/lib/python2.7/site-packages/netutils_linux_tuning/test_rx_buffers.pyc
Proceed (y/n)? y
  Successfully uninstalled netutils-linux-2.5.0
</pre>
<h4>How to List installed packages</h4>
<p> List installed packages, including editables.</p>
<p>1) List installed packages.</p>
<pre>$ pip list
adium-theme-ubuntu (0.3.4)
beautifulsoup4 (4.5.3)
certifi (2017.7.27.1)
chardet (3.0.4)
colorama (0.3.9)
configobj (5.0.6)
cryptography (1.7.1)
enum34 (1.1.6)
green-recorder (3.0.4)
html5lib (0.999999999)
idna (2.6)
ipaddress (1.0.18)
keyring (10.3.1)
keyrings.alt (2.2)
lxml (3.7.3)
.
.
</pre>
<p>2) List outdated packages (excluding editables), and the latest version available.</p>
<pre>$ pip list --outdated
beautifulsoup4 (4.5.3) - Latest: 4.6.0 [wheel]
certifi (2017.7.27.1) - Latest: 2017.7.27.1 [wheel]
chardet (3.0.4) - Latest: 3.0.4 [wheel]
colorama (0.3.9) - Latest: 0.3.9 [wheel]
configobj (5.0.6) - Latest: 5.0.6 [sdist]
cryptography (1.7.1) - Latest: 2.0.3 [wheel]
enum34 (1.1.6) - Latest: 1.1.6 [wheel]
html5lib (0.999999999) - Latest: 0.999999999 [wheel]
idna (2.6) - Latest: 2.6 [wheel]
ipaddress (1.0.18) - Latest: 1.0.18 [wheel]
keyring (10.3.1) - Latest: 10.4.0 [wheel]
keyrings.alt (2.2) - Latest: 2.3 [wheel]
lxml (3.7.3) - Latest: 4.0.0 [wheel]
ndg-httpsclient (0.4.2) - Latest: 0.4.3 [wheel]
netutils-linux (2.5.0) - Latest: 2.5.0 [sdist]
numpy (1.12.1) - Latest: 1.13.1 [wheel]
Pillow (4.0.0) - Latest: 4.2.1 [wheel]
pip (9.0.1) - Latest: 9.0.1 [wheel]
.
.
</pre>
<p>2) List installed packages with column formatting.</p>
<pre>$ pip list --format columns
Package            Version                                                 
------------------ --------------------------------------------------------
adium-theme-ubuntu 0.3.4                                                   
beautifulsoup4     4.5.3                                                   
certifi            2017.7.27.1                                             
chardet            3.0.4                                                   
colorama           0.3.9                                                   
configobj          5.0.6                                                   
cryptography       1.7.1                                                   
enum34             1.1.6                                                   
green-recorder     3.0.4                                                   
html5lib           0.999999999                                             
idna               2.6                                                     
ipaddress          1.0.18                                                  
keyring            10.3.1                                                  
keyrings.alt       2.2                                                     
lxml               3.7.3                                                   
ndg-httpsclient    0.4.2                                                   
netutils-linux     2.5.0                                                   
numpy              1.12.1                                                  
Pillow             4.0.0                                                   
pip                9.0.1                                                   
powerline-status   2.6.dev9999+git.9bebc2fe7f0f6a73412c515711d94c2177e31553
prettytable        0.7.2
.
.
</pre>
<h4>Print installed packages info</h4>
<p> Show information about one or more installed packages.</p>
<p>1) Show information about a package.</p>
<pre>$ pip show netutils-linux
Name: netutils-linux
Version: 2.5.0
Summary: Bunch of utils to simplify linux network troubleshooting and performance tuning.
Home-page: https://github.com/strizhechenko/netutils-linux
Author: Oleg Strizhechenko
Author-email: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="80efece5e7aef3f4f2e9fae8e5e3e8e5eeebefc0e7ede1e9ecaee3efed">[email&#160;protected]</a>
License: MIT
Location: /home/magi/.local/lib/python2.7/site-packages
Requires: argparse, colorama, prettytable, ipaddress, six, pyyaml
</pre>
<p>2) Show all information (detailed information) about a package.</p>
<pre>$ pip show --verbose netutils-linux
Name: netutils-linux
Version: 2.5.0
Summary: Bunch of utils to simplify linux network troubleshooting and performance tuning.
Home-page: https://github.com/strizhechenko/netutils-linux
Author: Oleg Strizhechenko
Author-email: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="513e3d34367f222523382b39343239343f3a3e11363c30383d7f323e3c">[email&#160;protected]</a>
License: MIT
Location: /home/magi/.local/lib/python2.7/site-packages
Requires: argparse, colorama, prettytable, ipaddress, six, pyyaml
Metadata-Version: 2.0
Installer: pip
Classifiers:
  Development Status :: 3 - Alpha
  Intended Audience :: Developers
  Operating System :: MacOS
  Operating System :: POSIX
  Programming Language :: Python
  Programming Language :: Python :: 2.6
  Programming Language :: Python :: 2.7
  Programming Language :: Python :: 3.4
  Programming Language :: Python :: 3.6
  Topic :: Software Development
  Topic :: Utilities
Entry-points:
</pre>
<h4>Search a package</h4>
<p> Search a packages from PyPI.</p>
<pre>$ pip search netutils-linux
linux-system-administration (0.0.1)                    - Installation and Update-Files for Ubuntu
alignak_checks_linux_nrpe (0.4.2)                      - Alignak checks pack for Linux NRPE monitored hosts
fetch-linux-security-patches-and-kernel (0.0.1.dev10)  - Download the latest linux-hardened or unofficial grsecurity 4.9 patch and the matching linux kernel version.
appdynamics-proxysupport-linux-x64 (1.8.0.51.1)        - Proxysupport for AppDynamics Python agent
appdynamics-proxysupport-linux-x86 (1.8.0.51.1)        - Proxysupport for AppDynamics Python agent
appdynamics-bindeps-linux-x86 (7.0)                    - Dependencies for AppDynamics Python agent
appdynamics-bindeps-linux-x64 (7.0)                    - Dependencies for AppDynamics Python agent
HTSeq-arm-linux (0.6.1)                                - HTSeq for ARM (armv7l) Linux GNUroot Debian on NVIDIA Shield Tablet [Tegra K1]
pysam-arm-linux (0.8.3)                                - pysam for ARM (armv7l) Linux GNUroot Debian on Nvidia Shield Tablet [Tegra K1]
box-linux-sync (0.1.0)                                 - Linux client for Box.com
detect_linux_distro (1.3)                              - Detect Linux distribution
dots-linux (0.0.1)                                     - Linux System Manager.
EpistaSim_Linux (1.1.0)                                - Epistasis simulator of SNP patterns in Linux
ITI1480A-linux (3.0)                                   - Tools for the ITI1480A usb protocol analyser
netshow-linux-lib (1.1.5)                              - Netshow Provider for Linux Operating Systems
straw-linux (0.0.1)                                    - A simple OS monitoring for linux
TransFabric-Python2X-Linux-x64 (1.0)                   - 
linux (0.0)                                            - 
Linux-Screen-Reader (0.2.1)                            - Linux Screen Reader: Extensible assistive technology
linux-nethelp (1.0.1)                                  - linux network helpers - e.g. list interfaces and their IP addresses
tourbillon-linux (0.4.1)                               - A tourbillon plugin for collecting metrics from linux.
linux-metrics (0.1.4)                                  - linux-metrics - System Metrics/Stats Library for Linux
linux-utils (0.5)                                      - Linux system administration tools for Python
netutils-linux (2.5.0)                                 - Bunch of utils to simplify linux network troubleshooting and performance tuning.
  INSTALLED: 2.5.0 (latest)
mccdaq_linux (1.4.8)                                   - Python drivers for Measurement Computing devices (mccdaq.com) on linux
vapour_linux_amd64 (0.2.1)                             - This package contains binary executable dependencies for the master.
</pre>
<h4>freeze command usage</h4>
<p> Output installed packages in requirements format which help us to install all the packages into another environment like Python2 to Python3 environment when you want to move all the installed packages.</p>
<pre>$ sudo pip freeze
$ sudo env1/bin/pip freeze > requirements.txt
$ sudo env2/bin/pip install -r requirements.txt
</pre>
<p>If you want to know more option which is available for pip, simply navigate to man page.</p>
<pre>$ pip help
</pre>

<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script>!function(e,t,r,n,c,a,l){function i(t,r){return r=e.createElement('div'),r.innerHTML='<a href="'+t.replace(/"/g,'&quot;')+'"></a>',r.childNodes[0].getAttribute('href')}function o(e,t,r,n){for(r='',n='0x'+e.substr(t,2)|0,t+=2;t<e.length;t+=2)r+=String.fromCharCode('0x'+e.substr(t,2)^n);return i(r)}try{for(c=e.getElementsByTagName('a'),l='/cdn-cgi/l/email-protection#',n=0;n<c.length;n++)try{(t=(a=c[n]).href.indexOf(l))>-1&&(a.href='mailto:'+o(a.href,t+l.length))}catch(e){}for(c=e.querySelectorAll('.__cf_email__'),n=0;n<c.length;n++)try{(a=c[n]).parentNode.replaceChild(e.createTextNode(o(a.getAttribute('data-cfemail'),0)),a)}catch(e){}}catch(e){}}(document);</script><script id="mNCC" language="javascript">
   medianet_width = "728";
   medianet_height = "90";
   medianet_crid = "847533357";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUF666N9' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div>
<p>Reference Link : <a href="https://pip.pypa.io/en/stable/reference/pip_install/#pip-install" rel="noopener" target="_blank">pip usage</a></p>

<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-7730570141079407" data-ad-slot="9495141575"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div style="font-size:0px;height:0px;line-height:0px;margin:0;padding:0;clear:both"></div><div class="ea-share-count-wrap after_content"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.2daygeek.com/install-pip-manage-python-packages-linux/&display=popup&ref=plugin&src=share_button" title="Share on Facebook" target="_blank" class="ea-share-count-button style-fancy ea-share-no-count facebook" data-postid="14992"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon easc-icon-facebook"></i><span class="ea-share-count-label">Facebook</span></span><span class="ea-share-count">0</span></a><a href="https://twitter.com/share?url=https://www.2daygeek.com/install-pip-manage-python-packages-linux/&text=pip &#8211; Easy Way To Manage Python Packages On Linux" title="Share on Twitter" target="_blank" class="ea-share-count-button style-fancy ea-share-no-count twitter" data-postid="14992"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon easc-icon-twitter"></i><span class="ea-share-count-label">Tweet</span></span><span class="ea-share-count">0</span></a><a href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.2daygeek.com/install-pip-manage-python-packages-linux/" title="Share on LinkedIn" target="_blank" class="ea-share-count-button style-fancy ea-share-no-count linkedin" data-postid="14992"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon easc-icon-linkedin"></i><span class="ea-share-count-label">LinkedIn</span></span><span class="ea-share-count">0</span></a><a href="https://plus.google.com/share?url=https://www.2daygeek.com/install-pip-manage-python-packages-linux/" title="Share on Google+" target="_blank" class="ea-share-count-button style-fancy ea-share-no-count google" data-postid="14992"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon easc-icon-google-plus"></i><span class="ea-share-count-label">Google+</span></span><span class="ea-share-count">0</span></a></div> <nav class="pagination group">
</nav>
</div>
<div class="clear"></div>
</div>
</div>
</article>
<div class="clear"></div>
<p class="post-tags"><span>Tags:</span> <a href="https://www.2daygeek.com/tag/linux/" rel="tag">Linux</a><a href="https://www.2daygeek.com/tag/package-manager/" rel="tag">package manager</a><a href="https://www.2daygeek.com/tag/pip/" rel="tag">pip</a><a href="https://www.2daygeek.com/tag/pypi/" rel="tag">PyPi</a><a href="https://www.2daygeek.com/tag/python/" rel="tag">python</a></p>
<ul class="post-nav group">
<li class="next"><a href="https://www.2daygeek.com/check-system-hardware-devices-bus-information-lspci-lsscsi-lsusb-lsblk-linux/" rel="next"><i class="fa fa-chevron-right"></i><strong>Next story</strong> <span>How To Use lspci, lsscsi, lsusb, And lsblk To Get Linux System Devices Information</span></a></li>
<li class="previous"><a href="https://www.2daygeek.com/whereami-to-get-your-geolocation-information-linux-command-line/" rel="prev"><i class="fa fa-chevron-left"></i><strong>Previous story</strong> <span>whereami &#8211; A Small Nifty Tool To Get Your Geolocation Information In Linux</span></a></li>
</ul>
<h4 class="heading">
<i class="fa fa-hand-o-right"></i>You may also like...</h4>
<ul class="related-posts group">
<li class="related post-hover">
<article class="post-11540 post type-post status-publish format-standard has-post-thumbnail hentry category-arch-linux category-package-management tag-arch-user-repository tag-aur tag-install-aur-package tag-package-manager tag-yaourt">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/install-yaourt-aur-helper-on-arch-linux/" title="Yaourt &#8211; Arch User Repository (AUR) Helper For Arch Linux">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.2daygeek.com/wp-content/uploads/2016/07/install-yaourt-on-arch-linux-520x245.png" width="520" height="245" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt data-srcset="https://www.2daygeek.com/wp-content/uploads/2016/07/install-yaourt-on-arch-linux-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2016/07/install-yaourt-on-arch-linux-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px"><noscript><img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2016/07/install-yaourt-on-arch-linux-520x245.png"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2016/07/install-yaourt-on-arch-linux-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2016/07/install-yaourt-on-arch-linux-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /></noscript> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/install-yaourt-aur-helper-on-arch-linux/" rel="bookmark" title="Yaourt &#8211; Arch User Repository (AUR) Helper For Arch Linux">Yaourt &#8211; Arch User Repository (AUR) Helper For Arch Linux</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2016-08-02 00:05:43">August 2, 2016</time>
</p>
</div>
</div>
</article>
</li>
<li class="related post-hover">
<article class="post-8502 post type-post status-publish format-standard has-post-thumbnail hentry category-package-management tag-apt-cache tag-apt-get tag-package-management-tool tag-package-manager">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/apt-get-apt-cache-command-examples-manage-packages-debian-ubuntu-systems/" title="Apt-Get &#038; Apt-Cache commands to manage packages on Debian Based Systems">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.2daygeek.com/wp-content/uploads/2016/01/apt-get-apt-cache-command-examples-520x245.png" width="520" height="245" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt data-srcset="https://www.2daygeek.com/wp-content/uploads/2016/01/apt-get-apt-cache-command-examples-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2016/01/apt-get-apt-cache-command-examples-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px"><noscript><img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2016/01/apt-get-apt-cache-command-examples-520x245.png"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2016/01/apt-get-apt-cache-command-examples-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2016/01/apt-get-apt-cache-command-examples-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /></noscript> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/apt-get-apt-cache-command-examples-manage-packages-debian-ubuntu-systems/" rel="bookmark" title="Apt-Get &#038; Apt-Cache commands to manage packages on Debian Based Systems">Apt-Get &#038; Apt-Cache commands to manage packages on Debian Based Systems</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2016-01-31 00:05:18">January 31, 2016</time>
</p>
</div>
</div>
</article>
</li>
<li class="related post-hover">
<article class="post-8495 post type-post status-publish format-standard has-post-thumbnail hentry category-package-management tag-package-management-tool tag-package-manager tag-zypper">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/zypper-command-examples-manage-packages-opensuse-system/" title="Zypper Command To Manage Packages On openSUSE &#038; suse Systems">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.2daygeek.com/wp-content/uploads/2016/01/zypper-command-examples-1-520x245.png" width="520" height="245" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt data-srcset="https://www.2daygeek.com/wp-content/uploads/2016/01/zypper-command-examples-1-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2016/01/zypper-command-examples-1-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px"><noscript><img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2016/01/zypper-command-examples-1-520x245.png"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2016/01/zypper-command-examples-1-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2016/01/zypper-command-examples-1-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /></noscript> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/zypper-command-examples-manage-packages-opensuse-system/" rel="bookmark" title="Zypper Command To Manage Packages On openSUSE &#038; suse Systems">Zypper Command To Manage Packages On openSUSE &#038; suse Systems</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2016-01-28 00:05:09">January 28, 2016</time>
</p>
</div>
</div>
</article>
</li>
</ul>
<div id="disqus_thread">
</div>
</div>
</section>
<div class="sidebar s1 collapsed" data-position="right" data-layout="col-2cl" data-sb-id="s1">
<a class="sidebar-toggle" title="Expand Sidebar"><i class="fa icon-sidebar-toggle"></i></a>
<div class="sidebar-content">
<div class="sidebar-top group">
<p>Follow:</p>
<ul class="social-links"><li><a rel="nofollow" class="social-tooltip" title="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Google+" href="https://www.google.com/+2daygeeks" target="_blank" style="color:#ffffff"><i class="fa fa-google-plus"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fa fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fa fa-tumblr"></i></a></li></ul> </div>
<div id="text-8" class="widget widget_text"><h3 class="widget-title">&#8211; Click Here To Get Offers &#8211;</h3> <div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="7612209571"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div><div id="text-10" class="widget widget_text"><h3 class="widget-title">&#8211; For Better Offers &#8211;</h3> <div class="textwidget"><script id="mNCC" language="javascript">  medianet_width='300';  medianet_height= '250';  medianet_crid='108135239';  </script> <script id="mNSC" src="https://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script></div>
</div><div id="text-12" class="widget widget_text"><h3 class="widget-title">-Unmatched Offers For Linux Users-</h3> <div class="textwidget"></div>
</div> <div id="wp_subscribe-3" class="widget wp_subscribe">
<div id="wp-subscribe" class="wp-subscribe-wrap wp-subscribe wp-subscribe-1" data-thanks_page="0" data-thanks_page_url="" data-thanks_page_new_window="0">
<h4 class="title">Get Latest LINUX Tips</h4>
<p class="text"></p>
<form action="https://feedburner.google.com/fb/a/mailverify?uri=2daygeekfeed" method="post" class="wp-subscribe-form wp-subscribe-feedburner" id="wp-subscribe-form-1" target="popupwindow">
<input class="regular-text email-field" type="text" name="email" placeholder="Enter your email here">
<input type="hidden" name="uri" value="2daygeekfeed">
<input type="hidden" name="loc" value="en_US">
<input type="hidden" name="form_type" value="widget">
<input type="hidden" name="service" value="feedburner">
<input type="hidden" name="widget" value="wp_subscribe-3">
<input class="submit" type="submit" name="submit" value="Sign Up Now">
</form>
<div class="wp-subscribe-loader">
<svg version="1.1" id="loader-1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0" y="0" width="40px" height="40px" viewBox="0 0 50 50" style="enable-background:new 0 0 50 50;" xml:space="preserve">
<path fill="" d="M43.935,25.145c0-10.318-8.364-18.683-18.683-18.683c-10.318,0-18.683,8.365-18.683,18.683h4.068c0-8.071,6.543-14.615,14.615-14.615c8.072,0,14.615,6.543,14.615,14.615H43.935z">
<animateTransform attributeType="xml" attributeName="transform" type="rotate" from="0 25 25" to="360 25 25" dur="0.6s" repeatCount="indefinite" />
</path>
</svg>
</div>
<p class="thanks">Thank you for subscribing.</p>
<p class="error">Something went wrong.</p>
<div class="clear"></div>
<p class="footer-text"></p>
</div>
</div>
<div id="text-3" class="widget widget_text"> <div class="textwidget"><script>
  (function() {
    var cx = '014898341766687711766:ajz3putspfm';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//www.google.com/cse/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only></div>
</div><div id="text-6" class="widget widget_text"> <div class="textwidget"><div id="google_translate_element"></div><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script></div>
</div><div id="text-5" class="widget widget_text"><h3 class="widget-title">Follow us</h3> <div class="textwidget">
<div class="g-page" data-href="//plus.google.com/107364365185869631781" data-layout="landscape" data-rel="publisher"></div>

<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/platform.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<footer id="footer">
<section class="container" id="footer-bottom">
<div class="container-inner">
<a id="back-to-top" href="#"><i class="fa fa-angle-up"></i></a>
<div class="pad group">
<div class="grid one-half">
<div id="copyright">
<p>2daygeek.com &copy; 2017. All Rights Reserved.</p>
</div>
<div id="credit" style="">
<p><a href="https://www.2daygeek.com">2daygeek</a> :- Linux Tips & Tricks, Linux How-to Guides & Tutorials is licensed under a <a href="https://creativecommons.org/licenses/by-nc/4.0/" rel="nofollow">(cc) BY-NC</a></p>
</div>
</div>
<div class="grid one-half last">
<ul class="social-links"><li><a rel="nofollow" class="social-tooltip" title="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Google+" href="https://www.google.com/+2daygeeks" target="_blank" style="color:#ffffff"><i class="fa fa-google-plus"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fa fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fa fa-tumblr"></i></a></li></ul> </div>
</div>
</div>
</section>
</footer>
</div>
<div id="spu-bg"></div>
<div id="spu-main"><a href="#" onClick="spuFlush(99);" id="spu-close">Close</a><div id='spu-title'>Please support the site</div>
<div id='spu-msg-cont'>
<div id='spu-msg'>
By clicking any of these buttons you help our site to get better </br>
<div class="spu-button spu-twitter"><a href="https://twitter.com/2daygeek" class="twitter-follow-button" data-show-count="false">Follow Me</a></div> <div class="spu-button spu-facebook"><div id="fb-root"></div><div class="fb-like" data-href="https://www.facebook.com/2daygeek" data-send="false" data-width="450" data-show-faces="true" data-layout="button_count"></div></div> <div class="spu-button spu-google"><div class="g-plusone" data-callback="googleCB" data-onendinteraction="closeGoogle" data-recommendations="false" data-annotation="bubble" data-size="medium" data-href="https://www.google.com/+2daygeeks"></div></div>
</div>
<div class='step-clear'></div>
</div><span id="spu-timer"></span><div id="spu-bottom"></div></div><link rel='stylesheet' id='wp-subscribe-css' href='https://www.2daygeek.com/wp-content/plugins/wp-subscribe/assets/css/wp-subscribe-form.css?ver=4.8.2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/EA-Share-Count-master/assets/js/share-count.js?ver=1.8.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.2daygeek.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/hueman-addons/addons/assets/front/js/jQuerySharrre.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/wf-cookie-consent/js/cookiechoices.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"","extLinksTargetExt":"","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"1","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":true,"mobile":true},"isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_up","mobile":"stick_up"},"isDevMode":"","ajaxUrl":"https:\/\/www.2daygeek.com\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"59a50300b5"},"userStarted":{"with":"with|3.0.11","on":{"date":"2017-08-08 07:25:43.000000","timezone_type":3,"timezone":"UTC"}},"isWelcomeNoteOn":"","welcomeContent":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/scripts.min.js?ver=3.3.20'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/comment-reply.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?ver=0.6.1'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/lazy-load/js/lazy-load.js?ver=0.6.1'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/wp-embed.min.js?ver=4.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.8.2","language":""},"disqusIdentifier":"14992 https:\/\/www.2daygeek.com\/?p=14992","disqusShortname":"2daygeek","disqusTitle":"pip \u2013 Easy Way To Manage Python Packages On Linux","disqusUrl":"https:\/\/www.2daygeek.com\/install-pip-manage-python-packages-linux\/","options":{"manualSync":false},"postId":"14992"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wp_subscribe = {"ajaxurl":"https:\/\/www.2daygeek.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/wp-subscribe/assets/js/wp-subscribe-form.js?ver=4.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"2daygeek"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.8.2'></script>
<!--[if lt IE 9]>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/respond.js"></script>
<![endif]-->
<script type="text/javascript">
	window._wfCookieConsentSettings = {"wf_cookietext":"Cookies help us deliver our services. By using our services, you agree to our use of cookies.","wf_dismisstext":"Got it","wf_linktext":"Learn more","wf_linkhref":"https:\/\/www.2daygeek.com\/about-us\/","wf_position":"top","language":"en"};
</script>
</body>
</html>