<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-71235901-1', 'auto');
  ga('send', 'pageview');

</script>
<meta name="google-site-verification" content="PuHJs7y90OgOH37jomlyBr-hu1ME7p4zbt8O9C7X8ng" />
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.2daygeek.com/xmlrpc.php">
<title>5 Methods to Avoid or Prevent Accidental Shutdown or Reboot on Linux | 2daygeek.com</title>
<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>

<meta name="description" content="2daygeek.com Linux Tips, Tricks &amp; News Today ! molly-guard - Protects Machines from Accidental Shutdowns/Reboots." />
<meta name="keywords" content="molly-guard,avoid accidental reboot,avoid accidental shutdown,protect accidental shutdown,protect accidental reboot,prevent accidental shutdown,prevent accidental reboot,linux system,systemctl command,poweroff command,halt command" />
<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.2daygeek.com/#organization","url":"https://www.2daygeek.com/","name":"2daygeek.com","sameAs":[]},{"@type":"WebSite","@id":"https://www.2daygeek.com/#website","url":"https://www.2daygeek.com/","name":"2daygeek.com","publisher":{"@id":"https://www.2daygeek.com/#organization"}},{"@type":"WebPage","@id":"https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/#webpage","url":"https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/","inLanguage":"en-US","name":"5 Methods to Avoid or Prevent Accidental Shutdown or Reboot on Linux","isPartOf":{"@id":"https://www.2daygeek.com/#website"},"image":{"@type":"ImageObject","@id":"https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/#primaryimage","url":"https://www.2daygeek.com/wp-content/uploads/2017/03/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux-1.png","width":600,"height":310},"primaryImageOfPage":{"@id":"https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/#primaryimage"},"datePublished":"2017-02-28T21:50:04+05:30","dateModified":"2019-11-11T04:16:18+05:30","description":"2daygeek.com Linux Tips, Tricks & News Today ! molly-guard - Protects Machines from Accidental Shutdowns/Reboots."},{"@type":"Article","@id":"https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/#article","isPartOf":{"@id":"https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/#webpage"},"author":{"@id":"https://www.2daygeek.com/author/magesh/#author"},"headline":"5 Methods to Avoid or Prevent Accidental Shutdown or Reboot on Linux","datePublished":"2017-02-28T21:50:04+05:30","dateModified":"2019-11-11T04:16:18+05:30","commentCount":0,"mainEntityOfPage":{"@id":"https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/#webpage"},"publisher":{"@id":"https://www.2daygeek.com/#organization"},"articleSection":"Linux Advanced Commands, Linux Commands, security, Avoid Accidental Reboot, Avoid Accidental shutdown, halt Command, Linux System, molly-guard, poweroff Command, Prevent Accidental Reboot, Prevent Accidental Shutdown, Protect Accidental Reboot, Protect Accidental Shutdown, systemctl command","image":{"@type":"ImageObject","@id":"https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/#primaryimage","url":"https://www.2daygeek.com/wp-content/uploads/2017/03/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux-1.png","width":600,"height":310}},{"@type":"Person","@id":"https://www.2daygeek.com/author/magesh/#author","name":"Magesh Maruthamuthu","sameAs":[],"image":{"@type":"ImageObject","@id":"https://www.2daygeek.com/#personlogo","url":"https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=96&d=mm&r=g","width":96,"height":96,"caption":"Magesh Maruthamuthu"}}]}</script>
<link rel="canonical" href="https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/" />

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; Feed" href="https://www.2daygeek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; Comments Feed" href="https://www.2daygeek.com/comments/feed/" />
<link id="hu-user-gfont" href="//fonts.googleapis.com/css?family=Roboto+Slab:400,300italic,300,400italic,700&subset=latin,cyrillic-ext" rel="stylesheet" type="text/css"><link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; 5 Methods to Avoid or Prevent Accidental Shutdown or Reboot on Linux Comments Feed" href="https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.2daygeek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.2daygeek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='https://www.2daygeek.com/wp-content/plugins/arconix-shortcodes/includes/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='arconix-shortcodes-css' href='https://www.2daygeek.com/wp-content/plugins/arconix-shortcodes/includes/css/arconix-shortcodes.min.css?ver=2.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-main-style-css' href='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/main.min.css?ver=3.4.29' type='text/css' media='all' />
<style id='hueman-main-style-inline-css' type='text/css'>
body { font-family:'Roboto Slab', Arial, sans-serif;font-size:0.94rem }@media only screen and (min-width: 720px) {
        .nav > li { font-size:0.94rem; }
      }.boxed #wrapper, .container-inner { max-width: 1200px; }@media only screen and (min-width: 720px) {
                .boxed .desktop-sticky {
                  width: 1200px;
                }
              }::selection { background-color: #3b8dbd; }
::-moz-selection { background-color: #3b8dbd; }a,a+span.hu-external::after,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #3b8dbd; }input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #3b8dbd; }.post-format .format-container { border-color: #3b8dbd; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #3b8dbd!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #82b965; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #82b965; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #82b965; }
.post-comments::before { border-right-color: #82b965; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #3b8dbd}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #3b8dbd; }
              }.is-scrolled #header .nav-container.desktop-sticky,
              .is-scrolled #header .search-expand { background-color: #3b8dbd; background-color: rgba(59,141,189,0.90) }.is-scrolled .topbar-transparent #nav-topbar.desktop-sticky .nav ul { background-color: #3b8dbd; background-color: rgba(59,141,189,0.95) }#header { background-color: #33363b; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #33363b; }
}
        #header #nav-mobile { background-color: #33363b; }.is-scrolled #header #nav-mobile { background-color: #33363b; background-color: rgba(51,54,59,0.90) }#nav-header.nav-container, #main-header-search .search-expand { background-color: #fa720e; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #fa720e; }
}
        img { -webkit-border-radius: 2px; border-radius: 2px; }body { background-color: #eaeaea; }
</style>
<link rel='stylesheet' id='theme-stylesheet-css' href='https://www.2daygeek.com/wp-content/themes/my-child-theme/style.css?ver=3.4.29' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-font-awesome-css' href='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/font-awesome.min.css?ver=3.4.29' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.2daygeek.com/wp-content/tablepress-combined.min.css?ver=12' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://www.2daygeek.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.2daygeek.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.9' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.2daygeek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.2daygeek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.2daygeek.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Ulauncher &#8211; A Lightweight Application Launcher for Linux' href='https://www.2daygeek.com/install-ulauncher-lightweight-app-application-launcher-linux-mint-debian-fedora-ubuntu/' />
<link rel='next' title='SiriKali – GUI Front End To Manage ecryptfs, cryfs, gocryptfs, securefs, and encfs Encrypted Folders' href='https://www.2daygeek.com/sirikali-password-protect-encrypt-decrypt-folder-directory-linux/' />
<meta name="generator" content="WordPress 5.3" />
<link rel='shortlink' href='https://wp.me/paS4jV-3vQ' />
<link rel="alternate" type="application/json+oembed" href="https://www.2daygeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.2daygeek.com%2Fhow-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.2daygeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.2daygeek.com%2Fhow-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux%2F&#038;format=xml" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js"></script>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js"></script>
<![endif]-->

<meta property="og:type" content="article" />
<meta property="og:title" content="5 Methods to Avoid or Prevent Accidental Shutdown or Reboot on Linux" />
<meta property="og:url" content="https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/" />
<meta property="og:description" content="In most cases there is a JUMP server where the Linux administrator can connect to all other Linux systems without a password. You may connect to more than one system at a time for troubleshooting p…" />
<meta property="article:published_time" content="2017-02-28T21:50:04+00:00" />
<meta property="article:modified_time" content="2019-11-11T04:16:18+00:00" />
<meta property="og:site_name" content="2daygeek.com" />
<meta property="og:image" content="https://www.2daygeek.com/wp-content/uploads/2017/03/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux-1.png" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="310" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@2daygeek" />
<meta name="twitter:text:title" content="5 Methods to Avoid or Prevent Accidental Shutdown or Reboot on Linux" />
<meta name="twitter:image" content="https://www.2daygeek.com/wp-content/uploads/2017/03/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux-1.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<link rel="icon" href="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-300x300.png" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-13506 single-format-standard wp-custom-logo wp-embed-responsive col-2cl boxed topbar-enabled header-desktop-sticky header-mobile-sticky unknown">
<div id="wrapper">
<header id="header" class="main-menu-mobile-on one-mobile-menu main_menu header-ads-desktop header-ads-mobile topbar-transparent no-header-img">
<nav class="nav-container group mobile-menu mobile-sticky " id="nav-mobile" data-menu-id="header-1">
<div class="mobile-title-logo-in-header"> <p class="site-title"><a class="custom-logo-link" href="https://www.2daygeek.com/" rel="home" title="2daygeek.com | Home page"><img src="https://www.2daygeek.com/wp-content/uploads/2015/12/2day-geek-new-logo-final.png" alt="2daygeek.com" " /></a></p>
</div>

<button class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false">
<div class="ham__navbar-span-wrapper">
<span class="line line-1"></span>
<span class="line line-2"></span>
<span class="line line-3"></span>
</div>
</button>
<div class="nav-text"></div>
<div class="nav-wrap container">
<ul class="nav container-inner group mobile-search">
<li>
<form method="get" class="searchform themeform" action="https://www.2daygeek.com/">
<div>
<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
</div>
</form> </li>
</ul>
<ul id="menu-menu-2" class="nav container-inner group"><li id="menu-item-19118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19118"><a href="https://www.2daygeek.com/category/shell-script/">Shell Script</a></li>
<li id="menu-item-6808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6808"><a href="https://www.2daygeek.com/category/linux-distributions/">Linux Distro&#8217;s</a></li>
<li id="menu-item-6806" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6806"><a href="https://www.2daygeek.com/category/linux-commands/">Linux Commands</a></li>
<li id="menu-item-9582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9582"><a href="https://www.2daygeek.com/category/webserver/">Web Servers</a></li>
<li id="menu-item-6809" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6809"><a href="https://www.2daygeek.com/category/monitoring-tools/">Monitoring Tools</a></li>
<li id="menu-item-6883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6883"><a href="https://www.2daygeek.com/category/package-management/">Package Manager</a></li>
<li id="menu-item-6811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6811"><a href="https://www.2daygeek.com/category/repository/">Additional Repos</a></li>
<li id="menu-item-6986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6986"><a href="https://www.2daygeek.com/category/free-cloud-storage/">Cloud Storage</a></li>
</ul> </div>
</nav>
<nav class="nav-container group desktop-menu desktop-sticky " id="nav-topbar" data-menu-id="header-2">
<div class="nav-text"></div>
<div class="topbar-toggle-down">
<i class="fas fa-angle-double-down" aria-hidden="true" data-toggle="down" title="Expand menu"></i>
<i class="fas fa-angle-double-up" aria-hidden="true" data-toggle="up" title="Collapse menu"></i>
</div>
<div class="nav-wrap container">
<ul id="menu-menu-1" class="nav container-inner group"><li id="menu-item-293" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-293"><a href="https://www.2daygeek.com/">Home</a></li>
<li id="menu-item-10920" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10920"><a href="https://linuxtechnews.com/">Linux Tech News</a></li>
<li id="menu-item-294" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294"><a href="https://www.2daygeek.com/about-us/">About</a></li>
<li id="menu-item-295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295"><a href="https://www.2daygeek.com/contact-us/">Contact Us</a></li>
<li id="menu-item-296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-296"><a href="https://www.2daygeek.com/disclaimer/">Disclaimer</a></li>
<li id="menu-item-3676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3676"><a href="https://www.2daygeek.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-2729" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2729"><a href="https://www.2daygeek.com/support-us/">Support Us</a></li>
<li id="menu-item-8366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8366"><a href="https://www.2daygeek.com/category/os-tweaks/">OS Tweak</a></li>
<li id="menu-item-12012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12012"><a href="https://www.2daygeek.com/category/icon-theme/">Icons</a></li>
<li id="menu-item-12013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12013"><a href="https://www.2daygeek.com/category/gtk-theme/">Themes</a></li>
</ul> </div>
<div id="topbar-header-search" class="container">
<div class="container-inner">
<button class="toggle-search"><i class="fas fa-search"></i></button>
<div class="search-expand">
<div class="search-expand-inner"><form method="get" class="searchform themeform" action="https://www.2daygeek.com/">
<div>
<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
</div>
</form></div>
</div>
</div>
</div>
</nav>
<div class="container group">
<div class="container-inner">
<div class="group pad central-header-zone">
<div class="logo-tagline-group">
<p class="site-title"><a class="custom-logo-link" href="https://www.2daygeek.com/" rel="home" title="2daygeek.com | Home page"><img src="https://www.2daygeek.com/wp-content/uploads/2015/12/2day-geek-new-logo-final.png" alt="2daygeek.com" " /></a></p>
</div>
<div id="header-widgets">
<div id="ai_widget-4" class="widget ai_widget"><div class='code-block code-block-2' style='margin: 8px 0; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="3848983170"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div> </div>
</div>
<nav class="nav-container group desktop-menu " id="nav-header" data-menu-id="header-3">
<div class="nav-text"></div>
<div class="nav-wrap container">
<ul id="menu-menu-3" class="nav container-inner group"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19118"><a href="https://www.2daygeek.com/category/shell-script/">Shell Script</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6808"><a href="https://www.2daygeek.com/category/linux-distributions/">Linux Distro&#8217;s</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6806"><a href="https://www.2daygeek.com/category/linux-commands/">Linux Commands</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9582"><a href="https://www.2daygeek.com/category/webserver/">Web Servers</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6809"><a href="https://www.2daygeek.com/category/monitoring-tools/">Monitoring Tools</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6883"><a href="https://www.2daygeek.com/category/package-management/">Package Manager</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6811"><a href="https://www.2daygeek.com/category/repository/">Additional Repos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6986"><a href="https://www.2daygeek.com/category/free-cloud-storage/">Cloud Storage</a></li>
</ul> </div>
</nav>
</div>
</div>
</header>
<div class="container" id="page">
<div class="container-inner">
<div class="main">
<div class="main-inner group">
<section class="content">
<div class="page-title pad group">
<ul class="meta-single group">
<li class="category"><a href="https://www.2daygeek.com/category/linux-advanced-commands/" rel="category tag">Linux Advanced Commands</a> <span>/</span> <a href="https://www.2daygeek.com/category/linux-commands/" rel="category tag">Linux Commands</a> <span>/</span> <a href="https://www.2daygeek.com/category/security/" rel="category tag">security</a></li>
</ul>
</div>
<div class="pad group">
<article class="post-13506 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-advanced-commands category-linux-commands category-security tag-avoid-accidental-reboot tag-avoid-accidental-shutdown tag-halt-command tag-linux-system tag-molly-guard tag-poweroff-command tag-prevent-accidental-reboot tag-prevent-accidental-shutdown tag-protect-accidental-reboot tag-protect-accidental-shutdown tag-systemctl-command">
<div class="post-inner group">
<h1 class="post-title entry-title">5 Methods to Avoid or Prevent Accidental Shutdown or Reboot on Linux</h1>
<p class="post-byline">
by <span class="vcard author">
<span class="fn"><a href="https://www.2daygeek.com/author/magesh/" title="Posts by Magesh Maruthamuthu" rel="author">Magesh Maruthamuthu</a></span>
</span>
&middot;
<span class="published">Last Updated: November 11, 2019</span>
</p>
<div class="clear"></div>
<div class="entry themeform">
<div class="entry-inner">

<div class="4ce8cb410074a13c74175297f2ee75bb" data-index="1" style="float: left; margin: 10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="8826511175"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>In most cases there is a JUMP server where the Linux administrator can connect to all other Linux systems without a password.</p>
<p>You may connect to more than one system at a time for troubleshooting purpose.</p>
<p>For some reason you want to restart the system, you can reboot the wrong machine instead of the actual system when you work on multiple machines.</p>
<p>No problem if it&#8217;s a Non Production server. But if you restart an important production server at the same time, think about the situation.</p>
<p>I even accidentally did it a few times.</p>
<p>In this case, how to prevent accidental shutdown or restart of Linux system.</p>
<p>Yes, we have some ways to prevent this, and we will teach you all about them in detail.</p>
<h4>1) Method-1: How to Prevent Accidental Shutdown or Reboot on Linux Using the molly-guard Utility</h4>
<p> <a href="https://packages.debian.org/sid/molly-guard" target="_blank" rel="noopener noreferrer">molly-guard</a> is a simple application, which protects machines from accidental shutdowns and reboots by asking your hostname. molly-guard primarily designed to protect SSH connections.</p>
<p>It is only available for Debian-based systems and has not been updated for this project for many years, but still works fine.</p>
<p>I haven&#8217;t found any other good alternative to this. If you find one, let me know and we&#8217;ll check it out and include in our upcoming article.</p>

<div class="4ce8cb410074a13c74175297f2ee75bb" data-index="2" style="float: left; margin: 10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="3265433976"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>How does the molly-guard work? molly-guard installs a shell script that overrides existing shutdown, restart, halt, and poweroff commands.</p>
<p>It runs a set of scripts available in <code>/etc/molly-guard/run.d/</code>, all of which need to be successfully exited, before the molly-guard executes the actual command (It has a couple of checks).</p>
<p>The script first checks whether the command is being executed from SSH. If yes, then the shell script prompts you to enter the host name you want to perform the function to prevent you from accidental shutdowns and restarts.</p>
<p>molly-guard diverts the real binaries to /lib/molly-guard/. You can bypass the molly-guard by running those binaries directly.</p>
<h4>How to Install molly-guard on Debian/Ubuntu</h4>
<p> As I said at the beginning of the article, the molly-guard application is only available for Debian-based systems. Use the <strong><a href="https://www.2daygeek.com/apt-command-examples/" target="_blank" rel="noopener noreferrer">apt command</a></strong> or the <strong><a href="https://www.2daygeek.com/apt-get-apt-cache-command-examples/" target="_blank" rel="noopener noreferrer">apt-get command</a></strong> to install it.</p>

<div class="4ce8cb410074a13c74175297f2ee75bb" data-index="3" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-7730570141079407" data-ad-slot="5150237910"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<pre>$ sudo apt install molly-guard
</pre>
<h4>Making a Test Case with the use of molly-guard</h4>
<p> I&#8217;m going to do <code>restart</code> and <code>shutdown</code> commands to check if the molly-guard application actually works as expected.</p>
<pre>$ sudo reboot

W: molly-guard: SSH session detected!
Please type in hostname of the machine to reboot: ^C
Good thing I asked; I won't reboot ubuntu.daygeek ...
</pre>
<p>Either halt or powered off after it has been brought down.</p>
<pre>$ sudo shutdown -h now

W: molly-guard: SSH session detected!
Please type in hostname of the machine to shutdown: ^C
Good thing I asked; I won't shutdown ubuntu.daygeek ...
</pre>
<p>Halt the System.</p>
<pre>$ sudo halt

W: molly-guard: SSH session detected!
Please type in hostname of the machine to halt: ^C
Good thing I asked; I won't halt ubuntu.daygeek ...
</pre>
<p>Poweroff the System.</p>
<pre>$ sudo poweroff

W: molly-guard: SSH session detected!
Please type in hostname of the machine to poweroff: ^C
Good thing I asked; I won't poweroff ubuntu.daygeek ...
</pre>
<p><strong><code>Note:</code></strong> The molly-guard application doesn&#8217;t prevent systemctl shutdown and systemctl reboot commands.</p>
<h4>2) Method-2: How to Prevent Accidental Shutdown or Reboot on Linux Using systemd Custom Service</h4>
<p> To do so, create a custom service to prevent shutdown/restart command.</p>
<p>Create the following unit files:</p>
<pre># vi /etc/systemd/system/reboot-guard.service

[Unit]
Description=Reboot Guard
[Service]
ExecStart=/bin/true
[Install]
RequiredBy=shutdown.target
</pre>
<p>Unit file-2:</p>
<pre># /etc/systemd/system/start-reboot-guard.service

[Unit]
Description=Start Reboot Guard
[Service]
ExecStart=/bin/systemctl enable reboot-guard
[Install]
WantedBy=multi-user.target
</pre>
<p>Run the following systemctl commands to activate the reboot-guard service.</p>
<pre># systemctl daemon-reload

# systemctl enable reboot-guard start-reboot-guard
Created symlink /etc/systemd/system/shutdown.target.requires/reboot-guard.service → /etc/systemd/system/reboot-guard.service.
Created symlink /etc/systemd/system/multi-user.target.wants/start-reboot-guard.service → /etc/systemd/system/start-reboot-guard.service.
</pre>
<p>Creating a Test Case with the reboot-guard Service.</p>
<p>For reboot</p>
<pre># systemctl reboot

Failed to reboot system via logind: Transaction contains conflicting jobs 'stop' and 'start' for shutdown.target. Probably contradicting requirement dependencies configured.
Failed to start reboot.target: Transaction contains conflicting jobs 'stop' and 'start' for shutdown.target. Probably contradicting requirement dependencies configured.
See system logs and 'systemctl status reboot.target' for details.
</pre>
<p>For poweroff</p>

<div class="4ce8cb410074a13c74175297f2ee75bb" data-index="4" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script id="mNCC" language="javascript">
   medianet_width = "728";
   medianet_height = "90";
   medianet_crid = "847533357";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUF666N9' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div>
<pre># systemctl poweroff

Failed to power off system via logind: Transaction contains conflicting jobs 'stop' and 'start' for poweroff.target. Probably contradicting requirement dependencies configured.
Failed to start poweroff.target: Transaction contains conflicting jobs 'stop' and 'start' for poweroff.target. Probably contradicting requirement dependencies configured.
See system logs and 'systemctl status poweroff.target' for details.
</pre>
<p>For legacy tools like reboot, init 0 and init 6, I see no effect, but the shutdown command showed the following output. However, this does not really shutdown the system.</p>
<pre># reboot
# init 6
# poweroff
# init 0
# shutdown
Shutdown scheduled for Sun 2019-11-10 21:59:17 IST, use 'shutdown -c' to cancel.
</pre>
<p>Run the following command to enable shutdown/restart commands.</p>
<pre># systemctl disable reboot-guard
</pre>
<p>Ref: Red Hat <a href="https://access.redhat.com/solutions/1580343" rel="noopener noreferrer" target="_blank">page</a></p>
<h4>3) Method-3: How to Prevent Accidental Shutdown or Reboot on Linux Using the reboot-guard Utility</h4>
<p> Block systemd-initiated poweroff/reboot/halt targets until configurable condition checks pass.</p>
<p>It only works with Python 2, so make sure you have Python 2 installed on your system. In my case, I tested this on CentOS 8, and it didn&#8217;t install Python 2 before, so I installed it.</p>
<p>Download the reboot-guard utility under the &#8220;/usr/sbin&#8221; directory.</p>
<pre># cd /usr/sbin
# curl -kO https://raw.githubusercontent.com/ryran/reboot-guard/master/rguard
# chmod +x rguard
</pre>
<p>Run the following command to enable the rguard utility to block reboot/shutdown.</p>
<pre># rguard -1

WARNING: ☹  Blocked poweroff.target
WARNING: ☹  Blocked reboot.target
WARNING: ☹  Blocked halt.target
</pre>
<p>Creating a test case of the rguard application.</p>
<p>For reboot</p>
<pre># systemctl reboot

Failed to reboot system via logind: Operation refused, unit reboot.target may be requested by dependency only (it is configured to refuse manual start/stop).
Failed to start reboot.target: Operation refused, unit reboot.target may be requested by dependency only (it is configured to refuse manual start/stop).
See system logs and 'systemctl status reboot.target' for details.
</pre>
<p>For poweroff</p>
<pre># systemctl poweroff

Failed to power off system via logind: Operation refused, unit poweroff.target may be requested by dependency only (it is configured to refuse manual start/stop).
Failed to start poweroff.target: Operation refused, unit poweroff.target may be requested by dependency only (it is configured to refuse manual start/stop).
See system logs and 'systemctl status poweroff.target' for details.
</pre>
<p>For legacy tools like reboot, init 0 and init 6, I see no effect, but the shutdown command showed the following output. However, this does not really shutdown the system.</p>
<pre># reboot
# init 6
# poweroff
# init 0
# shutdown
Shutdown scheduled for Sun 2019-11-10 23:46:24 IST, use 'shutdown -c' to cancel.
</pre>
<p>Run the following command to disable rguard utility.</p>
<pre># rguard -0

WARNING: ☻  Unblocked poweroff.target
WARNING: ☻  Unblocked reboot.target
WARNING: ☻  Unblocked halt.target
</pre>
<h4>4) Method-4: How to Prevent Accidental Shutdown or Reboot on Linux Using the systemctl Command</h4>
<p> Alternatively, you can use the systemctl command to mask a service. Masking a service prevents the service from being started manually or automatically.</p>
<p>Mask the following units to prevent accidental reboot/shutdown.</p>
<pre># systemctl mask reboot.target
Created symlink /etc/systemd/system/reboot.target → /dev/null.

# systemctl mask poweroff.target
Created symlink /etc/systemd/system/poweroff.target → /dev/null.

# systemctl mask halt.target
Created symlink /etc/systemd/system/halt.target → /dev/null.
</pre>
<p>For reboot</p>
<pre># systemctl reboot

Failed to reboot system via logind: Access denied
Failed to start reboot.target: Unit reboot.target is masked.
</pre>
<p>For poweroff</p>
<pre># systemctl poweroff

Failed to power off system via logind: Access denied
Failed to start poweroff.target: Unit poweroff.target is masked.
</pre>
<p>For legacy tools like reboot, poweroff, init 0 and init 6, I see no effect, but the shutdown command showed the following output. However, this does not really shutdown the system.</p>
<pre># reboot
# init 6
# poweroff
# init 0
# shutdown
Shutdown scheduled for Sun 2019-11-10 23:59:09 IST, use 'shutdown -c' to cancel.
</pre>
<p>Run the following command to enable them.</p>
<pre># systemctl unmask reboot.target
Removed /etc/systemd/system/reboot.target.

# systemctl unmask poweroff.target
Removed /etc/systemd/system/poweroff.target.

# systemctl unmask halt.target
Removed /etc/systemd/system/halt.target.
</pre>
<h4>5) Method-5: How to Prevent Accidental Shutdown or Reboot on Linux Using the alias Command</h4>
<p> Alternatively, you can create an alias to prevent this.</p>
<pre># vi .bashrc

alias reboot="echo -e 'Is \033[1;31m$HOSTNAME\033[0m the correct hostname you want to restart?' If yes, run /sbin/reboot"
alias shutdown="echo -e 'Is \033[1;31m$HOSTNAME\033[0m the correct hostname you want to shutdown?' If yes, run /sbin/shutdown"
</pre>
<p>Run the following command to take this change effect.</p>
<pre># source .bashrc
</pre>
<p>Now, test these commands and see the results.</p>
<pre># shutdown
Is CentOS6.2daygeek.com the correct hostname you want to shutdown? If yes, run /sbin/shutdown

# reboot
Is CentOS6.2daygeek.com the correct hostname you want to restart? If yes, run /sbin/reboot
</pre>

<div class="4ce8cb410074a13c74175297f2ee75bb" data-index="5" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script id="mNCC" language="javascript">  medianet_width='468';  medianet_height= '60';  medianet_crid='328488081';  </script> <script id="mNSC" src="https://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-7730570141079407" data-ad-slot="9495141575"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-13506" class="share-facebook sd-button share-icon" href="https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-13506" class="share-linkedin sd-button share-icon" href="https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-13506" class="share-twitter sd-button share-icon" href="https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-13506" class="share-pinterest sd-button share-icon" href="https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://www.2daygeek.com/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li></ul></div></div></div> <nav class="pagination group">
</nav>
</div>
<div class="clear"></div>
</div>
</div>
</article>
<div class="clear"></div>
<p class="post-tags"><span>Tags:</span> <a href="https://www.2daygeek.com/tag/avoid-accidental-reboot/" rel="tag">Avoid Accidental Reboot</a><a href="https://www.2daygeek.com/tag/avoid-accidental-shutdown/" rel="tag">Avoid Accidental shutdown</a><a href="https://www.2daygeek.com/tag/halt-command/" rel="tag">halt Command</a><a href="https://www.2daygeek.com/tag/linux-system/" rel="tag">Linux System</a><a href="https://www.2daygeek.com/tag/molly-guard/" rel="tag">molly-guard</a><a href="https://www.2daygeek.com/tag/poweroff-command/" rel="tag">poweroff Command</a><a href="https://www.2daygeek.com/tag/prevent-accidental-reboot/" rel="tag">Prevent Accidental Reboot</a><a href="https://www.2daygeek.com/tag/prevent-accidental-shutdown/" rel="tag">Prevent Accidental Shutdown</a><a href="https://www.2daygeek.com/tag/protect-accidental-reboot/" rel="tag">Protect Accidental Reboot</a><a href="https://www.2daygeek.com/tag/protect-accidental-shutdown/" rel="tag">Protect Accidental Shutdown</a><a href="https://www.2daygeek.com/tag/systemctl-command/" rel="tag">systemctl command</a></p>
<div class="author-bio">
<div class="bio-avatar"><img alt='' src='https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=128&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=256&#038;d=mm&#038;r=g 2x' class='avatar avatar-128 photo' height='128' width='128' /></div>
<p class="bio-name">Magesh Maruthamuthu</p>
<p class="bio-desc">Love to play with all Linux distribution</p>
<div class="clear"></div>
</div>
<ul class="post-nav group">
<li class="next"><a href="https://www.2daygeek.com/sirikali-password-protect-encrypt-decrypt-folder-directory-linux/" rel="next"><i class="fas fa-chevron-right"></i><strong>Next story</strong> <span>SiriKali – GUI Front End To Manage ecryptfs, cryfs, gocryptfs, securefs, and encfs Encrypted Folders</span></a></li>
<li class="previous"><a href="https://www.2daygeek.com/install-ulauncher-lightweight-app-application-launcher-linux-mint-debian-fedora-ubuntu/" rel="prev"><i class="fas fa-chevron-left"></i><strong>Previous story</strong> <span>Ulauncher &#8211; A Lightweight Application Launcher for Linux</span></a></li>
</ul>
<h4 class="heading">
<i class="far fa-hand-point-right"></i>You may also like...</h4>
<ul class="related-posts group">
<li class="related post-hover">
<article class="post-15690 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands category-user-management tag-audit tag-aureport tag-chage tag-passwd tag-stat tag-user-creation-date tag-useradd">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/how-to-check-user-created-date-on-linux/">
<img width="520" height="245" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2018/04/How-To-Check-User-Created-Date-In-Linux-520x245.png" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2018/04/How-To-Check-User-Created-Date-In-Linux-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2018/04/How-To-Check-User-Created-Date-In-Linux-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/how-to-check-user-created-date-on-linux/" rel="bookmark" title="Permalink to How To Check User Created Date On Linux">How To Check User Created Date On Linux</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2018-04-12 14:53:32">April 12, 2018</time>
</p>
</div>
</div>
</article>
</li>
<li class="related post-hover">
<article class="post-325 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands category-linux-service-command tag-check-pure-ftpd-service-status-in-linux tag-enable-pure-ftpd-server-in-boot tag-enable-pure-ftpd-service-in-boot tag-reload-pure-ftpd-service-in-linux tag-restart-pure-ftpd-server-in-linux tag-restart-pure-ftpd-service-in-linux tag-start-pure-ftpd-server-in-linux tag-start-pure-ftpd-service-in-linux tag-stop-pure-ftpd-service-in-linux">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/start-stop-restart-enable-reload-pure-ftpd-server-service-in-linux/">
<img width="520" height="245" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2013/10/start-stop-restart-enable-reload-pure-ftpd-server-service-in-linux-1a-520x245.png" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2013/10/start-stop-restart-enable-reload-pure-ftpd-server-service-in-linux-1a-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2013/10/start-stop-restart-enable-reload-pure-ftpd-server-service-in-linux-1a-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/start-stop-restart-enable-reload-pure-ftpd-server-service-in-linux/" rel="bookmark" title="Permalink to How To Start / Stop / Restart / Enable / Reload The Pure-FTPd Service In Linux?">How To Start / Stop / Restart / Enable / Reload The Pure-FTPd Service In Linux?</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2013-10-09 14:05:07">October 9, 2013</time>
</p>
</div>
</div>
</article>
</li>
<li class="related post-hover">
<article class="post-12362 post type-post status-publish format-standard has-post-thumbnail hentry category-general category-linux-commands tag-command-line-google-search tag-google-command-line-search tag-google-news-from-the-terminal tag-google-search tag-google-search-from-the-command-line tag-google-site-search">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/googler-google-search-from-the-command-line-on-linux/">
<img width="520" height="245" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2016/09/google-search-from-the-command-line-on-linux-520x245.png" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2016/09/google-search-from-the-command-line-on-linux-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2016/09/google-search-from-the-command-line-on-linux-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/googler-google-search-from-the-command-line-on-linux/" rel="bookmark" title="Permalink to Googler &#8211; Google Search From The Linux Command Line">Googler &#8211; Google Search From The Linux Command Line</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2016-09-23 00:05:08">September 23, 2016</time>
</p>
</div>
</div>
</article>
</li>
</ul>
<div id="disqus_thread"></div>
</div>
</section>
<div class="sidebar s1 collapsed" data-position="right" data-layout="col-2cl" data-sb-id="s1">
<button class="sidebar-toggle" title="Expand Sidebar"><i class="fas icon-sidebar-toggle"></i></button>
<div class="sidebar-content">
<div class="sidebar-top group">
<p>Follow:</p>
<ul class="social-links"><li><a rel="nofollow" class="social-tooltip" title="Facebook" aria-label="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Twitter" aria-label="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Linkein" aria-label="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Pinterest" aria-label="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fab fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Tumblr" aria-label="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fab fa-tumblr"></i></a></li></ul> </div>
<div id="media_image-4" class="widget widget_media_image"><h3 class="widget-title">Linux &#038; Open Source News</h3><a href="https://www.linuxtechnews.com/" target="_blank" rel="noopener noreferrer"><img width="300" height="43" src="https://www.2daygeek.com/wp-content/uploads/2019/05/linuxtechnews-logo-v3-300x43.png" class="image wp-image-17665  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://www.2daygeek.com/wp-content/uploads/2019/05/linuxtechnews-logo-v3-300x43.png 300w, https://www.2daygeek.com/wp-content/uploads/2019/05/linuxtechnews-logo-v3.png 330w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div id="text-8" class="widget widget_text"><h3 class="widget-title">&#8211; Click Here To Get Offers &#8211;</h3> <div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="7612209571"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div><div id="media_image-5" class="widget widget_media_image"><h3 class="widget-title">Ethical Hacking Course</h3><a href="https://ethicalhackersacademy.com/?ref=400ewqahhx" target="_blank" rel="noopener noreferrer"><img width="421" height="212" src="https://www.2daygeek.com/wp-content/uploads/2015/11/Hacking-Course-2.png" class="image wp-image-17800  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.2daygeek.com/wp-content/uploads/2015/11/Hacking-Course-2.png 421w, https://www.2daygeek.com/wp-content/uploads/2015/11/Hacking-Course-2-300x151.png 300w" sizes="(max-width: 421px) 100vw, 421px" /></a></div><div id="text-10" class="widget widget_text"><h3 class="widget-title">&#8211; For Better Offers &#8211;</h3> <div class="textwidget"><script id="mNCC" language="javascript">  medianet_width='300';  medianet_height= '250';  medianet_crid='108135239';  </script> <script id="mNSC" src="https://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script></div>
</div> <div id="wp_subscribe-3" class="widget wp_subscribe">
<div id="wp-subscribe" class="wp-subscribe-wrap wp-subscribe wp-subscribe-1" data-thanks_page="0" data-thanks_page_url="" data-thanks_page_new_window="0">
<h4 class="title">Get Latest LINUX Tips</h4>
<p class="text"></p>
<form action="https://feedburner.google.com/fb/a/mailverify?uri=2daygeekfeed" method="post" class="wp-subscribe-form wp-subscribe-feedburner" id="wp-subscribe-form-1" target="popupwindow">
<input class="regular-text email-field" type="email" name="email" placeholder="Enter your email here" required>
<input type="hidden" name="uri" value="2daygeekfeed">
<input type="hidden" name="loc" value="en_US">
<input type="hidden" name="form_type" value="widget">
<input type="hidden" name="service" value="feedburner">
<input type="hidden" name="widget" value="wp_subscribe-3">
<div class="wps-consent-wrapper">
<label for="consent-field">
<input class="consent-field" id="consent-field" type="checkbox" name="consent" required />
I consent to my submitted data being collected via this form* </label>
</div>
<input class="submit" type="submit" name="submit" value="Sign Up Now">
</form>
<div class="wp-subscribe-loader">
<svg version="1.1" id="loader-1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0" y="0" width="40px" height="40px" viewBox="0 0 50 50" style="enable-background:new 0 0 50 50;" xml:space="preserve">
<path fill="#ffffff" d="M43.935,25.145c0-10.318-8.364-18.683-18.683-18.683c-10.318,0-18.683,8.365-18.683,18.683h4.068c0-8.071,6.543-14.615,14.615-14.615c8.072,0,14.615,6.543,14.615,14.615H43.935z">
<animateTransform attributeType="xml" attributeName="transform" type="rotate" from="0 25 25" to="360 25 25" dur="0.6s" repeatCount="indefinite" />
</path>
</svg>
</div>
<p class="thanks">Thank you for subscribing.</p>
<p class="error">Something went wrong.</p>
<div class="clear"></div>
<p class="footer-text"></p>
</div>
</div>
<div id="text-3" class="widget widget_text"><h3 class="widget-title">To Search, Type and Hit Enter</h3> <div class="textwidget"><script>
  (function() {
    var cx = '007232544684438091033:5mzh938wm_e';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchresults-only></gcse:searchresults-only></div>
</div><div id="text-6" class="widget widget_text"><h3 class="widget-title">Google Translater</h3> <div class="textwidget"><div id="google_translate_element"></div><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script></div>
</div><div id="media_image-6" class="widget widget_media_image"><h3 class="widget-title">Linux Online Course</h3><a href="https://stacksocial.com/sales/complete-linux-crash-course-includes-topics-on-red-hat-unix-kali-python-and-opensuse?aid=a-4s5jc8po" target="_blank" rel="noopener noreferrer"><img width="402" height="355" src="https://www.2daygeek.com/wp-content/uploads/2015/11/Linux-Online-Course.png" class="image wp-image-17806  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.2daygeek.com/wp-content/uploads/2015/11/Linux-Online-Course.png 402w, https://www.2daygeek.com/wp-content/uploads/2015/11/Linux-Online-Course-300x265.png 300w" sizes="(max-width: 402px) 100vw, 402px" /></a></div>
</div>
</div>
</div>
</div>
</div>
</div>
<footer id="footer">
<section class="container" id="footer-bottom">
<div class="container-inner">
<a id="back-to-top" href="#"><i class="fas fa-angle-up"></i></a>
<div class="pad group">
<div class="grid one-half">
<div id="copyright">
<p></p>
</div>
<div id="credit" style="">
<p>Powered by&nbsp;<a class="fab fa-wordpress" title="Powered by WordPress" href="https://wordpress.org/" target="_blank"></a> - Designed with the&nbsp;<a href="" title="Hueman theme">Hueman theme</a></p>
</div>
</div>
<div class="grid one-half last">
<ul class="social-links"><li><a rel="nofollow" class="social-tooltip" title="Facebook" aria-label="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Twitter" aria-label="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Linkein" aria-label="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fab fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Pinterest" aria-label="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fab fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Tumblr" aria-label="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fab fa-tumblr"></i></a></li></ul> </div>
</div>
</div>
</section>
</footer>
</div>
<div style="display:none">
<div class="grofile-hash-map-d487bef1de15143a7b80a40396e96118">
</div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.2daygeek.com\/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux\/":13506};
	</script>
<link rel='stylesheet' id='wp-subscribe-css' href='https://www.2daygeek.com/wp-content/plugins/wp-subscribe/assets/css/wp-subscribe-form.css?ver=5.3' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"2daygeek"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"13506 https:\/\/www.2daygeek.com\/?p=13506","disqusShortname":"2daygeek","disqusTitle":"5 Methods to Avoid or Prevent Accidental Shutdown or Reboot on Linux","disqusUrl":"https:\/\/www.2daygeek.com\/how-to-avoid-or-prevent-accidental-shutdown-or-reboot-on-linux\/","postId":"13506"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/hueman-addons/addons/assets/front/js/jQuerySharrre.min.js?ver=5.3'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201948'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/wf-cookie-consent/js/cookiechoices.min.js?ver=5.3'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Novaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.3'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"","extLinksTargetExt":"","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"1","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":true,"mobile":true},"isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_up","mobile":"stick_up"},"mobileSubmenuExpandOnClick":"","submenuTogglerIcon":"<i class=\"fas fa-angle-down\"><\/i>","isDevMode":"","ajaxUrl":"https:\/\/www.2daygeek.com\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"59256fede2"},"isWelcomeNoteOn":"","welcomeContent":"","i18n":{"collapsibleExpand":"Expand","collapsibleCollapse":"Collapse"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/scripts.min.js?ver=3.4.29'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/comment-reply.min.js?ver=5.3'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/wp-embed.min.js?ver=5.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wp_subscribe = {"ajaxurl":"https:\/\/www.2daygeek.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/wp-subscribe/assets/js/wp-subscribe-form.js?ver=5.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.9'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<!--[if lt IE 9]>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/respond.js"></script>
<![endif]-->
<script type="text/javascript">
	window._wfCookieConsentSettings = {"wf_cookietext":"Cookies help us deliver our services. By using our services, you agree to our use of cookies.","wf_dismisstext":"Got it","wf_linktext":"Learn more","wf_linkhref":"https:\/\/www.2daygeek.com\/about-us\/","wf_position":"top","language":"en"};
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201948.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.9',blog:'160649683',post:'13506',tz:'5.5',srv:'www.2daygeek.com'} ]);
	_stq.push([ 'clickTrackerInit', '160649683', '13506' ]);
</script>
</body>
</html>