<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-71235901-1', 'auto');
  ga('send', 'pageview');
</script>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.2daygeek.com/xmlrpc.php">
<title>How To Set up Automatic Security Update (Unattended Upgrades) on Debian/Ubuntu? | 2daygeek.com</title>
<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>

<meta name="description" content="One of an important task for Linux admins to make the system up-to-date. It&#039;s keep your system more stable and avoid unwanted access and attack. Installing a" />
<meta name="keywords" content="install security updates,automatically install security updates,debian,ubuntu,unattended upgrades,apt-get command,apt command,automatic security update" />
<link rel="canonical" href="https://www.2daygeek.com/automatic-security-update-unattended-upgrades-ubuntu-debian/" />

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; Feed" href="https://www.2daygeek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; Comments Feed" href="https://www.2daygeek.com/comments/feed/" />
<link id="hu-user-gfont" href="//fonts.googleapis.com/css?family=Roboto+Slab:400,300italic,300,400italic,700&subset=latin,cyrillic-ext" rel="stylesheet" type="text/css"><link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; How To Set up Automatic Security Update (Unattended Upgrades) on Debian/Ubuntu? Comments Feed" href="https://www.2daygeek.com/automatic-security-update-unattended-upgrades-ubuntu-debian/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.2daygeek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.9"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='font-awesome-css' href='https://www.2daygeek.com/wp-content/plugins/arconix-shortcodes/includes/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='arconix-shortcodes-css' href='https://www.2daygeek.com/wp-content/plugins/arconix-shortcodes/includes/css/arconix-shortcodes.min.css?ver=2.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://www.2daygeek.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-main-style-css' href='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/main.min.css?ver=3.3.20' type='text/css' media='all' />
<link rel='stylesheet' id='theme-stylesheet-css' href='https://www.2daygeek.com/wp-content/themes/my-child-theme/style.css?ver=3.3.20' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-font-awesome-css' href='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/font-awesome.min.css?ver=3.3.20' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.2daygeek.com/wp-content/tablepress-combined.min.css?ver=10' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://www.2daygeek.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.2daygeek.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.0.1' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.2daygeek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.2daygeek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.2daygeek.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='How To Find Out Linux Operating System (OS) Installation Date And Time?' href='https://www.2daygeek.com/linux-os-installation-date-time/' />
<meta name="generator" content="WordPress 4.8.9" />
<link rel='shortlink' href='https://wp.me/paS4jV-4E3' />
<link rel="alternate" type="application/json+oembed" href="https://www.2daygeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.2daygeek.com%2Fautomatic-security-update-unattended-upgrades-ubuntu-debian%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.2daygeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.2daygeek.com%2Fautomatic-security-update-unattended-upgrades-ubuntu-debian%2F&#038;format=xml" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js"></script>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js"></script>
<![endif]-->

<meta property="og:type" content="article" />
<meta property="og:title" content="How To Set up Automatic Security Update (Unattended Upgrades) on Debian/Ubuntu?" />
<meta property="og:url" content="https://www.2daygeek.com/automatic-security-update-unattended-upgrades-ubuntu-debian/" />
<meta property="og:description" content="One of an important task for Linux admins to make the system up-to-date. It&#8217;s keep your system more stable and avoid unwanted access and attack. Installing a package in Linux is a piece of ca…" />
<meta property="article:published_time" content="2019-08-14T07:55:36+00:00" />
<meta property="article:modified_time" content="2019-08-14T08:41:10+00:00" />
<meta property="og:site_name" content="2daygeek.com" />
<meta property="og:image" content="https://www.2daygeek.com/wp-content/uploads/2019/08/automatic-security-update-unattended-upgrades-ubuntu-debian-2.png" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="310" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@2daygeek" />
<meta name="twitter:site" content="@2daygeek" />
<meta name="twitter:text:title" content="How To Set up Automatic Security Update (Unattended Upgrades) on Debian/Ubuntu?" />
<meta name="twitter:image" content="https://www.2daygeek.com/wp-content/uploads/2019/08/automatic-security-update-unattended-upgrades-ubuntu-debian-2.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<link rel="icon" href="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.2daygeek.com/wp-content/uploads/2019/05/cropped-favicon-32x32-300x300.png" />
<style type="text/css" id="hu-dynamic-style">/* Dynamic CSS: For no styles in head, copy and put the css below in your child theme's style.css, disable dynamic styles */body { font-family:'Roboto Slab', Arial, sans-serif;font-size:0.94rem }@media only screen and (min-width: 720px) {
        .nav > li { font-size:0.94rem; }
      }.boxed #wrapper, .container-inner { max-width: 1200px; }@media only screen and (min-width: 720px) {
                .boxed .desktop-sticky {
                  width: 1200px;
                }
              }::selection { background-color: #3b8dbd; }
::-moz-selection { background-color: #3b8dbd; }a,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #3b8dbd; }.themeform input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #3b8dbd; }.post-format .format-container { border-color: #3b8dbd; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #3b8dbd!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #82b965; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #82b965; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #82b965; }
.post-comments span:before { border-right-color: #82b965; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #3b8dbd}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #3b8dbd; }
              }.is-scrolled #header .nav-container.desktop-sticky,
              .is-scrolled #header .search-expand { background-color: #3b8dbd; background-color: rgba(59,141,189,0.90) }.is-scrolled .topbar-transparent #nav-topbar.desktop-sticky .nav ul { background-color: #3b8dbd; background-color: rgba(59,141,189,0.95) }#header { background-color: #33363b; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #33363b; }
}
        #header #nav-mobile { background-color: #33363b; }.is-scrolled #header #nav-mobile { background-color: #33363b; background-color: rgba(51,54,59,0.90) }#nav-header.nav-container, #main-header-search .search-expand { background-color: #fa720e; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #fa720e; }
}
        img { -webkit-border-radius: 2px; border-radius: 2px; }body { background-color: #eaeaea; }</style>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-17859 single-format-standard wp-custom-logo col-2cl boxed topbar-enabled header-desktop-sticky header-mobile-sticky unknown">
<div id="wrapper">
<header id="header" class="main-menu-mobile-on one-mobile-menu main_menu header-ads-desktop  topbar-transparent">
<nav class="nav-container group mobile-menu mobile-sticky " id="nav-mobile" data-menu-id="header-1">
<div class="mobile-title-logo-in-header"> <p class="site-title"><a class="custom-logo-link" href="https://www.2daygeek.com/" rel="home" title="2daygeek.com | Home page"><img src="https://www.2daygeek.com/wp-content/uploads/2015/12/2day-geek-new-logo-final.png" alt="2daygeek.com"></a></p>
</div>

<div class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false">
<div class="ham__navbar-span-wrapper">
<span class="line line-1"></span>
<span class="line line-2"></span>
<span class="line line-3"></span>
</div>
</div>
<div class="nav-text"></div>
<div class="nav-wrap container">
<ul class="nav container-inner group mobile-search">
<li>
<form method="get" class="searchform themeform" action="https://www.2daygeek.com/">
<div>
<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
</div>
</form> </li>
</ul>
<ul id="menu-menu-2" class="nav container-inner group"><li id="menu-item-6808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6808"><a href="https://www.2daygeek.com/category/linux-distributions/">LINUX DISTRO&#8217;S</a></li>
<li id="menu-item-6806" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6806"><a href="https://www.2daygeek.com/category/linux-commands/">LINUX COMMAND&#8217;S</a></li>
<li id="menu-item-9582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9582"><a href="https://www.2daygeek.com/category/webserver/">WEBSERVER</a></li>
<li id="menu-item-6809" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6809"><a href="https://www.2daygeek.com/category/monitoring-tools/">MONITORING TOOLS</a></li>
<li id="menu-item-6883" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6883"><a href="https://www.2daygeek.com/category/package-management/">PACKAGE MANAGEMENT</a></li>
<li id="menu-item-6811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6811"><a href="https://www.2daygeek.com/category/repository/">REPOSITORY</a></li>
<li id="menu-item-6986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6986"><a href="https://www.2daygeek.com/category/free-cloud-storage/">CLOUD STORAGE</a></li>
</ul> </div>
</nav>
<nav class="nav-container group desktop-menu desktop-sticky " id="nav-topbar" data-menu-id="header-2">
<div class="nav-text"></div>
<div class="topbar-toggle-down">
<i class="fa fa-angle-double-down" aria-hidden="true" data-toggle="down" title="Expand menu"></i>
<i class="fa fa-angle-double-up" aria-hidden="true" data-toggle="up" title="Collapse menu"></i>
</div>
<div class="nav-wrap container">
<ul id="menu-menu-1" class="nav container-inner group"><li id="menu-item-293" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-293"><a href="https://www.2daygeek.com/">HOME</a></li>
<li id="menu-item-10920" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10920"><a href="https://linuxtechnews.com/">Linux Tech News</a></li>
<li id="menu-item-294" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294"><a href="https://www.2daygeek.com/about-us/">ABOUT US</a></li>
<li id="menu-item-295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295"><a href="https://www.2daygeek.com/contact-us/">CONTACT US</a></li>
<li id="menu-item-296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-296"><a href="https://www.2daygeek.com/disclaimer/">DISCLAIMER</a></li>
<li id="menu-item-3676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3676"><a href="https://www.2daygeek.com/privacy-policy/">PRIVACY POLICY</a></li>
<li id="menu-item-2729" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2729"><a href="https://www.2daygeek.com/support-us/">SUPPORT US</a></li>
<li id="menu-item-8366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8366"><a href="https://www.2daygeek.com/category/os-tweaks/">OS TWEAK</a></li>
<li id="menu-item-12012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12012"><a href="https://www.2daygeek.com/category/icon-theme/">ICONS</a></li>
<li id="menu-item-12013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12013"><a href="https://www.2daygeek.com/category/gtk-theme/">THEMES</a></li>
</ul> </div>
<div id="topbar-header-search" class="container">
<div class="container-inner">
<div class="toggle-search"><i class="fa fa-search"></i></div>
<div class="search-expand">
<div class="search-expand-inner"><form method="get" class="searchform themeform" action="https://www.2daygeek.com/">
<div>
<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
</div>
</form></div>
</div>
</div>
</div>
</nav>
<div class="container group">
<div class="container-inner">
<div class="group pad central-header-zone">
<div class="logo-tagline-group">
<p class="site-title"><a class="custom-logo-link" href="https://www.2daygeek.com/" rel="home" title="2daygeek.com | Home page"><img src="https://www.2daygeek.com/wp-content/uploads/2015/12/2day-geek-new-logo-final.png" alt="2daygeek.com"></a></p>
</div>
<div id="header-widgets">
<div style="float:left;border:solid 0px;height:90px;width:728px;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="3848983170"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
</div>
<nav class="nav-container group desktop-menu " id="nav-header" data-menu-id="header-3">
<div class="nav-text"></div>
<div class="nav-wrap container">
<ul id="menu-menu-3" class="nav container-inner group"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6808"><a href="https://www.2daygeek.com/category/linux-distributions/">LINUX DISTRO&#8217;S</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6806"><a href="https://www.2daygeek.com/category/linux-commands/">LINUX COMMAND&#8217;S</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9582"><a href="https://www.2daygeek.com/category/webserver/">WEBSERVER</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6809"><a href="https://www.2daygeek.com/category/monitoring-tools/">MONITORING TOOLS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6883"><a href="https://www.2daygeek.com/category/package-management/">PACKAGE MANAGEMENT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6811"><a href="https://www.2daygeek.com/category/repository/">REPOSITORY</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6986"><a href="https://www.2daygeek.com/category/free-cloud-storage/">CLOUD STORAGE</a></li>
</ul> </div>
</nav>
</div>
</div>
</header>
<div class="container" id="page">
<div class="container-inner">
<div class="main">
<div class="main-inner group">
<section class="content">
<div class="page-title pad group">
<ul class="meta-single group">
<li class="category"><a href="https://www.2daygeek.com/category/debian/" rel="category tag">Debian</a> <span>/</span> <a href="https://www.2daygeek.com/category/package-management/" rel="category tag">Package Management</a> <span>/</span> <a href="https://www.2daygeek.com/category/security/" rel="category tag">security</a> <span>/</span> <a href="https://www.2daygeek.com/category/ubuntu/" rel="category tag">ubuntu</a></li>
</ul>
</div>
<div class="pad group">
<article class="post-17859 post type-post status-publish format-standard has-post-thumbnail hentry category-debian category-package-management category-security category-ubuntu tag-apt-command tag-apt-get-command tag-automatic-security-update tag-automatically-install-security-updates tag-debian tag-install-security-updates tag-ubuntu tag-unattended-upgrades">
<div class="post-inner group">
<h1 class="post-title entry-title">How To Set up Automatic Security Update (Unattended Upgrades) on Debian/Ubuntu?</h1>
<p class="post-byline">by <span class="vcard author">
<span class="fn"><a href="https://www.2daygeek.com/author/magesh/" title="Posts by Magesh Maruthamuthu" rel="author">Magesh Maruthamuthu</a></span>
</span> &middot;
<span class="published">Published : August 14, 2019 || Last Updated: August 14, 2019</span>
</p>
<div class="clear"></div>
<div class="entry themeform">
<div class="entry-inner">

<div style="float: left; margin: 10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="8826511175"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>One of an important task for Linux admins to make the system up-to-date.</p>
<p>It&#8217;s keep your system more stable and avoid unwanted access and attack.</p>
<p>Installing a package in Linux is a piece of cake.</p>
<p>In the similar way we can update security patches as well.</p>
<p>This is a simple tutorial that will show you to configure your system to receive automatic security updates.</p>
<p>There are some security risks involved when you running an automatic security package upgrades without inspection, but there are also benefits.</p>
<p>If you don&#8217;t want to miss security patches and would like to stay up-to-date with the latest security patches.</p>
<p>Then you should set up an automatic security update with help of unattended upgrades utility.</p>
<p>You can <strong><a href="https://www.2daygeek.com/manually-install-security-updates-ubuntu-debian/" rel="noopener" target="_blank">manually install Security Updates on Debian &#038; Ubuntu systems</a></strong> if you don&#8217;t want to go for automatic security update.</p>
<p>There are many ways that we can automate this. However, we are going with an official method and later we will cover other ways too.</p>

<div style="float: left; margin: 10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="3265433976"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<h4>How to Install unattended-upgrades package in Debian/Ubuntu?</h4>
<p> By default unattended-upgrades package should be installed on your system. But in case if it’s not installed use the following command to install it.</p>
<p>Use <strong><a href="https://www.2daygeek.com/apt-get-apt-cache-command-examples-manage-packages-debian-ubuntu-systems/" target="_blank">APT-GET Command</a></strong> or <strong><a href="https://www.2daygeek.com/apt-command-examples-manage-packages-debian-ubuntu-systems/" target="_blank">APT Command</a></strong> to install unattended-upgrades package.</p>
<pre>$ sudo apt-get install unattended-upgrades
</pre>
<p>The below two files are allows you to customize this utility.</p>
<pre>/etc/apt/apt.conf.d/50unattended-upgrades
/etc/apt/apt.conf.d/20auto-upgrades
</pre>
<h4>Make necessary changes in 50unattended-upgrades file</h4>
<p> By default only minimal required options were enabled for security updates. It&#8217;s not limited and you can configure many option in this to make this utility more useful.</p>
<p>I have trimmed the file and added only the enabled lines for better clarifications.</p>

<div style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-7730570141079407" data-ad-slot="5150237910"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<pre># vi /etc/apt/apt.conf.d/50unattended-upgrades

Unattended-Upgrade::Allowed-Origins {
        "${distro_id}:${distro_codename}";
	"${distro_id}:${distro_codename}-security";
	"${distro_id}ESM:${distro_codename}";
	};
Unattended-Upgrade::DevRelease "false";
</pre>
<p>There are three origins are enabled and the details are below.</p>

<div style="float: none; margin:10px 0 10px 0; text-align:center;">
<script id="mNCC" language="javascript">
   medianet_width = "728";
   medianet_height = "90";
   medianet_crid = "847533357";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUF666N9' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div>
<ul>
<li><strong><code>${distro_id}:${distro_codename}:</strong></code> It is necessary because security updates may pull in new dependencies from non-security sources.</li>
<li><strong><code>${distro_id}:${distro_codename}-security:</strong></code> It is used to get a security updates from sources.</li>
<li><strong><code>${distro_id}ESM:${distro_codename}:</strong></code> It is used to get a security updates for ESM (Extended Security Maintenance) users.</li>
</ul>
<p><strong>Enable Email Notification:</strong> If you would like to receive email notifications after every security update, then modify the following line (uncomment it and add your email id).</p>
<p>From:</p>
<pre>//Unattended-Upgrade::Mail "root";
</pre>
<p>To:</p>
<pre>Unattended-Upgrade::Mail "<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="a290c6c3dbc5c7c7c9e2c5cfc3cbce8cc1cdcf">[email&#160;protected]</a>";
</pre>
<p><strong>Auto Remove Unused Dependencies:</strong> You may need to run &#8220;sudo apt autoremove&#8221; command after every update to remove unused dependencies from the system.</p>
<p>We can automate this task by making the changes in the following line (uncomment it and change &#8220;false&#8221; to &#8220;true&#8221;).</p>
<p>From:</p>
<pre>//Unattended-Upgrade::Remove-Unused-Dependencies "false";
</pre>
<p>To:</p>
<pre>Unattended-Upgrade::Remove-Unused-Dependencies "true";
</pre>
<p><strong>Enable Automatic Reboot:</strong> You may need to reboot your system when a security updates installed for kernel. To do so, make the following changes in the following line.</p>
<p>From:</p>
<pre>//Unattended-Upgrade::Automatic-Reboot "false";
</pre>
<p>To: Uncomment it and change &#8220;false&#8221; to &#8220;true&#8221; to enable automatic reboot.</p>
<pre>Unattended-Upgrade::Automatic-Reboot "true";
</pre>
<p><strong>Enable Automatic Reboot at The Specific Time:</strong> If automatic reboot is enabled and you would like to perform the reboot at the specific time, then make the following changes.</p>
<p>From:</p>
<pre>//Unattended-Upgrade::Automatic-Reboot-Time "02:00";
</pre>
<p>To: Uncomment it and change the time as per your requirement. I set it to reboot at 5 AM.</p>
<pre>Unattended-Upgrade::Automatic-Reboot-Time "05:00";
</pre>
<h4>How to Enable Automatic Security Update?</h4>
<p> Now, we have configured the necessary options. Once you are done.</p>
<p>Open the following file and verify it, both the values are set up correctly or not? It should not be a zero&#8217;s. (1=enabled, 0=disabled).</p>
<pre># vi /etc/apt/apt.conf.d/20auto-upgrades

APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Unattended-Upgrade "1";
</pre>
<p><strong>Details:</strong></p>
<ul>
<li>The first line makes apt to perform “apt-get update” automatically every day.</li>
<li>The second line makes apt to install security updates automatically every day.</li>
</ul>

<div style="float: none; margin:10px 0 10px 0; text-align:center;">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script id="mNCC" language="javascript">  medianet_width='468';  medianet_height= '60';  medianet_crid='328488081';  </script> <script id="mNSC" src="https://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-7730570141079407" data-ad-slot="9495141575"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-17859" class="share-facebook sd-button share-icon" href="https://www.2daygeek.com/automatic-security-update-unattended-upgrades-ubuntu-debian/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-17859" class="share-linkedin sd-button share-icon" href="https://www.2daygeek.com/automatic-security-update-unattended-upgrades-ubuntu-debian/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-17859" class="share-twitter sd-button share-icon" href="https://www.2daygeek.com/automatic-security-update-unattended-upgrades-ubuntu-debian/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://www.2daygeek.com/automatic-security-update-unattended-upgrades-ubuntu-debian/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-17859" class="share-pinterest sd-button share-icon" href="https://www.2daygeek.com/automatic-security-update-unattended-upgrades-ubuntu-debian/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://www.2daygeek.com/automatic-security-update-unattended-upgrades-ubuntu-debian/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li></ul></div></div></div> <nav class="pagination group">
</nav>
</div>
<div class="clear"></div>
</div>
</div>
</article>
<div class="clear"></div>
<p class="post-tags"><span>Tags:</span> <a href="https://www.2daygeek.com/tag/apt-command/" rel="tag">apt command</a><a href="https://www.2daygeek.com/tag/apt-get-command/" rel="tag">apt-get command</a><a href="https://www.2daygeek.com/tag/automatic-security-update/" rel="tag">Automatic Security Update</a><a href="https://www.2daygeek.com/tag/automatically-install-security-updates/" rel="tag">Automatically Install Security Updates</a><a href="https://www.2daygeek.com/tag/debian/" rel="tag">Debian</a><a href="https://www.2daygeek.com/tag/install-security-updates/" rel="tag">Install Security Updates</a><a href="https://www.2daygeek.com/tag/ubuntu/" rel="tag">Ubuntu</a><a href="https://www.2daygeek.com/tag/unattended-upgrades/" rel="tag">Unattended Upgrades</a></p>
<div class="author-bio">
<div class="bio-avatar"><img src="https://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=128&#038;d=mm&#038;r=g" alt srcset="https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=256&amp;d=mm&amp;r=g 2x" class="avatar avatar-128 photo" height="128" width="128"><noscript><img alt='' src='https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=128&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=256&amp;d=mm&amp;r=g 2x' class='avatar avatar-128 photo' height='128' width='128' /></noscript></div>
<p class="bio-name">Magesh Maruthamuthu</p>
<p class="bio-desc">Love to play with all Linux distribution</p>
<div class="clear"></div>
</div>
<ul class="post-nav group">
<li class="next"></li>
<li class="previous"><a href="https://www.2daygeek.com/linux-os-installation-date-time/" rel="prev"><i class="fa fa-chevron-left"></i><strong>Previous story</strong> <span>How To Find Out Linux Operating System (OS) Installation Date And Time?</span></a></li>
</ul>
<h4 class="heading">
<i class="fa fa-hand-o-right"></i>You may also like...</h4>
<ul class="related-posts group">
<li class="related post-hover">
<article class="post-13181 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands category-package-management tag-delete-ppa tag-purge-ppa tag-remove-ppa">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/how-to-remove-delete-ppas-on-ubuntu-debian-linux-mint-elementary-os/" title="4 Easy Ways To Remove/Delete PPAs Completely On Ubuntu And It&#8217;s Derivatives">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.2daygeek.com/wp-content/uploads/2017/01/remove-delete-ppas-from-ubuntu-system-520x245.png" width="520" height="245" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt data-srcset="https://www.2daygeek.com/wp-content/uploads/2017/01/remove-delete-ppas-from-ubuntu-system-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2017/01/remove-delete-ppas-from-ubuntu-system-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px"><noscript><img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2017/01/remove-delete-ppas-from-ubuntu-system-520x245.png"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2017/01/remove-delete-ppas-from-ubuntu-system-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2017/01/remove-delete-ppas-from-ubuntu-system-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /></noscript> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/how-to-remove-delete-ppas-on-ubuntu-debian-linux-mint-elementary-os/" rel="bookmark" title="4 Easy Ways To Remove/Delete PPAs Completely On Ubuntu And It&#8217;s Derivatives">4 Easy Ways To Remove/Delete PPAs Completely On Ubuntu And It&#8217;s Derivatives</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2017-01-27 19:29:48">January 27, 2017</time>
</p>
</div>
</div>
</article>
</li>
<li class="related post-hover">
<article class="post-10775 post type-post status-publish format-standard has-post-thumbnail hentry category-ubuntu tag-ubuntu-tweak tag-unity-tweak tag-unity-tweak-tool">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/install-unity-tweak-tool-to-customize-ubuntu-desktop/" title="Customize Ubuntu Desktop using Unity Tweak Tool">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.2daygeek.com/wp-content/uploads/2016/04/unity-tweak-tool-to-customize-ubuntu-desktop-520x245.png" width="520" height="245" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt data-srcset="https://www.2daygeek.com/wp-content/uploads/2016/04/unity-tweak-tool-to-customize-ubuntu-desktop-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2016/04/unity-tweak-tool-to-customize-ubuntu-desktop-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px"><noscript><img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2016/04/unity-tweak-tool-to-customize-ubuntu-desktop-520x245.png"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2016/04/unity-tweak-tool-to-customize-ubuntu-desktop-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2016/04/unity-tweak-tool-to-customize-ubuntu-desktop-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /></noscript> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/install-unity-tweak-tool-to-customize-ubuntu-desktop/" rel="bookmark" title="Customize Ubuntu Desktop using Unity Tweak Tool">Customize Ubuntu Desktop using Unity Tweak Tool</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2016-05-04 01:16:56">May 4, 2016</time>
</p>
</div>
</div>
</article>
</li>
<li class="related post-hover">
<article class="post-10732 post type-post status-publish format-standard has-post-thumbnail hentry category-lemp category-ubuntu tag-hight-performance-web-server tag-install-lamp-stack tag-install-mysql tag-install-nginx tag-install-php tag-lemp tag-mysql tag-mysql_secure_installation tag-nginx tag-php tag-phpmyadmin tag-proxy-server tag-web-server">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/install-lemp-nginx-mariadb-php-phpmyadmin-on-ubuntu/" title="Install LEMP Server (Nginx 1.9, PHP 7.0, MariaDB 10.1 &#038; phpMyAdmin) on Ubuntu 14.04, 14.10, 15.04, 15.10 &#038; 16.04">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.2daygeek.com/wp-content/uploads/2016/04/install-lemp-on-ubuntu-520x245.png" width="520" height="245" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt data-srcset="https://www.2daygeek.com/wp-content/uploads/2016/04/install-lemp-on-ubuntu-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2016/04/install-lemp-on-ubuntu-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px"><noscript><img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2016/04/install-lemp-on-ubuntu-520x245.png"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2016/04/install-lemp-on-ubuntu-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2016/04/install-lemp-on-ubuntu-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /></noscript> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/install-lemp-nginx-mariadb-php-phpmyadmin-on-ubuntu/" rel="bookmark" title="Install LEMP Server (Nginx 1.9, PHP 7.0, MariaDB 10.1 &#038; phpMyAdmin) on Ubuntu 14.04, 14.10, 15.04, 15.10 &#038; 16.04">Install LEMP Server (Nginx 1.9, PHP 7.0, MariaDB 10.1 &#038; phpMyAdmin) on Ubuntu 14.04, 14.10, 15.04, 15.10 &#038; 16.04</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2016-04-28 00:05:39">April 28, 2016</time>
</p>
</div>
</div>
</article>
</li>
</ul>
<div id="disqus_thread"></div>
</div>
</section>
<div class="sidebar s1 collapsed" data-position="right" data-layout="col-2cl" data-sb-id="s1">
<a class="sidebar-toggle" title="Expand Sidebar"><i class="fa icon-sidebar-toggle"></i></a>
<div class="sidebar-content">
<div class="sidebar-top group">
<p>Follow:</p>
<ul class="social-links"><li><a rel="nofollow" class="social-tooltip" title="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fa fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fa fa-tumblr"></i></a></li></ul> </div>
<div id="media_image-4" class="widget widget_media_image"><h3 class="widget-title">Linux &#038; Open Source News</h3><a href="https://www.linuxtechnews.com/" class="" rel="" target="_blank"><img width="300" height="43" src="https://www.2daygeek.com/wp-content/uploads/2019/05/linuxtechnews-logo-v3-300x43.png" class="image wp-image-17665  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://www.2daygeek.com/wp-content/uploads/2019/05/linuxtechnews-logo-v3-300x43.png 300w, https://www.2daygeek.com/wp-content/uploads/2019/05/linuxtechnews-logo-v3.png 330w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div id="text-8" class="widget widget_text"><h3 class="widget-title">&#8211; Click Here To Get Offers &#8211;</h3> <div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="7612209571"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div><div id="media_image-5" class="widget widget_media_image"><h3 class="widget-title">Ethical Hacking Course</h3><a href="https://ethicalhackersacademy.com/?ref=400ewqahhx" class="" rel="" target="_blank"><img width="421" height="212" src="https://www.2daygeek.com/wp-content/uploads/2015/11/Hacking-Course-2.png" class="image wp-image-17800  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.2daygeek.com/wp-content/uploads/2015/11/Hacking-Course-2.png 421w, https://www.2daygeek.com/wp-content/uploads/2015/11/Hacking-Course-2-300x151.png 300w" sizes="(max-width: 421px) 100vw, 421px" /></a></div><div id="text-10" class="widget widget_text"><h3 class="widget-title">&#8211; For Better Offers &#8211;</h3> <div class="textwidget"><script id="mNCC" language="javascript">  medianet_width='300';  medianet_height= '250';  medianet_crid='108135239';  </script> <script id="mNSC" src="https://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script></div>
</div> <div id="wp_subscribe-3" class="widget wp_subscribe">
<div id="wp-subscribe" class="wp-subscribe-wrap wp-subscribe wp-subscribe-1" data-thanks_page="0" data-thanks_page_url="" data-thanks_page_new_window="0">
<h4 class="title">Get Latest LINUX Tips</h4>
<p class="text"></p>
<form action="https://feedburner.google.com/fb/a/mailverify?uri=2daygeekfeed" method="post" class="wp-subscribe-form wp-subscribe-feedburner" id="wp-subscribe-form-1" target="popupwindow">
<input class="regular-text email-field" type="email" name="email" placeholder="Enter your email here" required>
<input type="hidden" name="uri" value="2daygeekfeed">
<input type="hidden" name="loc" value="en_US">
<input type="hidden" name="form_type" value="widget">
<input type="hidden" name="service" value="feedburner">
<input type="hidden" name="widget" value="wp_subscribe-3">
<div class="wps-consent-wrapper">
<label for="consent-field">
<input class="consent-field" id="consent-field" type="checkbox" name="consent" required />
I consent to my submitted data being collected via this form* </label>
</div>
<input class="submit" type="submit" name="submit" value="Sign Up Now">
</form>
<div class="wp-subscribe-loader">
<svg version="1.1" id="loader-1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0" y="0" width="40px" height="40px" viewBox="0 0 50 50" style="enable-background:new 0 0 50 50;" xml:space="preserve">
<path fill="#ffffff" d="M43.935,25.145c0-10.318-8.364-18.683-18.683-18.683c-10.318,0-18.683,8.365-18.683,18.683h4.068c0-8.071,6.543-14.615,14.615-14.615c8.072,0,14.615,6.543,14.615,14.615H43.935z">
<animateTransform attributeType="xml" attributeName="transform" type="rotate" from="0 25 25" to="360 25 25" dur="0.6s" repeatCount="indefinite" />
</path>
</svg>
</div>
<p class="thanks">Thank you for subscribing.</p>
<p class="error">Something went wrong.</p>
<div class="clear"></div>
<p class="footer-text"></p>
</div>
</div>
<div id="text-3" class="widget widget_text"><h3 class="widget-title">To Search, Type and Hit Enter</h3> <div class="textwidget"><script>
  (function() {
    var cx = '007232544684438091033:5mzh938wm_e';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchresults-only></gcse:searchresults-only></div>
</div><div id="text-6" class="widget widget_text"><h3 class="widget-title">Google Translater</h3> <div class="textwidget"><div id="google_translate_element"></div><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script></div>
</div><div id="media_image-6" class="widget widget_media_image"><h3 class="widget-title">Linux Online Course</h3><a href="https://stacksocial.com/sales/complete-linux-crash-course-includes-topics-on-red-hat-unix-kali-python-and-opensuse?aid=a-4s5jc8po" class="" rel="" target="_blank"><img width="402" height="355" src="https://www.2daygeek.com/wp-content/uploads/2015/11/Linux-Online-Course.png" class="image wp-image-17806  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.2daygeek.com/wp-content/uploads/2015/11/Linux-Online-Course.png 402w, https://www.2daygeek.com/wp-content/uploads/2015/11/Linux-Online-Course-300x265.png 300w" sizes="(max-width: 402px) 100vw, 402px" /></a></div>
</div>
</div>
</div>
</div>
</div>
</div>
<footer id="footer">
<section class="container" id="footer-bottom">
<div class="container-inner">
<a id="back-to-top" href="#"><i class="fa fa-angle-up"></i></a>
<div class="pad group">
<div class="grid one-half">
<div id="copyright">
<p>2daygeek.com &copy; 2019. All Rights Reserved.</p>
</div>
<div id="credit" style="">
<p><a href="https://www.2daygeek.com">2daygeek</a> :- Linux Tips & Tricks, Linux How-to Guides & Tutorials is licensed under a <a href="https://creativecommons.org/licenses/by-nc/4.0/" rel="nofollow">(cc) BY-NC</a></p>
</div>
</div>
<div class="grid one-half last">
<ul class="social-links"><li><a rel="nofollow" class="social-tooltip" title="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fa fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fa fa-tumblr"></i></a></li></ul> </div>
</div>
</div>
</section>
</footer>
</div>
<div style="display:none">
<div class="grofile-hash-map-d487bef1de15143a7b80a40396e96118">
</div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.2daygeek.com\/automatic-security-update-unattended-upgrades-ubuntu-debian\/":17859};
	</script>
<link rel='stylesheet' id='wp-subscribe-css' href='https://www.2daygeek.com/wp-content/plugins/wp-subscribe/assets/css/wp-subscribe-form.css?ver=4.8.9' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.2daygeek.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"2daygeek"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"17859 https:\/\/www.2daygeek.com\/?p=17859","disqusShortname":"2daygeek","disqusTitle":"How To Set up Automatic Security Update (Unattended Upgrades) on Debian\/Ubuntu?","disqusUrl":"https:\/\/www.2daygeek.com\/automatic-security-update-unattended-upgrades-ubuntu-debian\/","postId":"17859"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201933'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/wf-cookie-consent/js/cookiechoices.min.js?ver=4.8.9'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Augaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.8.9'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"","extLinksTargetExt":"","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"1","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":true,"mobile":true},"isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_up","mobile":"stick_up"},"isDevMode":"","ajaxUrl":"https:\/\/www.2daygeek.com\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"3ef2ee558c"},"userStarted":{"with":"with|3.0.11","on":{"date":"2017-08-08 07:25:43.000000","timezone_type":3,"timezone":"UTC"}},"isWelcomeNoteOn":"","welcomeContent":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/scripts.min.js?ver=3.3.20'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/comment-reply.min.js?ver=4.8.9'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?ver=0.6.1'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/lazy-load/js/lazy-load.js?ver=0.6.1'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/wp-embed.min.js?ver=4.8.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wp_subscribe = {"ajaxurl":"https:\/\/www.2daygeek.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/wp-subscribe/assets/js/wp-subscribe-form.js?ver=4.8.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.0.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<!--[if lt IE 9]>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/respond.js"></script>
<![endif]-->
<script type="text/javascript">
	window._wfCookieConsentSettings = {"wf_cookietext":"Cookies help us deliver our services. By using our services, you agree to our use of cookies.","wf_dismisstext":"Got it","wf_linktext":"Learn more","wf_linkhref":"https:\/\/www.2daygeek.com\/about-us\/","wf_position":"top","language":"en"};
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201933.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.0.1',blog:'160649683',post:'17859',tz:'5.5',srv:'www.2daygeek.com'} ]);
	_stq.push([ 'clickTrackerInit', '160649683', '17859' ]);
</script>
</body>
</html>