<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-71235901-1', 'auto');
  ga('send', 'pageview');
</script>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.2daygeek.com/xmlrpc.php">
<title>4 Easiest Ways To Find Out Process ID (PID) In Linux | 2daygeek.com</title>
<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>

<link rel="author" href="https://plus.google.com/+2daygeeks" />
<meta name="description" content="Everybody knows about PID, Exactly what is PID? Why you want PID? What are you going to do using PID? Are you having the same questions on your mind? If so, you" />
<meta name="keywords" content="process id,pid,ppid,linux,program name,instances id" />
<link rel="canonical" href="https://www.2daygeek.com/how-to-check-find-the-process-id-pid-ppid-of-a-running-program-in-linux/" />

<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; Feed" href="https://www.2daygeek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; Comments Feed" href="https://www.2daygeek.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="2daygeek.com &raquo; 4 Easiest Ways To Find Out Process ID (PID) In Linux Comments Feed" href="https://www.2daygeek.com/how-to-check-find-the-process-id-pid-ppid-of-a-running-program-in-linux/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.2daygeek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='spu-css-css' href='https://www.2daygeek.com/wp-content/plugins/social-popup/spu.css?ver=1.6.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css-css' href='https://www.2daygeek.com/wp-content/plugins/accesspress-social-counter/css/font-awesome.min.css?ver=1.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='apsc-frontend-css-css' href='https://www.2daygeek.com/wp-content/plugins/accesspress-social-counter/css/frontend.css?ver=1.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='arconix-shortcodes-css' href='https://www.2daygeek.com/wp-content/plugins/arconix-shortcodes/includes/css/arconix-shortcodes.min.css?ver=2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://www.2daygeek.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='cresta-social-crestafont-css' href='https://www.2daygeek.com/wp-content/plugins/cresta-social-share-counter/css/csscfont.css?ver=2.7.6' type='text/css' media='all' />
<link rel='stylesheet' id='cresta-social-wp-style-css' href='https://www.2daygeek.com/wp-content/plugins/cresta-social-share-counter/css/cresta-wp-css.css?ver=2.7.6' type='text/css' media='all' />
<link rel='stylesheet' id='cresta-social-googlefonts-css' href='//fonts.googleapis.com/css?family=Noto+Sans:400,700' type='text/css' media='all' />
<link rel='stylesheet' id='gglcptch-css' href='https://www.2daygeek.com/wp-content/plugins/google-captcha/css/gglcptch.css?ver=1.33' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-main-style-css' href='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/main.min.css?ver=3.3.20' type='text/css' media='all' />
<link rel='stylesheet' id='theme-stylesheet-css' href='https://www.2daygeek.com/wp-content/themes/my-child-theme/style.css?ver=3.3.20' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-font-awesome-css' href='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/font-awesome.min.css?ver=3.3.20' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.2daygeek.com/wp-content/tablepress-combined.min.css?ver=10' type='text/css' media='all' />
<script>
      if (document.location.protocol != "https:") {
          document.location = document.URL.replace(/^http:/i, "https:");
      }
      </script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://connect.facebook.net/en_US/all.js?ver=1.6.4.3#xfbml=1'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=1.6.4.3'></script>
<script type='text/javascript' src='https://apis.google.com/js/plusone.js?ver=1.6.4.3'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/social-popup/spu.js?ver=1.6.4.3'></script>
<link rel='https://api.w.org/' href='https://www.2daygeek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.2daygeek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.2daygeek.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='How To Allow/Permit User To Access A Specific File or Folder In Linux Using ACL' href='https://www.2daygeek.com/how-to-configure-access-control-lists-acls-setfacl-getfacl-linux/' />
<meta name="generator" content="WordPress 4.8.4" />
<link rel='shortlink' href='https://www.2daygeek.com/?p=15346' />
<link rel="alternate" type="application/json+oembed" href="https://www.2daygeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.2daygeek.com%2Fhow-to-check-find-the-process-id-pid-ppid-of-a-running-program-in-linux%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.2daygeek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.2daygeek.com%2Fhow-to-check-find-the-process-id-pid-ppid-of-a-running-program-in-linux%2F&#038;format=xml" />
<style type='text/css'>
			@media (max-width : 640px) {
				#crestashareicon {
					display:none !important;
				}
			}
		#crestashareicon {position:fixed; top:35%; left:20px; float:left;z-index:99;}

		#crestashareicon .sbutton {clear:both;display:none;}
		#crestashareicon .sbutton { float:left;}</style>
<style type="text/css">
					.spu-button {
		margin-left:15px;
		margin-left: 15px;
		display: inline-table;
		margin-top: 12px;
		vertical-align: middle;
}
#spu-msg-cont {
	border-bottom:1px solid#ccc;
	border-top:1px solid#ccc;
	background-image:linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);
	background-image:-o-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);
	background-image:-moz-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);
	background-image:-webkit-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);
	background-image:-ms-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);
	background-image:-webkit-gradient(linear,left bottom,left top,color-stop(0,#D8E7FC),color-stop(0.85,#EBF2FC));
	padding:16px;
}
#spu-msg {
	margin:0 0 22px;
}
.step-clear {
	clear:both!important;
}
#spu-title {
	font-family:'Lucida Sans Unicode,Lucida Grande,sans-serif!important;
	font-size:12px;
	padding:12px 0 9px 10px;
	font-size:16px;
}					</style>
<script type="text/javascript">
						jQuery(document).ready(function($){
								
						setTimeout( 
						function(){				
							socialPopUP({
								// Configure display of popup
								advancedClose: true,
								opacity: "0.65",
								s_to_close: "0",
								days_no_click: "99",
								segundos : "seconds",
								esperar : "Wait",
								thanks_msg : "Thanks for supporting our site!!!",
								thanks_sec : "3",
							})
						}
							,1000								);
						});	
						
						
					</script>
<!--[if lt IE 9]>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js"></script>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js"></script>
<![endif]-->
<style type="text/css" id="hu-dynamic-style">/* Dynamic CSS: For no styles in head, copy and put the css below in your child theme's style.css, disable dynamic styles */body { font-size:1.00rem; }@media only screen and (min-width: 720px) {
        .nav > li { font-size:1.00rem; }
      }.container-inner { max-width: 1275px; }::selection { background-color: #3b8dbd; }
::-moz-selection { background-color: #3b8dbd; }a,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #3b8dbd; }.themeform input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #3b8dbd; }.post-format .format-container { border-color: #3b8dbd; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #3b8dbd!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #82b965; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #82b965; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #82b965; }
.post-comments span:before { border-right-color: #82b965; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #3b8dbd}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #3b8dbd; }
              }.is-scrolled #header .nav-container.desktop-sticky,
              .is-scrolled #header .search-expand { background-color: #3b8dbd; background-color: rgba(59,141,189,0.90) }.is-scrolled .topbar-transparent #nav-topbar.desktop-sticky .nav ul { background-color: #3b8dbd; background-color: rgba(59,141,189,0.95) }#header { background-color: #33363b; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #33363b; }
}
        #header #nav-mobile { background-color: #33363b; }.is-scrolled #header #nav-mobile { background-color: #33363b; background-color: rgba(51,54,59,0.90) }#nav-header.nav-container, #main-header-search .search-expand { background-color: #fa720e; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #fa720e; }
}
        img { -webkit-border-radius: 2px; border-radius: 2px; }body { background-color: #eaeaea; }</style>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-15346 single-format-standard wp-custom-logo col-2cl full-width topbar-enabled header-desktop-sticky header-mobile-sticky unknown">
<div id="wrapper">
<header id="header" class="main-menu-mobile-on one-mobile-menu main_menu header-ads-desktop  topbar-transparent">
<nav class="nav-container group mobile-menu mobile-sticky " id="nav-mobile" data-menu-id="header-1">
<div class="mobile-title-logo-in-header"> <p class="site-title"><a class="custom-logo-link" href="https://www.2daygeek.com/" rel="home" title="2daygeek.com | Home page"><img src="https://www.2daygeek.com/wp-content/uploads/2015/12/2day-geek-new-logo-final.png" alt="2daygeek.com"></a></p>
</div>

<div class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false">
<div class="ham__navbar-span-wrapper">
<span class="line line-1"></span>
<span class="line line-2"></span>
<span class="line line-3"></span>
</div>
</div>
 <div class="nav-text"></div>
<div class="nav-wrap container">
<ul class="nav container-inner group mobile-search">
<li>
<form method="get" class="searchform themeform" action="https://www.2daygeek.com/">
<div>
<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
</div>
</form> </li>
</ul>
<ul id="menu-menu-2" class="nav container-inner group"><li id="menu-item-6808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6808"><a href="https://www.2daygeek.com/category/linux-distributions/">LINUX DISTRO&#8217;S</a></li>
<li id="menu-item-6806" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6806"><a href="https://www.2daygeek.com/category/linux-commands/">LINUX COMMAND&#8217;S</a></li>
<li id="menu-item-9582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9582"><a href="https://www.2daygeek.com/category/webserver/">WEBSERVER</a></li>
<li id="menu-item-6809" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6809"><a href="https://www.2daygeek.com/category/monitoring-tools/">MONITORING TOOLS</a></li>
<li id="menu-item-6883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6883"><a href="https://www.2daygeek.com/category/package-management/">PACKAGE MANAGEMENT</a></li>
<li id="menu-item-6811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6811"><a href="https://www.2daygeek.com/category/repository/">REPOSITORY</a></li>
<li id="menu-item-6986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6986"><a href="https://www.2daygeek.com/category/free-cloud-storage/">CLOUD STORAGE</a></li>
<li id="menu-item-14871" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-14871"><a href="https://gbhackers.com/">HACKING</a>
<ul class="sub-menu">
<li id="menu-item-14872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14872"><a href="https://gbhackers.com/">Tutorials</a></li>
</ul>
</li>
</ul> </div>
</nav>
<nav class="nav-container group desktop-menu desktop-sticky " id="nav-topbar" data-menu-id="header-2">
<div class="nav-text"></div>
<div class="topbar-toggle-down">
<i class="fa fa-angle-double-down" aria-hidden="true" data-toggle="down" title="Expand menu"></i>
<i class="fa fa-angle-double-up" aria-hidden="true" data-toggle="up" title="Collapse menu"></i>
</div>
<div class="nav-wrap container">
<ul id="menu-menu-1" class="nav container-inner group"><li id="menu-item-293" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-293"><a href="https://www.2daygeek.com/">HOME</a></li>
<li id="menu-item-10920" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10920"><a href="http://linuxnews.2daygeek.com/">LINUX NEWS</a></li>
<li id="menu-item-294" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294"><a href="https://www.2daygeek.com/about-us/">ABOUT US</a></li>
<li id="menu-item-295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295"><a href="https://www.2daygeek.com/contact-us/">CONTACT US</a></li>
<li id="menu-item-296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-296"><a href="https://www.2daygeek.com/disclaimer/">DISCLAIMER</a></li>
<li id="menu-item-3676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3676"><a href="https://www.2daygeek.com/privacy-policy/">PRIVACY POLICY</a></li>
<li id="menu-item-2729" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2729"><a href="https://www.2daygeek.com/support-us/">SUPPORT US</a></li>
<li id="menu-item-8366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8366"><a href="https://www.2daygeek.com/category/os-tweaks/">OS TWEAK</a></li>
<li id="menu-item-12012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12012"><a href="https://www.2daygeek.com/category/icon-theme/">ICONS</a></li>
<li id="menu-item-12013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12013"><a href="https://www.2daygeek.com/category/gtk-theme/">THEMES</a></li>
</ul> </div>
<div id="topbar-header-search" class="container">
<div class="container-inner">
<div class="toggle-search"><i class="fa fa-search"></i></div>
<div class="search-expand">
<div class="search-expand-inner"><form method="get" class="searchform themeform" action="https://www.2daygeek.com/">
<div>
<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
</div>
</form></div>
</div>
</div>
</div>
</nav>
<div class="container group">
<div class="container-inner">
<div class="group pad central-header-zone">
<div class="logo-tagline-group">
<p class="site-title"><a class="custom-logo-link" href="https://www.2daygeek.com/" rel="home" title="2daygeek.com | Home page"><img src="https://www.2daygeek.com/wp-content/uploads/2015/12/2day-geek-new-logo-final.png" alt="2daygeek.com"></a></p>
</div>
<div id="header-widgets">
<div style="float:left;border:solid 0px;height:90px;width:728px;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="3848983170"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
</div>
<nav class="nav-container group desktop-menu " id="nav-header" data-menu-id="header-3">
<div class="nav-text"></div>
<div class="nav-wrap container">
<ul id="menu-menu-3" class="nav container-inner group"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6808"><a href="https://www.2daygeek.com/category/linux-distributions/">LINUX DISTRO&#8217;S</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6806"><a href="https://www.2daygeek.com/category/linux-commands/">LINUX COMMAND&#8217;S</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9582"><a href="https://www.2daygeek.com/category/webserver/">WEBSERVER</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6809"><a href="https://www.2daygeek.com/category/monitoring-tools/">MONITORING TOOLS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6883"><a href="https://www.2daygeek.com/category/package-management/">PACKAGE MANAGEMENT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6811"><a href="https://www.2daygeek.com/category/repository/">REPOSITORY</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6986"><a href="https://www.2daygeek.com/category/free-cloud-storage/">CLOUD STORAGE</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-14871"><a href="https://gbhackers.com/">HACKING</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14872"><a href="https://gbhackers.com/">Tutorials</a></li>
</ul>
</li>
</ul> </div>
</nav>
</div>
</div>
</header>
<div class="container" id="page">
<div class="container-inner">
<div class="main">
<div class="main-inner group">
<section class="content">
 <div class="page-title pad group">
<ul class="meta-single group">
<li class="category"><a href="https://www.2daygeek.com/category/linux-commands/" rel="category tag">Linux Commands</a></li>
</ul>
</div>
<div class="pad group">
<article class="post-15346 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-instances-id tag-linux tag-pid tag-ppid tag-process-id tag-program-name">
<div class="post-inner group">
<h1 class="post-title entry-title">4 Easiest Ways To Find Out Process ID (PID) In Linux</h1>
<p class="post-byline">by <span class="vcard author">
<span class="fn"><a href="https://www.2daygeek.com/author/magesh/" title="Posts by Magesh Maruthamuthu" rel="author">Magesh Maruthamuthu</a></span>
</span> &middot;
<span class="published">Published : December 19, 2017 || Last Updated: December 19, 2017</span>
</p>
<div class="clear"></div>
<div class="entry themeform">
<div class="entry-inner">

<div style="float:left;margin:10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="8826511175"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>Everybody knows about PID, Exactly what is PID? Why you want PID? What are you going to do using PID? Are you having the same questions on your mind? If so, you are in the right place to get all the details.</p>
<p>Mainly, we are looking PID to kill an unresponsive program and it&#8217;s similar to Windows task manager. Linux GUI also offering the same feature but CLI is an efficient way to perform the kill operation.</p>
<h4>What Is Process ID?</h4>
<p> PID stands for process identification number which is generally used by most operating system kernels such as Linux, Unix, macOS and Windows. It is a unique identification number that is automatically assigned to each process when it is created in an operating system. A process is a running instance of a program.</p>
<p style="padding: 15px; background-color: #dbe7f8; border: 1px solid #b0cbf0; color: #1e529c;"><strong>Suggested Read : </strong> <a style="color: #1e529c; text-decoration: none;" href="https://www.2daygeek.com/check-find-apache-httpd-web-server-uptime-linux/" target="_blank">How To Check Apache Web Server Uptime In Linux</a></p>
<p>Each time process ID will be getting change to all the processes except init because init is always the first process on the system and is the ancestor of all other processes. It&#8217;s PID is 1.</p>
<p>The default maximum value of PIDs is <code>32,768</code>. The same has been verified by running the following command on your system <code>cat /proc/sys/kernel/pid_max</code>. On 32-bit systems 32768 is the maximum value but we can set to any value up to 2^22 (approximately 4 million) on 64-bit systems.</p>
<p>You may ask, why we need such amount of PIDs? because we can&#8217;t reused the PIDs immediately that&#8217;s why. Also in order to prevent possible errors.</p>
<p>The PIDs for the running processes on the system can be found by using the pidof command, pgrep command, ps command, and pstree command.</p>

<div style="float:left;margin:10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="3265433976"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<h4>Method-1 : Using pidof Command</h4>
<p> pidof used to find the process ID of a running program. It&#8217;s prints those id&#8217;s on the standard output. To demonstrate this, we are going to find out the Apache2 process id from Debian 9 (stretch) system.</p>
<pre># pidof apache2
<strong><span style="color: #00FF00;">3754</span></strong> 2594 2365 2364 2363 2362 2361
</pre>
<p>From the above output you may face difficulties to identify the Process ID because it&#8217;s shows all the PIDs (included Parent and Childs) aginst the process name. Hence we need to find out the parent PID (PPID), which is the one we are looking. It could be the first number. In my case it&#8217;s <code>3754</code> and it&#8217;s shorted in descending order.</p>
<h4>Method-2 : Using pgrep Command</h4>
<p> pgrep looks through the currently running processes and lists the process IDs which match the selection criteria to stdout.</p>
<pre># pgrep apache2
2361
2362
2363
2364
2365
2594
<strong><span style="color: #00FF00;">3754</span></strong>
</pre>
<p>This also similar to the above output but it&#8217;s shorting the results in ascending order, which clearly says that the parent PID is the last one. In my case it&#8217;s <code>3754</code>.</p>
<p><strong>Note : </strong>If you have more than one process id of the process, you may face trouble to identify the parent process id when using pidof &#038; pgrep command.</p>
<h4>Method-3 : Using pstree Command</h4>
<p> pstree shows running processes as a tree. The tree is rooted at either pid or init if pid is omitted. If a user name is specified in the pstree command then it&#8217;s shows all the process owned by the corresponding user.</p>
<p>pstree visually merges identical branches by putting them in square brackets and prefixing them with the repetition count.</p>

<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-7730570141079407" data-ad-slot="5150237910"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<pre># pstree -p | grep "apache2"
           |-<strong><span style="color: #00FF00;">apache2(3754)</span></strong>-+-apache2(2361)
           |               |-apache2(2362)
           |               |-apache2(2363)
           |               |-apache2(2364)
           |               |-apache2(2365)
           |               `-apache2(2594)
</pre>
<p>To get parent process alone, use the following format.</p>
<pre># pstree -p | grep "apache2" | head -1
           |-<strong><span style="color: #00FF00;">apache2(3754)</span></strong>-+-apache2(2361)
</pre>
<p>pstree command is very simple because it&#8217;s segregating the Parent and Child processes separately but it&#8217;s not easy when using pidof &#038; pgrep command.</p>
<h4>Method-4 : Using ps Command</h4>
<p> ps displays information about a selection of the active processes. It displays the process ID (pid=PID), the terminal associated with the process (tname=TTY), the cumulated CPU time in [DD-]hh:mm:ss format (time=TIME), and the executable name (ucmd=CMD). Output is unsorted by default.</p>
<pre># ps aux | grep "apache2"
www-data  2361  0.0  0.4 302652  9732 ?        S    06:25   0:00 /usr/sbin/apache2 -k start
www-data  2362  0.0  0.4 302652  9732 ?        S    06:25   0:00 /usr/sbin/apache2 -k start
www-data  2363  0.0  0.4 302652  9732 ?        S    06:25   0:00 /usr/sbin/apache2 -k start
www-data  2364  0.0  0.4 302652  9732 ?        S    06:25   0:00 /usr/sbin/apache2 -k start
www-data  2365  0.0  0.4 302652  8400 ?        S    06:25   0:00 /usr/sbin/apache2 -k start
www-data  2594  0.0  0.4 302652  8400 ?        S    06:55   0:00 /usr/sbin/apache2 -k start
<strong><span style="color: #00FF00;">root      3754  0.0  1.4 302580 29324 ?        Ss   Dec11   0:23 /usr/sbin/apache2 -k start</span></strong>
root      5648  0.0  0.0  12784   940 pts/0    S+   21:32   0:00 grep apache2
</pre>

<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script id="mNCC" language="javascript">
   medianet_width = "728";
   medianet_height = "90";
   medianet_crid = "847533357";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUF666N9' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div>
<p>From the above output we can easily identify the parent process id (PPID) based on the process start date. In my case apache2 process was started @ <code>Dec11</code> which is the parent and others are child&#8217;s. PID of apache2 is <code>3754</code>.<br />
<strong>References:</strong></p>
<ul>
<li><a href="https://askubuntu.com/questions/180336/how-to-find-the-process-id-pid-of-a-running-terminal-program" rel="noopener" target="_blank">AskUbuntu</a></li>
</ul>

<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-7730570141079407" data-ad-slot="9495141575"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div style="font-size:0px;height:0px;line-height:0px;margin:0;padding:0;clear:both"></div> <nav class="pagination group">
</nav>
</div>
<div class="clear"></div>
</div>
</div>
</article>
<div class="clear"></div>
<p class="post-tags"><span>Tags:</span> <a href="https://www.2daygeek.com/tag/instances-id/" rel="tag">Instances ID</a><a href="https://www.2daygeek.com/tag/linux/" rel="tag">Linux</a><a href="https://www.2daygeek.com/tag/pid/" rel="tag">PID</a><a href="https://www.2daygeek.com/tag/ppid/" rel="tag">PPID</a><a href="https://www.2daygeek.com/tag/process-id/" rel="tag">Process ID</a><a href="https://www.2daygeek.com/tag/program-name/" rel="tag">Program Name</a></p>
<div class="author-bio">
<div class="bio-avatar"><img src="https://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=128&#038;d=mm&#038;r=g" alt srcset="https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=256&amp;d=mm&amp;r=g 2x" class="avatar avatar-128 photo" height="128" width="128"><noscript><img alt='' src='https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=128&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=256&amp;d=mm&amp;r=g 2x' class='avatar avatar-128 photo' height='128' width='128' /></noscript></div>
<p class="bio-name">Magesh Maruthamuthu</p>
<p class="bio-desc">Love to play with all Linux distribution</p>
<div class="clear"></div>
</div>
<ul class="post-nav group">
<li class="next"></li>
<li class="previous"><a href="https://www.2daygeek.com/how-to-configure-access-control-lists-acls-setfacl-getfacl-linux/" rel="prev"><i class="fa fa-chevron-left"></i><strong>Previous story</strong> <span>How To Allow/Permit User To Access A Specific File or Folder In Linux Using ACL</span></a></li>
</ul>
<h4 class="heading">
<i class="fa fa-hand-o-right"></i>You may also like...</h4>
<ul class="related-posts group">
<li class="related post-hover">
<article class="post-12362 post type-post status-publish format-standard has-post-thumbnail hentry category-general category-linux-commands tag-command-line-google-search tag-google-command-line-search tag-google-news-from-the-terminal tag-google-search tag-google-search-from-the-command-line tag-google-site-search">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/googler-google-search-from-the-command-line-on-linux/" title="Googler &#8211; Google Search From The Linux Command Line">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.2daygeek.com/wp-content/uploads/2016/09/google-search-from-the-command-line-on-linux-520x245.png" width="520" height="245" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt data-srcset="https://www.2daygeek.com/wp-content/uploads/2016/09/google-search-from-the-command-line-on-linux-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2016/09/google-search-from-the-command-line-on-linux-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px"><noscript><img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2016/09/google-search-from-the-command-line-on-linux-520x245.png"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2016/09/google-search-from-the-command-line-on-linux-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2016/09/google-search-from-the-command-line-on-linux-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /></noscript> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/googler-google-search-from-the-command-line-on-linux/" rel="bookmark" title="Googler &#8211; Google Search From The Linux Command Line">Googler &#8211; Google Search From The Linux Command Line</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2016-09-23 00:05:08">September 23, 2016</time>
</p>
</div>
</div>
</article>
</li>
<li class="related post-hover">
<article class="post-15034 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-linux tag-recycle-bin tag-trash tag-trash-cli tag-trashcan">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/trash-cli-command-line-trashcan-linux-system/" title="Trash-Cli : A Command Line Interface For Trashcan On Linux">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.2daygeek.com/wp-content/uploads/2017/10/trash-cli-command-line-interface-for-trash-can-linux-520x245.png" width="520" height="245" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt data-srcset="https://www.2daygeek.com/wp-content/uploads/2017/10/trash-cli-command-line-interface-for-trash-can-linux-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2017/10/trash-cli-command-line-interface-for-trash-can-linux-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px"><noscript><img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2017/10/trash-cli-command-line-interface-for-trash-can-linux-520x245.png"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2017/10/trash-cli-command-line-interface-for-trash-can-linux-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2017/10/trash-cli-command-line-interface-for-trash-can-linux-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /></noscript> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/trash-cli-command-line-trashcan-linux-system/" rel="bookmark" title="Trash-Cli : A Command Line Interface For Trashcan On Linux">Trash-Cli : A Command Line Interface For Trashcan On Linux</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2017-10-03 17:26:38">October 3, 2017</time>
</p>
</div>
</div>
</article>
</li>
<li class="related post-hover">
<article class="post-14854 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-commands tag-bash tag-exa tag-linux-command tag-list-directory tag-list-files tag-ls">
<div class="post-thumbnail">
<a href="https://www.2daygeek.com/exa-a-modern-replacement-for-ls-command-linux/" title="Exa &#8211; A Modern And Colorful Replacement For LS Command Written In Rust">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://www.2daygeek.com/wp-content/uploads/2017/09/exa-modern-replacement-for-ls-520x245.png" width="520" height="245" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt data-srcset="https://www.2daygeek.com/wp-content/uploads/2017/09/exa-modern-replacement-for-ls-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2017/09/exa-modern-replacement-for-ls-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px"><noscript><img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.2daygeek.com/wp-content/uploads/2017/09/exa-modern-replacement-for-ls-520x245.png"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://www.2daygeek.com/wp-content/uploads/2017/09/exa-modern-replacement-for-ls-520x245.png 520w, https://www.2daygeek.com/wp-content/uploads/2017/09/exa-modern-replacement-for-ls-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" /></noscript> </a>
</div>
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="https://www.2daygeek.com/exa-a-modern-replacement-for-ls-command-linux/" rel="bookmark" title="Exa &#8211; A Modern And Colorful Replacement For LS Command Written In Rust">Exa &#8211; A Modern And Colorful Replacement For LS Command Written In Rust</a>
</h4>
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2017-09-15 11:51:44">September 15, 2017</time>
</p>
</div>
</div>
</article>
</li>
</ul>
<div id="disqus_thread">
</div>
</div>
</section>
<div class="sidebar s1 collapsed" data-position="right" data-layout="col-2cl" data-sb-id="s1">
<a class="sidebar-toggle" title="Expand Sidebar"><i class="fa icon-sidebar-toggle"></i></a>
<div class="sidebar-content">
<div class="sidebar-top group">
<p>Follow:</p>
<ul class="social-links"><li><a rel="nofollow" class="social-tooltip" title="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Google+" href="https://www.google.com/+2daygeeks" target="_blank" style="color:#ffffff"><i class="fa fa-google-plus"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fa fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fa fa-tumblr"></i></a></li></ul> </div>
<div id="text-8" class="widget widget_text"><h3 class="widget-title">&#8211; Click Here To Get Offers &#8211;</h3> <div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="7612209571"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div><div id="text-10" class="widget widget_text"><h3 class="widget-title">&#8211; For Better Offers &#8211;</h3> <div class="textwidget"><script id="mNCC" language="javascript">  medianet_width='300';  medianet_height= '250';  medianet_crid='108135239';  </script> <script id="mNSC" src="https://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script></div>
</div><div id="text-12" class="widget widget_text"><h3 class="widget-title">-Unmatched Offers For Linux Users-</h3> <div class="textwidget"></div>
</div> <div id="wp_subscribe-3" class="widget wp_subscribe">
<div id="wp-subscribe" class="wp-subscribe-wrap wp-subscribe wp-subscribe-1" data-thanks_page="0" data-thanks_page_url="" data-thanks_page_new_window="0">
<h4 class="title">Get Latest LINUX Tips</h4>
<p class="text"></p>
<form action="https://feedburner.google.com/fb/a/mailverify?uri=2daygeekfeed" method="post" class="wp-subscribe-form wp-subscribe-feedburner" id="wp-subscribe-form-1" target="popupwindow">
<input class="regular-text email-field" type="text" name="email" placeholder="Enter your email here">
<input type="hidden" name="uri" value="2daygeekfeed">
<input type="hidden" name="loc" value="en_US">
<input type="hidden" name="form_type" value="widget">
<input type="hidden" name="service" value="feedburner">
<input type="hidden" name="widget" value="wp_subscribe-3">
<input class="submit" type="submit" name="submit" value="Sign Up Now">
</form>
<div class="wp-subscribe-loader">
<svg version="1.1" id="loader-1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0" y="0" width="40px" height="40px" viewBox="0 0 50 50" style="enable-background:new 0 0 50 50;" xml:space="preserve">
<path fill="" d="M43.935,25.145c0-10.318-8.364-18.683-18.683-18.683c-10.318,0-18.683,8.365-18.683,18.683h4.068c0-8.071,6.543-14.615,14.615-14.615c8.072,0,14.615,6.543,14.615,14.615H43.935z">
<animateTransform attributeType="xml" attributeName="transform" type="rotate" from="0 25 25" to="360 25 25" dur="0.6s" repeatCount="indefinite" />
</path>
</svg>
</div>
<p class="thanks">Thank you for subscribing.</p>
<p class="error">Something went wrong.</p>
<div class="clear"></div>
<p class="footer-text"></p>
</div>
</div>
<div id="text-3" class="widget widget_text"> <div class="textwidget"><script>
  (function() {
    var cx = '014898341766687711766:ajz3putspfm';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//www.google.com/cse/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only></div>
</div><div id="text-6" class="widget widget_text"> <div class="textwidget"><div id="google_translate_element"></div><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script></div>
</div><div id="text-5" class="widget widget_text"><h3 class="widget-title">Follow us</h3> <div class="textwidget">
<div class="g-page" data-href="//plus.google.com/107364365185869631781" data-layout="landscape" data-rel="publisher"></div>

<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/platform.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<footer id="footer">
<section class="container" id="footer-bottom">
<div class="container-inner">
<a id="back-to-top" href="#"><i class="fa fa-angle-up"></i></a>
<div class="pad group">
<div class="grid one-half">
<div id="copyright">
<p>2daygeek.com &copy; 2017. All Rights Reserved.</p>
</div>
 <div id="credit" style="">
<p><a href="https://www.2daygeek.com">2daygeek</a> :- Linux Tips & Tricks, Linux How-to Guides & Tutorials is licensed under a <a href="https://creativecommons.org/licenses/by-nc/4.0/" rel="nofollow">(cc) BY-NC</a></p>
</div>
</div>
<div class="grid one-half last">
<ul class="social-links"><li><a rel="nofollow" class="social-tooltip" title="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Google+" href="https://www.google.com/+2daygeeks" target="_blank" style="color:#ffffff"><i class="fa fa-google-plus"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fa fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fa fa-tumblr"></i></a></li></ul> </div>
</div>
</div>
</section>
</footer>
</div>
<div id="crestashareicon" class="cresta-share-icon sameColors first_style show-count-active"><div class="cresta-the-button"><i class="c-icon-cresta-minus"></i></div><div class="sbutton crestaShadow facebook-cresta-share float" id="facebook-cresta"><a rel="nofollow" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.2daygeek.com%2Fhow-to-check-find-the-process-id-pid-ppid-of-a-running-program-in-linux%2F&amp;t=4+Easiest+Ways+To+Find+Out+Process+ID+%28PID%29+In+Linux" title="Share to Facebook" onclick="window.open(this.href,'targetWindow','toolbars=0,location=0,status=0,menubar=0,scrollbars=1,resizable=1,width=640,height=320,left=200,top=200');return false;"><i class="cs c-icon-cresta-facebook"></i></a></div><div class="sbutton crestaShadow twitter-cresta-share float withCount" id="twitter-cresta"><a rel="nofollow" href="https://twitter.com/share?text=4+Easiest+Ways+To+Find+Out+Process+ID+%28PID%29+In+Linux&amp;url=https%3A%2F%2Fwww.2daygeek.com%2Fhow-to-check-find-the-process-id-pid-ppid-of-a-running-program-in-linux%2F&amp;via=2daygeek" title="Share to Twitter" onclick="window.open(this.href,'targetWindow','toolbars=0,location=0,status=0,menubar=0,scrollbars=1,resizable=1,width=640,height=320,left=200,top=200');return false;"><i class="cs c-icon-cresta-twitter"></i></a></div><div class="sbutton crestaShadow googleplus-cresta-share float" id="googleplus-cresta"><a rel="nofollow" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.2daygeek.com%2Fhow-to-check-find-the-process-id-pid-ppid-of-a-running-program-in-linux%2F" title="Share to Google Plus" onclick="window.open(this.href,'targetWindow','toolbars=0,location=0,status=0,menubar=0,scrollbars=1,resizable=1,width=640,height=320,left=200,top=200');return false;"><i class="cs c-icon-cresta-gplus"></i></a></div><div class="sbutton crestaShadow linkedin-cresta-share float" id="linkedin-cresta"><a rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww.2daygeek.com%2Fhow-to-check-find-the-process-id-pid-ppid-of-a-running-program-in-linux%2F&amp;title=4+Easiest+Ways+To+Find+Out+Process+ID+%28PID%29+In+Linux&amp;source=https://www.2daygeek.com/" title="Share to LinkedIn" onclick="window.open(this.href,'targetWindow','toolbars=0,location=0,status=0,menubar=0,scrollbars=1,resizable=1,width=640,height=320,left=200,top=200');return false;"><i class="cs c-icon-cresta-linkedin"></i></a></div><div class="sbutton crestaShadow pinterest-cresta-share float" id="pinterest-cresta"><a rel="nofollow" href="https://pinterest.com/pin/create/bookmarklet/?url=https%3A%2F%2Fwww.2daygeek.com%2Fhow-to-check-find-the-process-id-pid-ppid-of-a-running-program-in-linux%2F&amp;media=https://www.2daygeek.com/wp-content/uploads/2017/12/how-to-check-find-process-id-pid-ppid-in-linux.png&amp;description=4+Easiest+Ways+To+Find+Out+Process+ID+%28PID%29+In+Linux" title="Share to Pinterest" onclick="window.open(this.href,'targetWindow','toolbars=0,location=0,status=0,menubar=0,scrollbars=1,resizable=1,width=640,height=320,left=200,top=200');return false;"><i class="cs c-icon-cresta-pinterest"></i></a></div><div class="sbutton" id="total-shares"><span class="cresta-the-total-count" id="total-count"><i class="cs c-icon-cresta-spinner animate-spin"></i></span><span class="cresta-the-total-text">Shares</span></div><div style="clear: both;"></div></div>

<div id="spu-bg"></div>
<div id="spu-main"><a href="#" onClick="spuFlush(99);" id="spu-close">Close</a><div id='spu-title'>Please support the site</div>
<div id='spu-msg-cont'>
<div id='spu-msg'>
By clicking any of these buttons you help our site to get better </br>
<div class="spu-button spu-twitter"><a href="https://twitter.com/2daygeek" class="twitter-follow-button" data-show-count="false">Follow Me</a></div> <div class="spu-button spu-facebook"><div id="fb-root"></div><div class="fb-like" data-href="https://www.facebook.com/2daygeek" data-send="false" data-width="450" data-show-faces="true" data-layout="button_count"></div></div> <div class="spu-button spu-google"><div class="g-plusone" data-callback="googleCB" data-onendinteraction="closeGoogle" data-recommendations="false" data-annotation="bubble" data-size="medium" data-href="https://www.google.com/+2daygeeks"></div></div>
</div>
<div class='step-clear'></div>
</div><span id="spu-timer"></span><div id="spu-bottom"></div></div><link rel='stylesheet' id='wp-subscribe-css' href='https://www.2daygeek.com/wp-content/plugins/wp-subscribe/assets/css/wp-subscribe-form.css?ver=4.8.4' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.2daygeek.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var crestaShareSSS = {"FacebookCount":"nope"};
var crestaShareSS = {"LinkedinCount":"0"};
var crestaPermalink = {"thePermalink":"https:\/\/www.2daygeek.com\/how-to-check-find-the-process-id-pid-ppid-of-a-running-program-in-linux\/","themorezero":"yesmore","themorenumber":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/cresta-social-share-counter/js/jquery.cresta-social-share-counter.js?ver=2.7.6'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/cresta-social-share-counter/js/jquery.cresta-social-effect.js?ver=2.7.6'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/wf-cookie-consent/js/cookiechoices.js?ver=4.8.4'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"","extLinksTargetExt":"","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"1","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":true,"mobile":true},"isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_up","mobile":"stick_up"},"isDevMode":"","ajaxUrl":"https:\/\/www.2daygeek.com\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"abc450d20c"},"userStarted":{"with":"with|3.0.11","on":{"date":"2017-08-08 07:25:43.000000","timezone_type":3,"timezone":"UTC"}},"isWelcomeNoteOn":"","welcomeContent":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/scripts.min.js?ver=3.3.20'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/comment-reply.min.js?ver=4.8.4'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?ver=0.6.1'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/lazy-load/js/lazy-load.js?ver=0.6.1'></script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-includes/js/wp-embed.min.js?ver=4.8.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.8.4","language":""},"disqusIdentifier":"15346 https:\/\/www.2daygeek.com\/?p=15346","disqusShortname":"2daygeek","disqusTitle":"4 Easiest Ways To Find Out Process ID (PID) In Linux","disqusUrl":"https:\/\/www.2daygeek.com\/how-to-check-find-the-process-id-pid-ppid-of-a-running-program-in-linux\/","options":{"manualSync":false},"postId":"15346"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.8.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wp_subscribe = {"ajaxurl":"https:\/\/www.2daygeek.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/wp-subscribe/assets/js/wp-subscribe-form.js?ver=4.8.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"2daygeek"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.2daygeek.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.8.4'></script>
<!--[if lt IE 9]>
<script src="https://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/respond.js"></script>
<![endif]-->
<script type="text/javascript">
	window._wfCookieConsentSettings = {"wf_cookietext":"Cookies help us deliver our services. By using our services, you agree to our use of cookies.","wf_dismisstext":"Got it","wf_linktext":"Learn more","wf_linkhref":"https:\/\/www.2daygeek.com\/about-us\/","wf_position":"top","language":"en"};
</script>
</body>
</html>