How To Install GenyMotion (Android Emulator) On Linux

GenyMotion is a Android emulator which comes with per-configured Android (x86 with OpenGL hardware acceleration) images, suitable for application testing.

If you want to run any mobile apps such as WhatsApp in your system you should install the android emulator. Genymotion is the one of best Android Emulator compared to others because genymotion have more and more features.

We have already wrote about Android SDK installation and Whatsapp installation in our previous articles. Now, I’m going to explain how to install genymotion (Android Emulator) in Linux.

How to Install Android Emulator (SDK) on Linux

How to Install WhatsApp on Linux

genymotion Features

  • Resizable windows
  • Screenshots
  • CPU virtualization
  • support latest version of android
  • Custom devices
  • Command line tool
  • Java API
  • Customizable IMEI, MEID, Android ID
  • App installation via drag and drop
  • OpenGL acceleration
  • 20 pre-configured devices

1) Prerequisites for genymotion

Make sure, your system have virtualbox installed before proceeding to genymotion installation because virtualbox is mandatory to run genymotion.

How to Install Virtualbox on Linux

How to Install Virtualbox on ArchLinux/Manjaro

2) Download genymotion

There is no direct download link for genymotion. You need to signup into genymotion then download the file. Currently they are offering image for Ubuntu & Debian but it will work for all the distributions. I have tested with Ubuntu, Fedora & openSUSE.

3) genymotion installation

We already knows, for thirdparty software installation should go to /opt directory. So, first will move the download file from /home/username/download to /opt directory then start installation by following the below steps.

[Move the downloaded file to /opt directory]
# mv genymotion-2.3.1_x64.bin /opt

[Set executable permission]
# chmod +x genymotion-2.3.1_x64.bin

[Install genymotion by running the file]
# ./genymotion-2.3.1_x64.bin

[Navigate into genymotion directory]
# cd genymotion

[launch the genymotion]
# ./genymotion

genymotion-installation-linux-1

4) Add a new device

As of now ,there is no device added into genymotion. So, click Yes to add new device.
genymotion-installation-linux-1

5) Sign into your account

Click Sign_in button and enter your account details then hit Sign in button.
genymotion-installation-linux-2

6) Choose a device

By default genymotion offers 20 pre-configured devices you can choose one or you can configure the custom one. Then hit Next.
genymotion-installation-linux-3

Vinoth Kumar

Vinoth Kumar has 3.5+ years of experience in Linux server administration & RHEL certified professional. He is currently working as a Senior L2 Linux Server administrator.

You may also like...

23 Responses

  1. Surendar M says:

    https://uploads.disquscdn.com/images/9299e29cd985abfc62e21ba2ae0d331b8af8622d83d7731b63119692efaef8db.png when I run ./genymotion I get following error and I installed virtualbox
    ./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8′ not found (required by /home/synerzip/software/genymotion/genymotion/libQt5Core.so.5)
    ./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20′ not found (required by /home/synerzip/software/genymotion/genymotion/libQt5WebKit.so.5)
    ./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8′ not found (required by /home/synerzip/software/genymotion/genymotion/libicui18n.so.52)
    ./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8′ not found (required by /home/synerzip/software/genymotion/genymotion/libicuuc.so.52)
    ./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20′ not found (required by /home/synerzip/software/genymotion/genymotion/libQt5Qml.so.5)

    Mine is Cent 7 please help me on this

  2. Gonzalo Abeiro says:

    I have ubuntu 14.04 32 bit, I thougt it’ll work for it. When I run ./genymotion it says cannot execute binary file: Formato de ejecutable incorrecto.

    Any idea of how can I issue this???

    thanks

  3. Sentosa Liem says:

    why i get this error?
    ./genymotion-2.5.3_x86.bin: line 2: syntax error near unexpected token `newline’
    ./genymotion-2.5.3_x86.bin: line 2: `’
    when i run this, ./genymotion-2.5.3_x86.bin

  4. Yogesh Kamble says:

    when I run ./genymotion I get following error and I installed virtualbox
    ./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8′ not found (required by /home/synerzip/software/genymotion/genymotion/libQt5Core.so.5)
    ./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20′ not found (required by /home/synerzip/software/genymotion/genymotion/libQt5WebKit.so.5)
    ./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8′ not found (required by /home/synerzip/software/genymotion/genymotion/libicui18n.so.52)
    ./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8′ not found (required by /home/synerzip/software/genymotion/genymotion/libicuuc.so.52)
    ./genymotion: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20′ not found (required by /home/synerzip/software/genymotion/genymotion/libQt5Qml.so.5)

    • Tokuibiye Dasetima says:

      Run the following commands to fix this:

      $ LD_LIBRARY_PATH=/usr/local/lib64/:$LD_LIBRARY_PATH

      $ export LD_LIBRARY_PATH

      $ sudo apt-add-repository ppa:ubuntu-toolchain-r/test

      $ sudo apt-get update

      $ sudo apt-get install gcc-4.9 g++-4.9

  5. AGarcia says:

    I moved genymotion-2.6.0-linux_x86.bin to opt directory. But now when i type this command chmod +x genymotion-2.6.0-linux_x86.bin i get this..
    chmod: cannot access ‘genymotion-2.6.0-linux_x86.bin’: No such file or directory

    im new to linux so i have no idea what im doing wrong

    oh and im also running lubuntu not sure if that info will help

  6. Sayalah says:

    Hello 2daygeek do you know why I can’t run Wechat app on genymotion 2.52 with linux mint machine? My virtuaI device is Samsung Galaxy S3 – 43. – API 18 and I manage to install wechat but I can’t run it? I mean I still can fill in my username password but when I enter I will lose the wechat display and go back to my main menu. Can you explain why please.

  7. Mike says:

    This guide was awesome, thanks so much!

  8. Binu Kuriaksoe says:

    I am getting the same error on windows too……….

  9. Binu Kuriaksoe says:

    I am getting the error: genymotion could not open ‘sys/class/power_supply genymotion_fake_path/present’

  10. Binu Kuriaksoe says:

    My OS is 14.04 Ubuntu & Oracle VM succesfully installed

  11. Binu Kuriaksoe says:

    I am getting the message while ./genymotion “bash: ./genymotion: No such file or directory”

  12. chitane says:

    It tells the downloaded package is corrupted after Deploying to the virtual device.

  13. AJI says:

    hello, I can`t run this step ./genymotion in CentOs7?

Leave a Reply

Your email address will not be published. Required fields are marked *