<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-71235901-1', 'auto');
  ga('send', 'pageview');

</script>
<meta name="google-site-verification" content="PuHJs7y90OgOH37jomlyBr-hu1ME7p4zbt8O9C7X8ng"/>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://www.2daygeek.com/xmlrpc.php">
<title>Script - A Simple Command To Record Your Terminal Session Activity | 2daygeek</title>
<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>
 
<link rel="author" href="https://plus.google.com/+2daygeeks"/>
<meta name="description" content="By default everyone prefer history command to review/recall the previously entered commands in terminal but unfortunately, that shows only the commands and"/>
<meta name="keywords" content="script command,record terminal session,save terminal activity,linux"/>
<link rel="canonical" href="http://www.2daygeek.com/script-command-record-save-your-terminal-session-activity-linux/"/>
 
<link rel='dns-prefetch' href='//connect.facebook.net'/>
<link rel='dns-prefetch' href='//platform.twitter.com'/>
<link rel='dns-prefetch' href='//apis.google.com'/>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="2daygeek &raquo; Feed" href="http://www.2daygeek.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="2daygeek &raquo; Comments Feed" href="http://www.2daygeek.com/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="2daygeek &raquo; Script &#8211; A Simple Command To Record Your Terminal Session Activity Comments Feed" href="http://www.2daygeek.com/script-command-record-save-your-terminal-session-activity-linux/feed/"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.2daygeek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='spu-css-css' href='http://www.2daygeek.com/wp-content/plugins/social-popup/spu.css?ver=1.6.4.3' type='text/css' media='all'/>
<link rel='stylesheet' id='font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all'/>
<link rel='stylesheet' id='arconix-shortcodes-css' href='http://www.2daygeek.com/wp-content/plugins/arconix-shortcodes/includes/css/arconix-shortcodes.min.css?ver=2.0.4' type='text/css' media='all'/>
<link rel='stylesheet' id='gglcptch-css' href='http://www.2daygeek.com/wp-content/plugins/google-captcha/css/gglcptch.css?ver=1.30' type='text/css' media='all'/>
<link rel='stylesheet' id='hueman-main-style-css' href='http://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/main.min.css?ver=3.3.2' type='text/css' media='all'/>
<link rel='stylesheet' id='theme-stylesheet-css' href='http://www.2daygeek.com/wp-content/themes/my-child-theme/style.css?ver=3.3.2' type='text/css' media='all'/>
<link rel='stylesheet' id='hueman-font-awesome-css' href='http://www.2daygeek.com/wp-content/themes/hueman/assets/front/css/font-awesome.min.css?ver=3.3.2' type='text/css' media='all'/>
<link rel='stylesheet' id='tablepress-default-css' href='http://www.2daygeek.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.8' type='text/css' media='all'/>
<style id='tablepress-default-inline-css' type='text/css'>.tablepress tbody td{text-align:left!important;padding:.3em .4em!important}.tablepress td{border:2px solid #DDD}</style>
<script type='text/javascript' src='http://www.2daygeek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://connect.facebook.net/en_US/all.js?ver=1.6.4.3#xfbml=1'></script>
<script type='text/javascript' src='http://platform.twitter.com/widgets.js?ver=1.6.4.3'></script>
<script type='text/javascript' src='https://apis.google.com/js/plusone.js?ver=1.6.4.3'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/social-popup/spu.js?ver=1.6.4.3'></script>
<link rel='https://api.w.org/' href='http://www.2daygeek.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.2daygeek.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.2daygeek.com/wp-includes/wlwmanifest.xml"/>
<link rel='prev' title='6 Methods To Check The Running Linux Kernel Version On System' href='http://www.2daygeek.com/check-find-determine-running-installed-linux-kernel-version/'/>
<meta name="generator" content="WordPress 4.7.5"/>
<link rel='shortlink' href='http://www.2daygeek.com/?p=1786'/>
<link rel="alternate" type="application/json+oembed" href="http://www.2daygeek.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.2daygeek.com%2Fscript-command-record-save-your-terminal-session-activity-linux%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.2daygeek.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.2daygeek.com%2Fscript-command-record-save-your-terminal-session-activity-linux%2F&#038;format=xml"/>
<script type="text/javascript" id="ha-customize-btn">
              jQuery( function($) {
                  $( "#wp-admin-bar-customize").find('a').attr('title', 'Customize this page !' );
              });
            </script>
<style type="text/css" id="ha-fun-ab">@-webkit-keyframes super-rainbow{0%{text-shadow:0px 0px 2px;}20%{text-shadow:0px 0px 5px;}40%{text-shadow:0px 0px 10px;}60%{text-shadow:0px 0px 13px}80%{text-shadow:0px 0px 10px;}100%{text-shadow:0px 0px 5px;}}@-moz-keyframes super-rainbow{0%{text-shadow:0px 0px 2px;}20%{text-shadow:0px 0px 5px;}40%{text-shadow:0px 0px 10px;}60%{text-shadow:0px 0px 13px}80%{text-shadow:0px 0px 10px;}100%{text-shadow:0px 0px 5px;}}#wp-admin-bar-customize .ab-item:before{color:#7ECEFD;-webkit-animation:super-rainbow 4s infinite linear;-moz-animation:super-rainbow 4s infinite linear;}</style>
<style type="text/css">.spu-button{margin-left:15px;margin-left:15px;display:inline-table;margin-top:12px;vertical-align:middle;}#spu-msg-cont{border-bottom:1px solid#ccc;border-top:1px solid#ccc;background-image:linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);background-image:-o-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);background-image:-moz-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);background-image:-webkit-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);background-image:-ms-linear-gradient(bottom,#D8E7FC 0%,#EBF2FC 65%);background-image:-webkit-gradient(linear,left bottom,left top,color-stop(0,#D8E7FC),color-stop(0.85,#EBF2FC));padding:16px;}#spu-msg{margin:0 0 22px;}.step-clear{clear:both!important;}#spu-title{font-family:'Lucida Sans Unicode,Lucida Grande,sans-serif!important;
	font-size:12px;
	padding:12px 0 9px 10px;
	font-size:16px;
}					</style>			
					<script type="text/javascript">
						jQuery(document).ready(function($){
								
						setTimeout( 
						function(){				
							socialPopUP({
								// Configure display of popup
								advancedClose: true,
								opacity: "0.65",
								s_to_close: "0",
								days_no_click: "99",
								segundos : "seconds",
								esperar : "Wait",
								thanks_msg : "Thanks for supporting our site!!!",
								thanks_sec : "3",
							})
						}
							,1000								);
						});	
						
						
					</script>
					
	<!--[if lt IE 9]>
<script src="http://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js"></script>
<script src="http://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js"></script>
<![endif]-->
<style type="text/css">
/* Dynamic CSS: For no styles in head, copy and put the css below in your child theme' s style.css,disable dynamic styles */

.search-expand,
#nav-topbar.nav-container { background-color: #3b8dbd; }@media only screen and (min-width: 720px) {#nav-topbar .nav ul{background-color:#3b8dbd;}}#nav-header.nav-container{background-color:#fa720e;}@media only screen and (min-width: 720px) {#nav-header .nav ul{background-color:#fa720e;}}img{-webkit-border-radius:2px;border-radius:2px;}body{background-color:#eaeaea;}</style>
</head>
<body class="post-template-default single single-post postid-1786 single-format-standard wp-custom-logo col-2cl full-width topbar-enabled unknown">
<div id="wrapper">
<header id="header">
<nav class="nav-container group" id="nav-topbar">
<div class="nav-toggle"><i class="fa fa-bars"></i></div>
<div class="nav-text"> </div>
<div class="nav-wrap container"><ul id="menu-menu-1" class="nav container-inner group"><li id="menu-item-293" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-293"><a href="http://www.2daygeek.com/">HOME</a></li>
<li id="menu-item-10920" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10920"><a href="http://linuxnews.2daygeek.com/">LINUX NEWS</a></li>
<li id="menu-item-294" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-294"><a href="http://www.2daygeek.com/about-us/">ABOUT US</a></li>
<li id="menu-item-295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-295"><a href="http://www.2daygeek.com/contact-us/">CONTACT US</a></li>
<li id="menu-item-296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-296"><a href="http://www.2daygeek.com/disclaimer/">DISCLAIMER</a></li>
<li id="menu-item-3676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3676"><a href="http://www.2daygeek.com/privacy-policy/">PRIVACY POLICY</a></li>
<li id="menu-item-2729" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2729"><a href="http://www.2daygeek.com/support-us/">SUPPORT US</a></li>
<li id="menu-item-8366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8366"><a href="http://www.2daygeek.com/category/os-tweaks/">OS TWEAK</a></li>
<li id="menu-item-12012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12012"><a href="http://www.2daygeek.com/category/icon-theme/">ICONS</a></li>
<li id="menu-item-12013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12013"><a href="http://www.2daygeek.com/category/gtk-theme/">THEMES</a></li>
</ul></div>
<div class="container">
<div class="container-inner">
<div class="toggle-search"><i class="fa fa-search"></i></div>
<div class="search-expand">
<div class="search-expand-inner">
<form method="get" class="searchform themeform" action="http://www.2daygeek.com/">
<div>
<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter"/>
</div>
</form> </div>
</div>
</div> 
</div> 
</nav>  <div class="container group">
<div class="container-inner">
<div class="group pad">
<p class="site-title"><a class="custom-logo-link" href="http://www.2daygeek.com/" rel="home"><img src="http://www.2daygeek.com/wp-content/uploads/2015/12/2day-geek-new-logo-final.png" alt="2daygeek"></a></p>
<p class="site-description"></p>
<div id="header-widgets">
<div style="float:left;border:solid 0px;height:60px;width:468px;">
<script id="mNCC" language="javascript">  medianet_width='468';  medianet_height= '60';  medianet_crid='328488081';  </script> <script id="mNSC" src="http://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script></div>
</div> 
</div>
<nav class="nav-container group" id="nav-header">
<div class="nav-toggle"><i class="fa fa-bars"></i></div>
<div class="nav-text"> </div>
<div class="nav-wrap container">
<ul id="menu-menu-2" class="nav container-inner group"><li id="menu-item-6808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6808"><a href="http://www.2daygeek.com/category/linux-distributions/">LINUX DISTRO&#8217;S</a></li>
<li id="menu-item-6806" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6806"><a href="http://www.2daygeek.com/category/linux-commands/">LINUX COMMAND&#8217;S</a></li>
<li id="menu-item-9582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9582"><a href="http://www.2daygeek.com/category/webserver/">WEBSERVER</a></li>
<li id="menu-item-6809" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6809"><a href="http://www.2daygeek.com/category/monitoring-tools/">MONITORING TOOLS</a></li>
<li id="menu-item-6883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6883"><a href="http://www.2daygeek.com/category/package-management/">PACKAGE MANAGEMENT</a></li>
<li id="menu-item-6811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6811"><a href="http://www.2daygeek.com/category/repository/">REPOSITORY</a></li>
<li id="menu-item-6986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6986"><a href="http://www.2daygeek.com/category/free-cloud-storage/">FREE CLOUD STORAGE</a></li>
<li id="menu-item-6810" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6810"><a href="http://www.2daygeek.com/category/owncloud/">OWNCLOUD</a></li>
</ul> </div>
</nav> 
</div> 
</div> 
</header> 
<div class="container" id="page">
<div class="container-inner">
<div class="main">
<div class="main-inner group">
<section class="content">
<div class="page-title pad group">
<ul class="meta-single group">
<li class="category"><a href="http://www.2daygeek.com/category/ssh-tutorials/" rel="category tag">ssh-tutorials</a></li>
</ul>
</div> 
<div class="pad group">
<article class="post-1786 post type-post status-publish format-standard has-post-thumbnail hentry category-ssh-tutorials tag-linux tag-record-terminal-session tag-save-terminal-activity tag-script-command">
<div class="post-inner group">
<h1 class="post-title entry-title">Script &#8211; A Simple Command To Record Your Terminal Session Activity</h1>
<p class="post-byline">by <span class="vcard author">
<span class="fn"><a href="http://www.2daygeek.com/author/magesh/" title="Posts by Magesh Maruthamuthu" rel="author">Magesh Maruthamuthu</a></span>
</span> &middot;
<span class="published">Published : July 11, 2017 || Last Updated: July 11, 2017</span>
</p>
<div class="clear"></div>
<div class="entry themeform">
<div class="entry-inner">
 
<div style="float:left;margin:10px 10px 10px 0;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="8826511175"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="3265433976"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>By default everyone prefer history command to review/recall the previously entered commands in terminal but unfortunately, that shows only the commands and doesn&#8217;t shows the commands output which was performed previously.</p>
<p>There are many utilities available in GUI to record the terminal session activity but very few applications are available for CLI and script is one of the best utility to record your terminal session on headless server.</p>
<p>It&#8217;s a best practices to record your terminal activity and keep it safe for further reference, even if you want to know the output of your command later sometime to investigate on this, it might help you.</p>
<h4>What&#8217;s Script?</h4>
<p> Script is a Unix command line utility that records a terminal session (in other terms, It&#8217;s record everything displayed on your terminal). It stores the output in the current directory as a text file and the default file name is typescript.</p>
<p>Script is one of the Linux core utility and by default pre-installed in most of the Linux distributions. The script command is part of the util-linux-ng package.</p>
<h4>How To Check Whether Scrip Command Installed Or Not?</h4>
<p> The script command is part of the util-linux-ng package, so grep this package to confirm whether the script command installed or not in system.</p>
<p>For RPM based systems</p>
<pre>
$ yum list installed | grep util-linux-ng
util-linux-ng.x86_64                              2.17.2-12.14.el6     @base
</pre>
<p>For DEB based systems</p>
<pre>
$ apt-cache policy util-linux
util-linux:
  Installed: 2.28.2-1ubuntu1.1
  Candidate: 2.28.2-1ubuntu1.2
  Version table:
     2.28.2-1ubuntu1.2 500
        500 http://in.archive.ubuntu.com/ubuntu yakkety-updates/main amd64 Packages
 *** 2.28.2-1ubuntu1.1 100
        100 /var/lib/dpkg/status
     2.28.2-1ubuntu1 500
        500 http://in.archive.ubuntu.com/ubuntu yakkety/main amd64 Packages
</pre>
<h4>How To Use Script Command</h4>
<p> Just type <code>script</code> command on terminal before start working, instantly it will start record the current terminal activity, once you have done the work, finally type <code>exit</code> to complete the current recording.</p>
<p>To initiate the recording, just type <code>script</code> command on terminal and you will get a message like below.</p>
<pre>
$ script
Script started, file is typescript
</pre>
<p>Let&#8217;s run few commands on terminal to check this experiment.</p>
<pre>
$ w
</pre>
<pre>
$ lsb_release -a
</pre>
<pre>
$ last
</pre>
<pre>
$ uname -a
</pre>
<pre>
$ pwd
</pre>
<pre>
$ free -m
</pre>
<pre>
$ speedtest-cli
</pre>
<p>Finally exit the script by inputting the <code>exit</code> command on terminal.</p>
<pre>
$ exit
exit
Script done, file is typescript
</pre>
<h4>Check Script Command Output</h4>
<p> We have successfully exit the script command, after executing few commands for this experiment. Now, we are going to print the script command output (The default output file name is typescript) with help of cat command.</p>
 
<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7730570141079407" data-ad-slot="6977341179" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<pre>
$ cat typescript 
Script started on Tuesday 04 July 2017 08:37:34 AM IST
<a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="e48985838da48985838d">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script>:~$ <strong><span style="color:#25c5fa">w</span></strong>
 08:37:45 up 1 day, 48 min,  1 user,  load average: 0.51, 0.27, 0.22
USER     TTY      FROM             LOGIN@   IDLE   JCPU   PCPU WHAT
magi     tty7     :0               Mon07   24:48m 21:15  17.25s /sbin/upstart --user
<a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="a0cdc1c7c9e0cdc1c7c9">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script>:~$ <strong><span style="color:#25c5fa">lsb_release -a</span></strong>
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 16.10
Release:	16.10
Codename:	yakkety
<a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="3e535f59577e535f5957">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script>:~$ <strong><span style="color:#25c5fa">last</span></strong>

wtmp begins Mon Jul  3 07:54:43 2017
<a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="2845494f416845494f41">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script>:~$ <strong><span style="color:#25c5fa">uname -a</span></strong>
Linux daygeek 4.10.1-041001-generic #201702260735 SMP Sun Feb 26 12:36:48 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
<a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="fc919d9b95bc919d9b95">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script>:~$ <strong><span style="color:#25c5fa">pwd</span></strong>
/home/magi
<a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="4b262a2c220b262a2c22">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script>:~$ <strong><span style="color:#25c5fa">df -h</span></strong>
Filesystem      Size  Used Avail Use% Mounted on
udev            979M     0  979M   0% /dev
tmpfs           200M   17M  184M   9% /run
/dev/sda1        38G   16G   20G  45% /
tmpfs           999M  152K  999M   1% /dev/shm
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           999M     0  999M   0% /sys/fs/cgroup
tmpfs           200M  120K  200M   1% /run/user/1000
<a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="c4a9a5a3ad84a9a5a3ad">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script>:~$ <strong><span style="color:#25c5fa">free -m</span></strong>
              total        used        free      shared  buff/cache   available
Mem:           1997        1585          87          22         325         246
Swap:          2045         972        1073
<a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="2b464a4c426b464a4c42">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script>:~$ <strong><span style="color:#25c5fa">speedtest-cli</span></strong>
Retrieving speedtest.net configuration...
Testing from BBNL (103.5.134.167)...
Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by E-Infrastructure & Entertainment India Pvt. Ltd (Bangalore) [27.56 km]: 9.772 ms
Testing download speed................................................................................
Download: 9.96 Mbit/s
Testing upload speed................................................................................................
Upload: 10.26 Mbit/s
<a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="1a777b7d735a777b7d73">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script>:~$ <strong><span style="color:#25c5fa">exit</span></strong>
exit

Script done on Tuesday 04 July 2017 08:41:48 AM IST
</pre>
<h4>Add A Custom Filename To Script Output</h4>
<p> By default the script command save the output in the name of <code>typescript</code>. You can add a custom file name by passing a file name followed by script command, retaining the prior contents. In my case, i have input a file name called <code>2g-terminal.txt</code>, you can change the filename as per your wish.</p>
<pre>
$ script 2g-terminal.txt
Script started, file is 2g-terminal.txt
</pre>
<h4>Append The Output To File</h4>
<p> This will overwrite the output file, when you run the script command again. To append the output to file, use <code>-a</code> option followed by the filename.</p>
<pre>
$ script -a 2g-terminal.txt
Script started, file is 2g-terminal.txt
</pre>
<h4>Store A Single Command Output</h4>
<p> To store a single command output instead of an interactive shell session, use the <code>-c</code> option with script command. Say for example, Lynis – Security Auditing tool has 1000+ lines output, so this option very helpful for such kind of requirement.</p>
<pre>
$ script -c 'whoami' magi-terminal.txt
Script started, file is magi-terminal.txt
magi
Script done, file is magi-terminal.txt
</pre>
<h4>Run The Script Command On Quit Mode</h4>
<p> Use <code>-q</code> option with script command to avoid script started and script done message on terminal while run the script command.</p>
<pre>
$ script -c 'whoami' -q magi-terminal.txt
magi
</pre>
<h4>Script Man Page</h4>
 
<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script id="mNCC" language="javascript">
   medianet_width = "728";
   medianet_height = "90";
   medianet_crid = "847533357";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUF666N9' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div>
<p> To know other options and purpose, nagivate to script command man page.</p>
<pre>
$ man script
or
$ script --help
</pre>
 
<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script id="mNCC" language="javascript">  medianet_width='728';  medianet_height= '90';  medianet_crid='827143833';  </script> <script id="mNSC" src="http://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script>
</div>
<div style="font-size:0px;height:0px;line-height:0px;margin:0;padding:0;clear:both"></div> <nav class="pagination group">
</nav> 
</div>
<div class="clear"></div>
</div> 
</div> 
</article> 
<div class="clear"></div>
<p class="post-tags"><span>Tags:</span> <a href="http://www.2daygeek.com/tag/linux/" rel="tag">Linux</a><a href="http://www.2daygeek.com/tag/record-terminal-session/" rel="tag">Record Terminal Session</a><a href="http://www.2daygeek.com/tag/save-terminal-activity/" rel="tag">Save Terminal Activity</a><a href="http://www.2daygeek.com/tag/script-command/" rel="tag">Script Command</a></p>
<div class="author-bio">
<div class="bio-avatar"><img src="http://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://1.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=128&#038;d=mm&#038;r=g" alt srcset="http://1.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=256&amp;d=mm&amp;r=g 2x" class="avatar avatar-128 photo" height="128" width="128"><noscript><img alt='' src='http://1.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=128&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/d487bef1de15143a7b80a40396e96118?s=256&amp;d=mm&amp;r=g 2x' class='avatar avatar-128 photo' height='128' width='128'/></noscript></div>
<p class="bio-name">Magesh Maruthamuthu</p>
<p class="bio-desc">Love to play with all Linux distribution</p>
<div class="clear"></div>
</div>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-7730570141079407" data-ad-slot="9495141575"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<ul class="post-nav group">
<li class="next"></li>
<li class="previous"><a href="http://www.2daygeek.com/check-find-determine-running-installed-linux-kernel-version/" rel="prev"><i class="fa fa-chevron-left"></i><strong>Previous story</strong> <span>6 Methods To Check The Running Linux Kernel Version On System</span></a></li>
</ul>
<h4 class="heading">
<i class="fa fa-hand-o-right"></i>You may also like...</h4>
<ul class="related-posts group">
<li class="related post-hover">
<article class="post-788 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-tutorials category-ssh-tutorials tag-disconnect-idle-ssh-sessions tag-kill-idle-linux-users tag-kill-idle-ssh-sessions tag-kill-inactive-ssh-session tag-kill-unresponsive-ssh-session">
<div class="post-thumbnail">
<a href="http://www.2daygeek.com/kill-inactive-idle-ssh-sessions/" title="How To kill An Inactive OR Idle SSH Sessions">
<img src="http://www.2daygeek.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://www.2daygeek.com/wp-content/uploads/2017/04/kill-inactive-idle-ssh-sessions-1a-520x245.png" width="520" height="245" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt srcset="http://www.2daygeek.com/wp-content/uploads/2017/04/kill-inactive-idle-ssh-sessions-1a-520x245.png 520w, http://www.2daygeek.com/wp-content/uploads/2017/04/kill-inactive-idle-ssh-sessions-1a-720x340.png 720w" sizes="(max-width: 520px) 100vw, 520px"><noscript><img width="520" height="245" src="http://www.2daygeek.com/wp-content/uploads/2017/04/kill-inactive-idle-ssh-sessions-1a-520x245.png" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" srcset="http://www.2daygeek.com/wp-content/uploads/2017/04/kill-inactive-idle-ssh-sessions-1a-520x245.png 520w, http://www.2daygeek.com/wp-content/uploads/2017/04/kill-inactive-idle-ssh-sessions-1a-720x340.png 720w" sizes="(max-width: 520px) 100vw, 520px"/></noscript> </a>
</div> 
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="http://www.2daygeek.com/kill-inactive-idle-ssh-sessions/" rel="bookmark" title="How To kill An Inactive OR Idle SSH Sessions">How To kill An Inactive OR Idle SSH Sessions</a>
</h4> 
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2017-06-21 00:05:08">June 21, 2017</time>
</p>
</div> 
</div> 
</article>
</li> 
<li class="related post-hover">
<article class="post-861 post type-post status-publish format-standard hentry category-linux-tutorials category-ssh-tutorials tag-bash tag-email-alerts tag-login-alerts tag-root-ssh-login-alerts tag-security tag-ssh-login-alerts tag-user-login-alerts">
<div class="post-thumbnail">
<a href="http://www.2daygeek.com/setup-enable-ssh-login-email-alerts-root-user-linux/" title="How To Setup/Enable SSH Login Email Alerts For Root User In Linux">
<svg class="hu-svg-placeholder thumb-medium-empty" id="5965b825bfc90" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M928 832q0-14-9-23t-23-9q-66 0-113 47t-47 113q0 14 9 23t23 9 23-9 9-23q0-40 28-68t68-28q14 0 23-9t9-23zm224 130q0 106-75 181t-181 75-181-75-75-181 75-181 181-75 181 75 75 181zm-1024 574h1536v-128h-1536v128zm1152-574q0-159-112.5-271.5t-271.5-112.5-271.5 112.5-112.5 271.5 112.5 271.5 271.5 112.5 271.5-112.5 112.5-271.5zm-1024-642h384v-128h-384v128zm-128 192h1536v-256h-828l-64 128h-644v128zm1664-256v1280q0 53-37.5 90.5t-90.5 37.5h-1536q-53 0-90.5-37.5t-37.5-90.5v-1280q0-53 37.5-90.5t90.5-37.5h1536q53 0 90.5 37.5t37.5 90.5z"/></svg>
<script type="text/javascript">
          jQuery( function($){
            if ( $('#flexslider-featured').length ) {
              $('#flexslider-featured').on('featured-slider-ready', function() {
                $( '#5965b825bfc90' ).animateSvg();
              });
            } else { $( '#5965b825bfc90' ).animateSvg( { svg_opacity : 0.3, filter_opacity : 0.5 } ); }
          });
        </script>
<img class="hu-img-placeholder" src="http://www.2daygeek.com/wp-content/themes/hueman/assets/front/img/thumb-medium-empty.png" alt="How To Setup/Enable SSH Login Email Alerts For Root User In Linux" data-hu-post-id="5965b825bfc90"/> </a>
</div> 
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="http://www.2daygeek.com/setup-enable-ssh-login-email-alerts-root-user-linux/" rel="bookmark" title="How To Setup/Enable SSH Login Email Alerts For Root User In Linux">How To Setup/Enable SSH Login Email Alerts For Root User In Linux</a>
</h4> 
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2013-11-25 15:45:08">November 25, 2013</time>
</p>
</div> 
</div> 
</article>
</li> 
<li class="related post-hover">
<article class="post-779 post type-post status-publish format-standard hentry category-linux-tutorials category-ssh-tutorials tag-disable-ssh-root-login tag-enable-su-user tag-how-to-enable-su-user-on-linux tag-how-to-give-a-linux-user-sudo-access tag-permit-via-su-user-in-linux">
<div class="post-thumbnail">
<a href="http://www.2daygeek.com/disable-ssh-root-login-and-permit-via-su-user-in-linux/" title="Disable SSH Root Login and Permit via &#8220;su&#8221; user in Linux">
<svg class="hu-svg-placeholder thumb-medium-empty" id="5965b825c1852" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M928 832q0-14-9-23t-23-9q-66 0-113 47t-47 113q0 14 9 23t23 9 23-9 9-23q0-40 28-68t68-28q14 0 23-9t9-23zm224 130q0 106-75 181t-181 75-181-75-75-181 75-181 181-75 181 75 75 181zm-1024 574h1536v-128h-1536v128zm1152-574q0-159-112.5-271.5t-271.5-112.5-271.5 112.5-112.5 271.5 112.5 271.5 271.5 112.5 271.5-112.5 112.5-271.5zm-1024-642h384v-128h-384v128zm-128 192h1536v-256h-828l-64 128h-644v128zm1664-256v1280q0 53-37.5 90.5t-90.5 37.5h-1536q-53 0-90.5-37.5t-37.5-90.5v-1280q0-53 37.5-90.5t90.5-37.5h1536q53 0 90.5 37.5t37.5 90.5z"/></svg>
<script type="text/javascript">
          jQuery( function($){
            if ( $('#flexslider-featured').length ) {
              $('#flexslider-featured').on('featured-slider-ready', function() {
                $( '#5965b825c1852' ).animateSvg();
              });
            } else { $( '#5965b825c1852' ).animateSvg( { svg_opacity : 0.3, filter_opacity : 0.5 } ); }
          });
        </script>
<img class="hu-img-placeholder" src="http://www.2daygeek.com/wp-content/themes/hueman/assets/front/img/thumb-medium-empty.png" alt="Disable SSH Root Login and Permit via &#8220;su&#8221; user in Linux" data-hu-post-id="5965b825c1852"/> </a>
</div> 
<div class="related-inner">
<h4 class="post-title entry-title">
<a href="http://www.2daygeek.com/disable-ssh-root-login-and-permit-via-su-user-in-linux/" rel="bookmark" title="Disable SSH Root Login and Permit via &#8220;su&#8221; user in Linux">Disable SSH Root Login and Permit via &#8220;su&#8221; user in Linux</a>
</h4> 
<div class="post-meta group">
<p class="post-date">
<time class="published updated" datetime="2013-11-16 16:36:03">November 16, 2013</time>
</p>
</div> 
</div> 
</article>
</li> 
</ul> 
<div id="disqus_thread">
<div id="dsq-content">
<ul id="dsq-comments">
<li class="comment even thread-even depth-1" id="dsq-comment-13491">
<div id="dsq-comment-header-13491" class="dsq-comment-header">
<cite id="dsq-cite-13491">
<span id="dsq-author-user-13491">Dan Stromberg</span>
</cite>
</div>
<div id="dsq-comment-body-13491" class="dsq-comment-body">
<div id="dsq-comment-message-13491" class="dsq-comment-message"><p>FWIW, I reimplemented script(1) in python: <a href="http://stromberg.dnsalias.org/~strombrg/pypty/" rel="nofollow">http://stromberg.dnsalias.org/~strombrg/pypty/</a><br/>
It also includes a script-replay program that allows you to go forward and backward in a typescript.</p>
</div>
</div>
</li> 
</ul>
</div>
</div>
</div> 
</section> 
<div class="sidebar s1">
<a class="sidebar-toggle" title="Expand Sidebar"><i class="fa icon-sidebar-toggle"></i></a>
<div class="sidebar-content">
<div class="sidebar-top group">
<p>Follow:</p>
<ul class="social-links"><li><a rel="nofollow" class="social-tooltip" title="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Google+" href="https://www.google.com/+2daygeeks" target="_blank" style="color:#ffffff"><i class="fa fa-google-plus"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fa fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fa fa-tumblr"></i></a></li></ul> </div>
<div id="text-8" class="widget widget_text"><h3 class="widget-title">&#8211; Click Here To Get Offers &#8211;</h3> <div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-7730570141079407" data-ad-slot="7612209571"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div><div id="text-10" class="widget widget_text"><h3 class="widget-title">&#8211; For Better Offers &#8211;</h3> <div class="textwidget"><script id="mNCC" language="javascript">  medianet_width='300';  medianet_height= '250';  medianet_crid='108135239';  </script> <script id="mNSC" src="http://contextual.media.net/nmedianet.js?cid=8CUF666N9" language="javascript"></script></div>
</div><div id="text-12" class="widget widget_text"><h3 class="widget-title">-Unmatched Offers For Linux Users-</h3> <div class="textwidget"></div>
</div> <div id="wp_subscribe-3" class="widget wp_subscribe">
<style>#wp-subscribe.wp-subscribe-1{background:}#wp-subscribe.wp-subscribe-1 h4{color:}#wp-subscribe.wp-subscribe-1 p{color:}#wp-subscribe.wp-subscribe-1 .regular-text{background:;color:}#wp-subscribe.wp-subscribe-1 .submit{background:;color:}#wp-subscribe.wp-subscribe-1 .thanks{color:;display:none}#wp-subscribe.wp-subscribe-1 .error{color:;display:none}#wp-subscribe.wp-subscribe-1 .footer-text{color:}</style>
<div id="wp-subscribe" class="wp-subscribe-wrap wp-subscribe wp-subscribe-1" data-thanks_page="0" data-thanks_page_url="" data-thanks_page_new_window="0">
<h4 class="title">Get Latest LINUX Tips</h4>
<p class="text"></p>
<form action="https://feedburner.google.com/fb/a/mailverify?uri=2daygeekfeed" method="post" class="wp-subscribe-form wp-subscribe-feedburner" id="wp-subscribe-form-1" target="popupwindow">
<input class="regular-text email-field" type="text" name="email" placeholder="Enter your email here">
<input type="hidden" name="uri" value="2daygeekfeed">
<input type="hidden" name="loc" value="en_US">
<input type="hidden" name="form_type" value="widget">
<input type="hidden" name="service" value="feedburner">
<input type="hidden" name="widget" value="wp_subscribe-3">
<input class="submit" type="submit" name="submit" value="Sign Up Now">
</form>
<div class="wp-subscribe-loader">
<svg version="1.1" id="loader-1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0" y="0" width="40px" height="40px" viewBox="0 0 50 50" style="enable-background:new 0 0 50 50;" xml:space="preserve">
<path fill="" d="M43.935,25.145c0-10.318-8.364-18.683-18.683-18.683c-10.318,0-18.683,8.365-18.683,18.683h4.068c0-8.071,6.543-14.615,14.615-14.615c8.072,0,14.615,6.543,14.615,14.615H43.935z">
<animateTransform attributeType="xml" attributeName="transform" type="rotate" from="0 25 25" to="360 25 25" dur="0.6s" repeatCount="indefinite"/>
</path>
</svg>
</div>
<p class="thanks">Thank you for subscribing.</p>
<p class="error">Something went wrong.</p>
<div class="clear"></div>
<p class="footer-text"></p>
</div>
</div>
<div id="text-3" class="widget widget_text"> <div class="textwidget"><script>
  (function() {
    var cx = '014898341766687711766:ajz3putspfm';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//www.google.com/cse/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only></div>
</div><div id="text-6" class="widget widget_text"> <div class="textwidget"><div id="google_translate_element"></div><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script></div>
</div><div id="text-5" class="widget widget_text"><h3 class="widget-title">Follow us</h3> <div class="textwidget"> 
<div class="g-page" data-href="//plus.google.com/107364365185869631781" data-layout="landscape" data-rel="publisher"></div>
 
<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/platform.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></div>
</div>
</div> 
</div> 
</div> 
</div> 
</div> 
</div> 
<footer id="footer">
<section class="container" id="footer-bottom">
<div class="container-inner">
<a id="back-to-top" href="#"><i class="fa fa-angle-up"></i></a>
<div class="pad group">
<div class="grid one-half">
<div id="copyright">
<p>2daygeek &copy; 2017. All Rights Reserved.</p>
</div> 
<div id="credit" style="">
<p><a href="http://www.2daygeek.com">2daygeek</a> :- Linux Tips & Tricks, Linux How-to Guides & Tutorials is licensed under a <a href="http://creativecommons.org/licenses/by-nc/4.0/" rel="nofollow">(cc) BY-NC</a></p>
</div> 
</div>
<div class="grid one-half last">
<ul class="social-links"><li><a rel="nofollow" class="social-tooltip" title="Facebook" href="https://www.facebook.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Twitter" href="https://www.twitter.com/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Google+" href="https://www.google.com/+2daygeeks" target="_blank" style="color:#ffffff"><i class="fa fa-google-plus"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Linkein" href="https://www.linkedin.com/company/2daygeek" target="_blank" style="color:#ffffff"><i class="fa fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Pinterest" href="javascript:void(0)" target="_blank" style="color:#ffffff"><i class="fa fa-pinterest"></i></a></li><li><a rel="nofollow" class="social-tooltip" title="Tumblr" href="http://2daygeek.tumblr.com/" target="_blank" style="color:#ffffff"><i class="fa fa-tumblr"></i></a></li></ul> </div>
</div> 
</div> 
</section> 
</footer> 
</div> 
<div id="spu-bg"></div>
<div id="spu-main"><a href="#" onClick="spuFlush(99);" id="spu-close">Close</a><div id='spu-title'>Please support the site</div>
<div id='spu-msg-cont'>
<div id='spu-msg'>
By clicking any of these buttons you help our site to get better </br>
<div class="spu-button spu-twitter"><a href="https://twitter.com/2daygeek" class="twitter-follow-button" data-show-count="false">Follow Me</a></div> <div class="spu-button spu-facebook"><div id="fb-root"></div><div class="fb-like" data-href="https://www.facebook.com/2daygeek" data-send="false" data-width="450" data-show-faces="true"data-layout="button_count"></div></div> <div class="spu-button spu-google"><div class="g-plusone" data-callback="googleCB" data-onendinteraction="closeGoogle" data-recommendations="false" data-annotation="bubble" data-size="medium" data-href="https://www.google.com/+2daygeeks"></div></div>
     </div>
    <div class='step-clear'></div>
</div><span id="spu-timer"></span><div id="spu-bottom"></div></div><link rel='stylesheet' id='wp-subscribe-css'  href='http://www.2daygeek.com/wp-content/plugins/wp-subscribe/assets/css/wp-subscribe-form.css?ver=4.7.5' type='text/css' media='all' />
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/hueman-addons/addons/assets/front/js/jQuerySharrre.min.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/wf-cookie-consent/js/cookiechoices.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":null,"extLinksTargetExt":null,"extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":null,"imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","vivusSvgSpeed":"300","isDevMode":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/scripts.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-includes/js/comment-reply.min.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?ver=0.6.1'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/lazy-load/js/lazy-load.js?ver=0.6.1'></script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.7.5","language":""},"disqusIdentifier":"1786 http:\/\/www.2daygeek.com\/?p=1786","disqusShortname":"2daygeek","disqusTitle":"Script \u2013 A Simple Command To Record Your Terminal Session Activity","disqusUrl":"http:\/\/www.2daygeek.com\/script-command-record-save-your-terminal-session-activity-linux\/","options":{"manualSync":false},"postId":"1786"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.7.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wp_subscribe = {"ajaxurl":"http:\/\/www.2daygeek.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/wp-subscribe/assets/js/wp-subscribe-form.js?ver=4.7.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"2daygeek"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.2daygeek.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.7.5'></script>
<!--[if lt IE 9]>
<script src="http://www.2daygeek.com/wp-content/themes/hueman/assets/front/js/ie/respond.js"></script>
<![endif]-->
<script type="text/javascript">
	window._wfCookieConsentSettings = {"wf_cookietext":"Cookies help us deliver our services. By using our services, you agree to our use of cookies.","wf_dismisstext":"Got it","wf_linktext":"Learn more","wf_linkhref":"http:\/\/www.2daygeek.com\/about-us\/","wf_position":"top","language":"en"};
</script>
</body>
</html>
